Unknown Error Code 100

Okay, sorry I have nothing else. Just FYI, a "partial update" scenario exists when a user updates only some of the packages that are in need of updating. Or, what's more likely, installs an up-to-date application or system component (qt5-base, say) without the benefit of updating everything else necessary. That's where/when breakage will occur along with a variety of system instabilities.

So, at least you get something outta this thread.

"A little knowledge is a dangerous thing.
Go to school, get a little knowledge.
Live dangerously."
~from the film, "Lord, Love a Duck" circa 1964/5

2 Likes

More detail needed.

Indicates it's not on your $PATH, check on the Lutris or "Mod Organizer 2" forums.

No, you're supposed to be patient and expect people won't read every thread on the forum within a short timescale. If you want a 24-hour-response SLA then there are people who you can pay.

2 Likes

I downgraded to the version prior to 5.15.2+kde+r203-1 via sudo downgrade qt5-base in this case 5.15.2+kde+r200

1 Like

Creating your own code to run on Python programming and setting it to execute so that it would be a functioning, executable file that world work without issue because my now, I did recheck the code so many times and still got the same error.

It is on my path, but let me rest a bit before I get that to you.

So, if you have a basic "Hello world" Python script and run it from a terminal, what happens?

If I do the "Hello world" Python Script, the same error as I said appears.

My $PATH leads to one location being ~/.local/bin, which does hold the modorganizer2-nxm-broker.sh with in it.

Can you please post the script, your terminal commands, and the output (as text, not as screenshots).

2 Likes

Certainly you did something terrible in past. My advice would be to reinstall, if possible. It will be the most time saving and easy workaround

2 Likes

Or, he's trying to run a Python script directly without a shebang. "More details needed."

3 Likes

I've done tons of terrible things in the past... and yet, I can still execute Python scripts. :rofl:

Perhaps reset the permissions on your home directory, on the off chance running as root created a problem.

4 Likes

It is the "," problem :rofl: ?

3 Likes

The code I used was
print("Hello World!")

That may be for the best, but I wish to understand how it went wrong before I do, and if I can't, I'll do that anyways.

2 Likes

There is absolutely no information in the screenshot you provided that indicates how you are running the file.

However, Python files need to be executed by a Python interpreter, which is normally achieved with e.g.

python /path/to/script.py

If you're trying to run it directly as a shell script then the script file would need to contain e.g.

#!/usr/bin/python

print("This might actually work");

and then you can use e.g.

chmod u+x script.py
./script.py

None of this is related to KDE - it's all just "user error".

7 Likes

I see, yeah... I'm going to shulk for forgetting such a thing...
Thanks for the help through my stupidity.

1 Like

It's not stupidity, it's just missing knowledge. Completely different things.

3 Likes

Thank the Lord for small mercies, I was expecting this "Error Code 100" thread to go on for 100 posts. At least it did have a little comedic value. :rofl:

Lucky for you @jonathon was there to catch your omission. Nice job Jon. :+1:

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.