Unable to satisfy dependency 'libcap=2.52' required by lib32-libcap

Hello guys, So i am new to linux. I have only used zorin os for 3 months and recently shifted to garuda linux(dragonised) for a month. It was all working fine and smooth until yesterday, I decided to play portal, and while installing dependencies , I found out that i bymistakenly installed vulkan dependencies for AMD instead of intel. So i thought of trying timeshift to go back to previous version and did that but now whenever im trying to install or update package it doesnt work it give this error

unable to satisfy dependency 'libcap=2.52' required by lib32-libcap

I used both

sudo pamac update

and

sudo pacman -Syyu

Im also getting this while pamac update

cp: cannot stat '/tmp/pamac/dbs/sync/*': No such file or directory

I have tried manually installing libcap 2.52 through pacman but it gives this error

sudo pacman -S libcap 2.52-1
warning: libcap-2.51-1 is up to date -- reinstalling
error: target not found: 2.52-1

Hmm...perhaps a partially updated mirror?

I would try re-sorting your mirrors from Garuda Assistant and updating again.

You can't just add a version like that. That isn't how pacman works. There should only be one version of each package in the repos.

2 Likes

Forum search come up with anything? I'd swear I've seen this same error message in here before.

regards

1 Like

Tried that but still gives the same error, I think ill have to fresh install it again.

Warning: Building packages as root
Warning: Setting build directory to /var/cache/pamac
Preparing...
Cloning protonvpn build files...
Running as unit: run-u345.service
Finished with result: success
Main processes terminated with: code=exited/status=0
Service runtime: 670ms
CPU time consumed: 65ms
Running as unit: run-u346.service
Finished with result: success
Main processes terminated with: code=exited/status=0
Service runtime: 30ms
CPU time consumed: 30ms
Checking protonvpn dependencies...
Synchronizing package databases...
no servers configured for repository
Failed to synchronize databases
Resolving dependencies...
Warning: cannot resolve "libcap=2.52", a dependency of "lib32-libcap"
Error: Failed to prepare transaction:
could not satisfy dependencies:
- unable to satisfy dependency 'libcap=2.52' required by lib32-libcap

No did not find any

Don't reinstall, this is a minor problem.

Can you try using pacman?

sudo pacman -Syu
2 Likes

It gives this error

:: Synchronizing package databases...
error: failed to synchronize all databases (no servers configured for repository)

DId you resort your mirrors as I suggested above? If so, how?

1 Like

Yes I did that. I selected different mirrors from vefore

How, specifically.

Previously it was only India mirror selected by default so i selected worldwide and few other mirrors of countries nearby

Can you share the contents of your /etc/pacman.conf?

You appear to have a newer version of lib32-libcap.

Can you also share the output of pacman -Si lib32-libcap

1 Like
#
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
CacheDir = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
#HookDir     = /etc/pacman.d/hooks/
HoldPkg      = pacman glibc garuda-system
#XferCommand = /usr/bin/curl -L -C - -f -o %o %u
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
#UseSyslog
Color
#NoProgressBar
CheckSpace
#VerbosePkgLists
ILoveCandy
ParallelDownloads = 5

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Arch Linux
# packagers with `pacman-key --populate archlinux`.

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

#[testing]
#Include = /etc/pacman.d/mirrorlist

[core]
Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

[multilib-testing]
#Include = /etc/pacman.d/mirrorlist

[multilib]
#Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs
[chaotic-aur]
#SigLevel = Never
Include = /etc/pacman.d/chaotic-mirrorlist

###REPO for MEGA###
[DEB_Arch_Extra]
SigLevel = Required TrustedOnly
Server = https://mega.nz/linux/MEGAsync/Arch_Extra/$arch
###END REPO for MEGA###

this is inside pacman.conf

And this is the output for pacman -Si lib32-libcap

╰─λ pacman -Si lib32-libcap
Repository      : multilib-testing
Name            : lib32-libcap
Version         : 2.52-1
Description     : POSIX 1003.1e capabilities (32-bit)
Architecture    : x86_64
URL             : https://sites.google.com/site/fullycapable/
Licenses        : GPL2
Groups          : None
Provides        : libcap.so=2-32  libpsx.so=2-32
Depends On      : libcap=2.52  lib32-glibc  lib32-pam
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 25.78 KiB
Installed Size  : 70.47 KiB
Packager        : David Runge <[email protected]>
Build Date      : Wednesday 11 August 2021 11:19:07 PM
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Repository      : multilib
Name            : lib32-libcap
Version         : 2.51-1
Description     : POSIX 1003.1e capabilities (32-bit)
Architecture    : x86_64
URL             : https://sites.google.com/site/fullycapable/
Licenses        : GPL2
Groups          : None
Provides        : libcap.so=2-32  libpsx.so=2-32
Depends On      : libcap=2.51  lib32-glibc  lib32-pam
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 24.12 KiB
Installed Size  : 66.07 KiB
Packager        : David Runge <[email protected]>
Build Date      : Monday 28 June 2021 03:30:00 PM
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Enable the multilib repo by uncommenting the line below that. Comment out the multilib-testing repo

3 Likes

already did that

No, you clearly didn't.

It should look like this:

#[multilib-testing]
#Include = /etc/pacman.d/mirrorlist

[multilib]
Include = /etc/pacman.d/mirrorlist
4 Likes

sorry my bad i had did it earlier
but maybe due to restoring previous snapshot it mustve reset

The issue is that you enabled the multilib-testing repo but not the testing repo so you have mismatched package versions.

3 Likes

I've mistakenly done that before, too. First, remove the Vulkan AMD packages. You should be able to do that in Pamac, Octopi, or from a terminal.

Replace them with the appropriate Intel packages.

Using an installation helper (Pamac, Octopi, etc), search on vulkan, and later intel, and swap out the appropriate packages.

You can also search them out using pacman -Ss or a couple other search terms.

Timeshift is nice, but solving the problem instead is exponentially better. I hope it all works out for you. You're so new you are a stranger in a strange land. Terminology is baffling, I remember. This forum and Wiki, the Arch Wiki, from whence comes all baffling knowledge.

But you are off to a good start. Keep it up and you'll feel comfortable in it sooner than later. That's the overall goal you should be shooting for in Learning Linux.

Best regards

3 Likes