Unable to log in to my root account

Thank you for providing the answers in topics similar. However, when I tried to delete the guest account as suggested it said that I could not do it because I did not have sudo access. A bit unsure of what to do now.


What are you doing to try to


What tells you that you do not


1 Like

Simply trying to log in as my user name. It is displayed on the home screen and when i select it nothing changes except the "guest" log in only enters the system.

When I go to the terminal and enter the details supplied that is where I am denied access.

This seems like a different issue to the one in your original post.

Can you detail the exact steps you followed to get to where you are now?

1 Like

Downloaded and installed garuda. Opened. Guest is displayed. Click on the icon at the bottom of the screen to change accounts. Name comes up. Click on name and it disappears and Guest is displayed again. I dont want a guest account I simply want to be able to log into my account.

1 Like

If sudo does not work use pkexec

pkexec pacman -R systemd-guest-user

You may use su for using root account with root password.
Troubleshoot, fix the problem.


It sounds like something in the accounts setup has broken.

Given this is a fresh installation I'd recommend you to reinstall, then note down the steps you follow to remove the guest user, and then see if this was a mis-click (e.g. you removed the wrong thing) or a bug somewhere along the line.


Thanks. I have reinstalled and it works now.


Could you please tell me where I can find a better place to post my information?
I couldn't find a better place to add my discovery, and the problem appears not to be fixed.



As I already wrote once, if I could put 100% twice, I would. But the second click removes the first :slight_smile:
I'll close it here...

By the way, create a new topic or update yours, which was split from this one yesterday (if applicable)