NumLock occasionally active on boot

This week I installed Garuda linux on an Acer Swift 1 laptop.
All looked good except when I tried to login, it rejected my password each time.
I used the show password icon to show me what I was typing, and it was correct - but the password was rejected.
The only way in was via the guest account.
After some days of trouble, I discovered the problem, which is twofold:

  1. When the laptop boots up, it considers the NumLock to be on (toggled via the F12 key)
  2. In the password field, it displays the characters you appeared to type, not what the system is given. In other words, whether NumLock was on or off, it displayed what I thought I was typing, but what was actually passed in to the system depended on whether NumLock was on or off.
    Note: on this model laptop, there is no visible indicator whether NL is on or off.
    You can tell whether NL is on/off once you're logged in, because what you type is very different depending on NL = on or off. It's only the password field of the graphical login, with the password reveal option turned on, that can't be trusted to show you what the system is being sent.

Oh, and I just discovered that the same problem occurs after the session locks: when asked for the password, you will discover that something has turned on Num Lock again, and although the password will look correct, it will be rejected, until you hit the Num Lock key again and type it a second time (which will also look correct).
Hope this helps someone else!

1 Like

There will be a setting somewhere to alter this, whether it's in the BIOS or the somewhere in the DE... :thinking:

1 Like

Really? Although it sounds plausible, if it was a config option in the BIOS,wouldn't it affect Windows too? It doesn't. (I'm dual booting.)

I also have to modify what I claimed: Num Lock is not always re-enabled when the session locks, only sometimes. After that first session lock, when I had to unlock it I could type the password without first hitting the NumLock key. I tried closing the lid and reopening it and on that occasion I did have to toggle Num Lock before the password was accepted.

It surely must be a Linux bug for the text being displayed in the password field (when the Show option is enabled) not to match what is being sent to the authentication system?

Some login managers warn you if Caps Lock is on. Num Lock is worse!

Just a guess?
Check your keyboard layout is set correctly

1 Like

Excellent suggestion. The Garuda keyboard selector doesn't appear to show a preview of the keyboard, so I don't know how to see if the one I've chosen is correct.
Perhaps I should do that and then run... something? to see what the system thinks the keyboard is doing.

1 year later

Please avoid necrobumping technical threads in the future @lukejkendall

4 Likes

There's a DE setting to remember the numlock state (and restore it), for example: https://wiki.archlinux.org/title/Activating_numlock_on_bootup#X.org

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.