Unable to get 7900 XT working

Hi all,

I've got a new Garuda KDE Dragonized install that I'm trying to get working on a brand new machine. I've followed the steps I found on this Reddit thread, which were basically to update /etc/pacman.conf with:

[mesa-git]
SigLevel = PackageOptional
#SigLevel = Never    <-- or this
Server = https://pkgbuild.com/~lcarlier/$repo/$arch

And then to install these packages:

  • llvm-libs-git
    
  • lib32-llvm-libs-git
    
  • mesa-git
    
  • lib32-mesa-git
    
  • vulkan-radeon-git
    
  • lib32-vulkan-radeon-git
    

I currently have:

  • Kernel: 6.1.6-zen1-1-zen
  • llvm: 16.0.0_r448039.3696941dae5c-1
  • mesa: 1:23.1.0_devel.165238.4fb2463a37f-1

In what may or may not be a related problem, when I try to open Steam, it crashes. When I do that from the terminal, the relevant parts seem to be:

[2023-01-15 21:53:29] Verifying installation...
[2023-01-15 21:53:29] Performing checksum verification of executable files
[2023-01-15 21:53:29] Verification complete
Loaded SDL version 2.27.0-p7692409
OpenGL GLX extension not supported by display
OpenGL GLX extension not supported by displaysrc/steamUI/Main.cpp (395) : Assertion Failed: Error: OpenGL GLX extension not supported by display
src/steamUI/Main.cpp (395) : Assertion Failed: Error: OpenGL GLX extension not supported by display
Installing breakpad exception handler for appid(steam)/version(1671236931)
assert_20230115215329_6.dmp[3959]: Uploading dump (out-of-process)
/tmp/dumps/assert_20230115215329_6.dmp
Gtk-Message: 21:53:29.841: Failed to load module "appmenu-gtk-module"
Gtk-Message: 21:53:29.842: Failed to load module "appmenu-gtk-module"

(steam:3953): Gtk-WARNING **: 21:53:29.843: Unable to locate theme engine in module_path: "adwaita",
/usr/share/themes/Sweet-Dark/gtk-2.0/main.rc:727: error: unexpected identifier 'direction', expected character'}'
/usr/share/themes/Sweet-Dark/gtk-2.0/apps/chrome.rc:50: error: invalid string constant "button", expected valid string constant
/usr/share/themes/Sweet-Dark/gtk-2.0/apps/xfce.rc:79: error: invalid string constant "entry", expected valid string constant
XRRGetOutputInfo Workaround: initialized with override: 0 real: 0xf5f2adb0
XRRGetCrtcInfo Workaround: initialized with override: 0 real: 0xf5f29500
Installing breakpad exception handler for appid(steam)/version(1671236931)
steamwebhelper.sh[3964]: Runtime for steamwebhelper: defaulting to /home/kestrel/.local/share/Steam/ubuntu12_64/steam-runtime-heavy
steamwebhelper.sh[3964]: glibc >= 2.34, partially disabling sandbox until CEF supports clone3()
glXChooseVisual failed
glXChooseVisual failedsrc/steamUI/Main.cpp (395) : Assertion Failed: Error: glXChooseVisual failed
src/steamUI/Main.cpp (395) : Assertion Failed: Error: glXChooseVisual failed
crash_20230115215329_8.dmp[3989]: Uploading dump (out-of-process)
/tmp/dumps/crash_20230115215329_8.dmp
/home/kestrel/.local/share/Steam/steam.sh: line 798:  3953 Segmentation fault      (core dumped) "$STEAMROOT/$STEAMEXEPATH" "[email protected]"

From what I've found searching for similar errors, it sounds like that means there's a problem with my drivers. I've tried installing the latest linux-firmware-git from chaotic, but that didn't seem to help. Any assistance getting my new system and Steam up and running would be much appreciated.

System:
Kernel: 6.1.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=cf95cbc9-d27b-41f5-acc4-f8824ac2d362 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Gigabyte model: Z790 UD AC v: x.x
serial: <superuser required> UEFI: American Megatrends LLC. v: F3k
date: 01/05/2023
CPU:
Info: model: 13th Gen Intel Core i9-13900K bits: 64 type: MST AMCP
arch: Raptor Lake gen: core 13 level: v3 note: check built: 2022+
process: Intel 7 (10nm) family: 6 model-id: 0xB7 (183) stepping: 1
microcode: 0x10F
Topology: cpus: 1x cores: 24 mt: 8 tpc: 2 st: 16 threads: 32 smt: enabled
cache: L1: 2.1 MiB desc: d-16x32 KiB, 8x48 KiB; i-8x32 KiB, 16x64 KiB
L2: 32 MiB desc: 8x2 MiB, 4x4 MiB L3: 36 MiB desc: 1x36 MiB
Speed (MHz): avg: 3021 high: 4300 min/max: 800/5500:5800:4300 scaling:
driver: intel_pstate governor: performance cores: 1: 3000 2: 3000 3: 3000
4: 3000 5: 3000 6: 3000 7: 3619 8: 4041 9: 800 10: 3000 11: 2924 12: 3000
13: 3000 14: 3000 15: 3000 16: 3000 17: 3000 18: 3000 19: 3000 20: 3000
21: 4300 22: 3000 23: 3000 24: 3000 25: 3000 26: 3000 27: 3000 28: 3000
29: 3000 30: 3000 31: 3000 32: 3000 bogomips: 191692
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel Raptor Lake-S GT1 [UHD Graphics 770] vendor: Gigabyte
driver: i915 v: kernel arch: Gen-13 process: Intel 7 (10nm) built: 2022+
ports: active: HDMI-A-2 empty: DP-1,HDMI-A-1 bus-ID: 00:02.0
chip-ID: 8086:a780 class-ID: 0300
Device-2: AMD Navi 31 [Radeon RX 7900 XT/7900 XTX] driver: amdgpu
v: kernel arch: RDNA-3 code: Navi-3x process: TSMC n5 (5nm) built: 2022+
pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: none empty: DP-2,
DP-3, DP-4, HDMI-A-3 bus-ID: 03:00.0 chip-ID: 1002:744c class-ID: 0300
Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
compositor: kwin_x11 driver: X: loaded: amdgpu,modesetting unloaded: radeon
alternate: fbdev,intel,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-2 mapped: HDMI-2 model: VG245 serial: <filter>
built: 2020 res: 1920x1080 hz: 60 dpi: 92 gamma: 1.2
size: 531x299mm (20.91x11.77") diag: 609mm (24") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
API: OpenGL v: N/A renderer: N/A direct render: N/A
Audio:
Device-1: Intel vendor: Gigabyte driver: snd_hda_intel bus-ID: 1-5:2
v: kernel chip-ID: 1038:12ad alternate: snd_sof_pci_intel_tgl
bus-ID: 00:1f.3 class-ID: 0300 chip-ID: 8086:7a50 class-ID: 0403
Device-2: AMD driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s
lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab30 class-ID: 0403
Device-3: SteelSeries ApS Arctis 7 type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound API: ALSA v: k6.1.6-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.64 running: yes
Network:
Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
vendor: AzureWave driver: rtw_8821ce v: N/A modules: rtw88_8821ce pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 port: 4000 bus-ID: 06:00.0
chip-ID: 10ec:c821 class-ID: 0280
IF: wlp6s0 state: down mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 07:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 1-14:9 chip-ID: 13d3:3533 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 2.26 TiB used: 332.48 GiB (14.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WD BLACK SN850X 2000GB size: 1.82 TiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 620281WD temp: 50.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Intel model: SSDSC2BP480G4
size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 0420 scheme: GPT
Partition:
ID-1: / raw-size: 60 GiB size: 60 GiB (100.00%) used: 16.23 GiB (27.0%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 1024 MiB size: 1022 MiB (99.80%)
used: 608 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 1.76 TiB size: 1.76 TiB (100.00%)
used: 1.26 GiB (0.1%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-4: /var/log raw-size: 60 GiB size: 60 GiB (100.00%)
used: 16.23 GiB (27.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 60 GiB size: 60 GiB (100.00%)
used: 16.23 GiB (27.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.12 GiB used: 1.2 MiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 37.0 C mobo: N/A gpu: amdgpu temp: 38.0 C
mem: 52.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:
Processes: 489 Uptime: 28m wakeups: 0 Memory: 31.12 GiB
used: 3.31 GiB (10.6%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1939
libs: 552 tools: octopi,pamac,paru Shell: fish v: 3.5.1 default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.24
Garuda (2.6.14-1):
System install date:     2023-01-15
Last full system update: 2023-01-15
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       No/Undetected
Failed units:

It may be worth trying some other kernels. The post you linked did not mention any specific kernel, but the Zen kernel could be considered nonstandard. Try the vanilla kernel and the mainline kernel.

sudo pacman -Syu linux linux-headers linux-mainline linux-mainline-headers

Boot to a new kernel from the advanced options in the Grub menu.

Thanks for the tip. I tried out 6.1.6-arch1-1 and still had no luck. Digging into that Steam error I mentioned in the first post, it sounds like Error: OpenGL GLX extension not supported by display may be due to mesa being built against an older llvm version. It looks like I've got 2 llvm-libs-git versions, and the older one is probably the one that I want, since it's from mesa-git. I'd upload a screenshot, but apparently I can't because I'm a new user.

Anyway, the problem now is that I've got these two different versions of llvm-libs-git installed. One's from chaotic-aur and one's from mesa-git. The chaotic one is the most recent, so it's active. I'd like to get rid of it, but if I try to uninstall it, it's going to take a thousand or so packages with it because they're dependent. What I really want to do is just swap those dependencies over to the other version that I already have installed. Is that a thing I can do?

I've solved my Steam problem. It seems like the slightly newer version of llvm-libs-git from chaotic was indeed the culprit. I was able to force the version from mesa-git with sudo pacman -Sd mesa-git/llvm-libs-git. After a restart, Steam was able to run. glxinfo -B successfully runs now as well, and gives me this:

╰─λ glxinfo -B
name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
Vendor: Intel (0x8086)
Device: Mesa Intel(R) Graphics (RPL-S) (0xa780)
Version: 23.1.0
Accelerated: yes
Video memory: 31863MB
Unified memory: yes
Preferred profile: core (0x1)
Max core profile version: 4.6
Max compat profile version: 4.6
Max GLES1 profile version: 1.1
Max GLES[23] profile version: 3.2
OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) Graphics (RPL-S)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 23.1.0-devel (git-4fb2463a37)
OpenGL core profile shading language version string: 4.60
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.6 (Compatibility Profile) Mesa 23.1.0-devel (git-4fb2463a37)
OpenGL shading language version string: 4.60
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 23.1.0-devel (git-4fb2463a37)
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20

That makes me think it's still the intel integrated graphics running rather that the 7900 xt.

I don't know much about this, but I'd try prepending DRI_PRIME=1 to the Steam game launch string.
https://wiki.archlinux.org/title/PRIME#For_open_source_drivers_-_PRIME

1 Like

Oh dang! It looks like it might actually be working. I was able to fire up Control with everything turned all the way up, and it ran smooth as silk. I think it's up and running. Exciting times!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.