Unable to connect to a remote server using ssh

System:
Kernel: 6.4.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=f2437583-6345-4124-a9ae-b9f3cf7b1471 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=9ab3115e-c62a-4e32-af95-9e00b376cc5e loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: A320M-A PRO (MS-7C51) v: 1.0
serial: <superuser required> UEFI: American Megatrends LLC. v: 1.80
date: 05/08/2023
CPU:
Info: model: AMD Ryzen 5 5500 bits: 64 type: MT MCP arch: Zen 3 gen: 4
level: v3 note: check built: 2021-22 process: TSMC n7 (7nm)
family: 0x19 (25) model-id: 0x50 (80) stepping: 0 microcode: 0xA50000D
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 3242 high: 3933 min/max: 1400/4268 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 2997 2: 3242
3: 2990 4: 3933 5: 3600 6: 2990 7: 2982 8: 3600 9: 2993 10: 2994 11: 2993
12: 3600 bogomips: 86235
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA TU116 [GeForce GTX 1650 SUPER] vendor: eVga.com.
driver: nvidia v: 535.54.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
status: current (as of 2023-05) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-22 pcie: gen: 2 speed: 5 GT/s lanes: 16
link-max: gen: 3 speed: 8 GT/s bus-ID: 10:00.0 chip-ID: 10de:2187
class-ID: 0300
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 75 s-size: 650x366mm (25.59x14.41")
s-diag: 746mm (29.37")
Monitor-1: HDMI-0 res: 1920x1080 size: N/A modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 535.54.03 renderer: NVIDIA GeForce GTX 1650
SUPER/PCIe/SSE2 direct-render: Yes
Audio:
Device-1: NVIDIA TU116 High Definition Audio vendor: eVga.com.
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 10:00.1 chip-ID: 10de:1aeb class-ID: 0403
Device-2: AMD Renoir Radeon High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 30:00.1 chip-ID: 1002:1637
class-ID: 0403
Device-3: AMD Family 17h/19h HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 30:00.6 chip-ID: 1022:15e3
class-ID: 0403
API: ALSA v: k6.4.2-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.73 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: e000 bus-ID: 25:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp37s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: TP-Link UB500 Adapter driver: btusb v: 0.8 type: USB rev: 1.1
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-3:2 chip-ID: 2357:0604
class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 1.29 TiB used: 816.67 GiB (61.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Biostar model: S100-120GB
size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 5.0 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SA400S37240G
size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 0107 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
model: WD10EZEX-22MFCA0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
fw-rev: 1A01 scheme: MBR
ID-4: /dev/sdd maj-min: 8:48 vendor: Kingston model: DataTraveler 3.0
size: 57.8 GiB block-size: physical: 512 B logical: 512 B type: USB rev: 3.2
spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
fw-rev: PMAP scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 206.21 GiB size: 206.21 GiB (100.00%)
used: 21.32 GiB (10.3%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 29.7 MiB (9.9%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 206.21 GiB size: 206.21 GiB (100.00%)
used: 21.32 GiB (10.3%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-4: /var/log raw-size: 206.21 GiB size: 206.21 GiB (100.00%)
used: 21.32 GiB (10.3%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-5: /var/tmp raw-size: 206.21 GiB size: 206.21 GiB (100.00%)
used: 21.32 GiB (10.3%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 17.06 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sdb3 maj-min: 8:19
ID-2: swap-2 type: zram size: 15.51 GiB used: 10.8 MiB (0.1%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 50.6 C mobo: N/A gpu: nvidia temp: 48 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
Processes: 309 Uptime: 3h 58m wakeups: 0 Memory: available: 15.51 GiB
used: 5.96 GiB (38.4%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 13.1.1 Packages: 1373 pm: pacman pkgs: 1339
libs: 346 tools: octopi,paru pm: flatpak pkgs: 34 Shell: fish v: 3.6.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.27
Garuda (2.6.16-1):
System install date:     2023-07-08
Last full system update: 2023-07-08
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Hello, this is my first post here, so sorry if I do something incorrectly such choosing the wrong template.

When I first tried to ssh using Konsole without modifying anything a pop-up appears asking me to type my password, although the text inside the box doesn't match, because the box was asking me to type my password but the text in Konsole ask me to type the typical "Yes/No", the first time I type my local password, then it fails, and I type "Yes" and it worked, but after that the same pop-up appear asking me to type my password, and I incorrectly type my local password instead of the remote server password and now every time I tried to ssh into same server the incorrect password write itself without giving me any time to do something, and obviously it fails.

According to something that I read, this happens because of a Plasma's dependency called ksshaskpass that is responsible to automatize the log-in into remove servers using ssh, I already tried removing the dependency and every time I tried to ssh I receive this message:

ssh_askpass: exec(/usr/bin/ksshaskpass): No such file or directory

I tried reinstalling the dependency but the only thing that change is if I delete .ssh/known_hosts file that the pop-up will appear again asking to write "Yes/No", but that's it, then it will write the incorrect password again

What exactly does the popup say?

What is the question the prompt is asking you?

What is the exact failure message you get?

My understanding is ksshaskpass saves a passphrase to unlock your SSH key for the agent--not passwords of remote servers. It sounds like you are trying to connect to the server with a password, not an SSH key--is that right?

2 Likes

At this moment I can't write the exact thing that it said before because once I typed it wrong it just automatically auto-complete everything for me, but it says the same thing that the text in Konsole said, "Fingerprint" something, sorry for not being very helpful.

The above.

I don't give any error message, it just "fails", here is an image to explain the problem.

Hmmm... I guess. Honestly I just started into this self-hosting stuff, and I'm still on my way to learning how to do things, I just came from KDE Neon where I type into my Konsole "ssh user@domain" and I can access remotely.

I dislike ksshaskpass and prefer the normal enter password mode in the Shell directly.
Maybe you would like that version as well.

4 Likes

Thank you so much! It worked like a charm!

I was almost already giving up :upside_down_face:

I wonder why the Garuda team decide to use ksshaskpass

I found it to be quite useful, though given nobody else seems to like it shall be reverted?

1 Like

I never said that it should be reverted, as someone who just start self-hosting honestly I know absolutely nothing, that tool probably should be super useful, and I'm yet just too blind to learn or know how to use it.

Actually, I should start learning how to use it. :upside_down_face:

But when I asked that I mean that for me, in my case, was not exactly super friendly to being unable to type again my password after typing it bad one time, and yes, I know, it was because I don't know how to use that tool.

1 Like

To anybody having this problem in the future, I just realize that if you install KDE Wallet you can access and delete your server passwords from there without much trouble.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.