Unable to boot to any snapshot

Hello Garuda users.

I'm unable to execute garuda-inxi since I accidentally removed libinput and my pc won't boot into a past snapshot

When I try to boot to a snapshot it gives me the following error

setfont: KDFONTOP: Function not implemented
ERROR: Root device mounted successfully, but /sbin/init does not  exist.
Bailing out, you are on your own. Good luck

sh: can't access tty; job control turned off
[rootfs ]#

This is the default grub config

This is the one for booting into a btrfs snapshot


I can get an usb stick with garuda but not fast so if possible I would like to avoid it.

Not booting into tty so I can't follow those steps.
Is there a way to fix that without having to use a live usb?

....

Also, I don't know how to solve the problem even with a live usb, because I don't want to repair the currently installed system, but restore a previous snapshot.

To chroot I need to use a live usb I was hoping there was a solution by just modifying the grub config.

I'm not sure on this one, but it is at least worth a shot since you don't have a USB drive handy: arch linux - /sbin/init does not exist - Bailing out, you are on your own. Good luck - Unix & Linux Stack Exchange

Essentially, add init=/lib/systemd/systemd to the kernel line in Grub and see if it will boot. :crossed_fingers:

Already tried but it didn't worked. Probably because it's a snapshot.

Anyway I'm now download the ISO but I don't know what to do even in the live environment. Maybe I'm going to be able to fix the current installation to then use garuda snapshots but idk if then it's going to boot.

If you are able to a live environment you can probably get it fixed. It's not obvious what the issue is, but a few efforts you can make that will cover several possible scenarios:

  • Chroot onto your installation
  • Bring the system up to date with garuda-update
  • Reinstall the kernel and headers
  • Reinstall Grub
  • Regenerate the Grub configuration file
  • Rebuild the initramfs

Any underlying issues will likely be exposed during the course of carrying out these routine tasks, after which you can adjust your intervention accordingly.

2 Likes

No, you get me wrong the current "version" works just doesn't get my input since I removed libinput so the problem is only when booting from snapshots. :sweat_smile:

If the problem is simply that libinput has been accidentally removed, as you say, then the solution is simple: chroot from the live session and install the package.

It sounds like something else is broken though. Having or not having libinput should not affect your ability to restore a snapshot.

1 Like

Now fixing it in that way but I would like to restore to a past snapshot...

Fixed by using btrfs-assistant to restore to the old snapshot

1 Like

That's interesting, how were you able to interact with Btrfs Assistant without libinput? :thinking:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.