Unable to boot live (acer)

I’ve been a proud garuda user for about two years but I’m having trouble getting dr460nized started from a bootable usb on a new acer aspire 5 (A515-48M)…
I’m required to have an acer which is quite unfortunate for anyone wanting linux

AMD Ryzen 5 7530U with Radeon Graphics
AMD Radeon Graphics

Using rufus from windows 10. GPT and MBR give the same result.
The initial boot menu loads just fine, but either driver option leads me to a black screen before returning to the acer splash (green text acer logo) and looping to the driver selection. I have been unable to boot into any live linux to try fixing things.
My secure boot and fast boot are disabled, SATA mode is AHCI and F12 boot is activated.
The usb does not appear if I try adding the bootloader as a trusted UEFI file. Removing quiet still gives no output.
I’ve tried many things and multiple versions of linux to no avail. I would love to get garuda going again! Please let me know if I’m just being stupid or if there’s any way to help (or if you just need more information from this daft old bird)
Thanks much!

try running ventoy on the thumbdrive, might work out better https://www.ventoy.net/en/index.html i promise that it IS possible to run garuda on an acer, I do.

in the middle of an update

Kernel: 6.5.8-AMD-znver2 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: hpet available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-amd-znver2
root=UUID=db37640e-243e-401b-9117-5ab4e247db2f rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=26f9424d-c98e-4028-849c-9edad2ba726d loglevel=3
initcall_blacklist=acpi_cpufreq_init amd-pstate=passive options amdgpu
ppfeaturemask=0xffffffff sysrq_always_enabled=1 ibt=off
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Arch Linux
Type: Laptop System: Acer product: Aspire A515-45 v: V1.07
serial: <superuser required>
Mobo: LN model: Calla_LC v: V1.07 serial: <superuser required>
UEFI: INSYDE v: 1.07 date: 07/27/2021
ID-1: BAT1 charge: 42.7 Wh (100.0%) condition: 42.7/53.2 Wh (80.2%)
volts: 12.6 min: 11.6 model: COSMX AP20CBL type: Li-ion serial: <filter>
status: full
Info: model: AMD Ryzen 7 5700U with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 2 gen: 3 level: v3 note: check built: 2020-22
process: TSMC n7 (7nm) family: 0x17 (23) model-id: 0x68 (104) stepping: 1
microcode: 0x8608102
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 8 MiB
desc: 2x4 MiB
Speed (MHz): avg: 4062 high: 4372 min/max: 400/4372 boost: enabled
scaling: driver: amd-pstate governor: performance cores: 1: 4372 2: 4372
3: 4372 4: 4372 5: 4372 6: 2015 7: 4372 8: 4372 9: 4372 10: 4372 11: 4372
12: 4372 13: 4372 14: 4372 15: 1777 16: 4372 bogomips: 57504
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: AMD Lucienne vendor: Acer Incorporated ALI driver: amdgpu
v: kernel arch: GCN-5 code: Vega process: GF 14nm built: 2017-20 pcie:
gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
active: eDP-1 empty: HDMI-A-1 bus-ID: 05:00.0 chip-ID: 1002:164c
class-ID: 0300 temp: 47.0 C
Device-2: Chicony HD User Facing driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-4:2 chip-ID: 04f2:b72b
class-ID: fe01 serial: <filter>
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.1
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP model: AU Optronics 0x4999 built: 2019
res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6")
diag: 394mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast gbm: drv: kms_swrast surfaceless: drv: radeonsi x11:
drv: radeonsi inactive: wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (renoir LLVM
16.0.6 DRM 3.54 6.5.8-AMD-znver2) device-ID: 1002:164c memory: 500 MiB
unified: no
API: Vulkan v: 1.3.264 layers: 13 device: 0 type: integrated-gpu name: AMD
Radeon Graphics (RADV RENOIR) driver: mesa radv v: 23.2.1-arch1.2
device-ID: 1002:164c surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: AMD Renoir Radeon High Definition Audio
vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel pcie: gen: 3
speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 05:00.1
chip-ID: 1002:1637 class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor
vendor: Acer Incorporated ALI driver: N/A alternate: snd_pci_acp3x,
snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x, snd_acp_pci pcie: gen: 3
speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 05:00.5
chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 05:00.6 chip-ID: 1022:15e3
class-ID: 0403
API: ALSA v: k6.5.8-AMD-znver2 status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.83 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Acer Incorporated ALI driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 03:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
IF-ID-1: br-4bc3498b1392 state: down mac: <filter>
IF-ID-2: br-b23cc15b115d state: up speed: 10000 Mbps duplex: unknown
mac: <filter>
IF-ID-3: docker0 state: down mac: <filter>
IF-ID-4: veth2e99ed0 state: up speed: 10000 Mbps duplex: full
mac: <filter>
Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-3:2 chip-ID: 8087:0029
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 5.2 lmp-v: 11
status: discoverable: no pairing: no
Local Storage: total: 4.1 TiB used: 2.16 TiB (52.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: 2210 MTFDHBA512QFD
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: P6MA000 temp: 34.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Crucial model: CT4000MX500SSD1
size: 3.64 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 044 scheme: GPT
ID-1: / raw-size: 460.16 GiB size: 460.16 GiB (100.00%)
used: 104.81 GiB (22.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 592 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 460.16 GiB size: 460.16 GiB (100.00%)
used: 104.81 GiB (22.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 460.16 GiB size: 460.16 GiB (100.00%)
used: 104.81 GiB (22.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 460.16 GiB size: 460.16 GiB (100.00%)
used: 104.81 GiB (22.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 14.99 GiB used: 140.8 MiB (0.9%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16
dev: /dev/zram0
ID-2: swap-2 type: partition size: 16.48 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
System Temperatures: cpu: 60.0 C mobo: N/A gpu: amdgpu temp: 47.0 C
Fan Speeds (rpm): N/A
Processes: 398 Uptime: 4h 46m wakeups: 1 Memory: total: 16 GiB note: est.
available: 14.99 GiB used: 6.67 GiB (44.5%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: pm: pacman pkgs: 2440 libs: 610 tools: octopi,pamac,paru
Shell: fish v: 3.6.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.30
Garuda (2.6.17-1):
System install date:     2022-06-28
Last full system update: 2023-10-24 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       No/Undetected
Failed units:

Thank you for the quick response, friend! I’ll give that a try.
Good to know that it’s possible somehow…

You can test maybe also the LTS kernel version


Thanks SGS, I’ll try this version

@Javabean Ventoy and boot menu load, but I get a quick flash of “secure boot disabled” before it goes back to the black screen and acer splash. Does the drive need to be formatted in a certain way?

not that i can think of… when you install/run ventoy and tell it to install to your usb drive it creates 2 partitions on that device. one partition is very small, the other not. toss your raw iso’s onto the larger(2nd) partition and it will be an option on boot if the ventoy is installed/booted properly


I use extra space for memory

 ╭─sgs@hypr in ~ as 🧙 took 2ms
   21:56:12 🕙
 ╰─λ df -Th | grep sda
/dev/sda1      exfat      27G     13G   15G   46% /run/media/sgs/Ventoy
/dev/sda3      ext4       32G     23G  7,1G   77% /run/media/sgs/Speicher

 ╭─sgs@hypr in ~ as 🧙 took 3ms
   21:56:32 🕙
 ╰─λ lsblk -f | grep sda
├─sda1      exfat  1.0   Ventoy      1C24-D355                              14,6G    45% /run/media/sgs/Ventoy
├─sda2      vfat   FAT16 VTOYEFI     1E1C-88C8                                           
└─sda3      ext4   1.0   Speicher    8f7d761a-910d-4612-88db-d0a5ee320880    7,1G    72% /run/media/sgs/Speicher

I’m unable to download any of these files. Is there an alternative link to any LTS versions?

Works fine here


That’s odd… The downloads complete, but I get a download failed error and my folder doesn’t even gain a partial file. I’ll try on a different device and send it to myself

@Javabean I get the boot option for garuda and am able to use it. Still getting blackscreened past the driver selection grub menu

Download direct to ventoy stick, some file browser show ready messages to early.


Fail messages again, but I did get part files this time. I’ve waited a fair bit after the downloads ‘ended’ in case the completion appeared early, though nothing seems to have changed

(All downloads seem to get stuck at 2.1GB regardless of browser)

ok… i updated my ventoy(assume it is freshly installed) and grabbed the latest torrent off of the downloads page and torrented the iso (garuda-dr460nized-gaming-linux-zen-230501.iso) and transferred it to the ventoy partition like you are supposed to. no issues booting it(took a minute to remember the bios password to change boot device) and here you see me, in the live of the installer…

i am sorry condor, i CAN NOT replicate your issue… have you tried updating your bios? https://www.acer.com/us-en/support

Thank you both for the help. I’d best be off to get some shut-eye and come back tomorrow.

I can’t seem to find a BIOS update option for my device on that website (unless I’m just a bit blind)
Are there any options in my acer BIOS you’d like to check? I’m sorry to be such a pain.
Maybe this specific laptop make has its own issues with linux? It’s a shame you aren’t able to reproduce this issue

Strangely, I get network errors for the failed downloads. Very weird indeed…
Maybe trying on a different connection tomorrow will help

sadly the only thing i can think of is to make sure that uefi is on… unless you posted pics of all the screens in your bios, which i am not sure would help. these bios’s do appear “buggy”, hell mine is booting in secureboot and i am pretty sure i never setup any of that

I’ll plonk them all in an image host for you to have a look. There might be an embarrassingly obvious issue I glanced over

If secure boot standard means on, then change to off.

ok, comparing your bios shots with what mine shows… i apparently cleared the secureboot settings and the tpm on my system.WARNING, I WAS INTENDING TO NEVER USE WINDOWS ON THIS MACHINE. clearing these settings basically should destroy your windows license

if you are ok with destroying windows and basically voiding your warrenty. i would start with the restore secure boot to factory default and then clear secure boot settings and then try again. clearing the tpm shouldn’t be needed and i for one would be interested if it worked without doing just that.

also, personally, i have fast boot enabled and the function keys set to function keys and i also have a supervisor password set. d2d recovery is disabled on mine

that should be about it, i can’t promise that this will help you though.


1 Like

Secure and fast boot off, are enough on my lenovos, M$ and Linux boot fine, no need to destroy win keys.
But IDK the acer way and their cooperation with M$.

indeed, but i didn’t want anything cluttering up that bit of storage… if i ever try to use secureboot or tpm encryption i don’t want to go oh yeah, there is 5mb of windows keys there, no wonder nothing is storing. but that is kinda how i am, i try to live maxim 37 as much as i can. There is no 'overkill.' There is only 'open fire' and 'reload.'