Unable to boot into my Encrepted Sway After Dual Booting Qtile

After Dualbooting Qtile with sway option to boot into sway was not there so i booted into Qtile and did sudo grub-update that didn't detected Sway so i mounted the encrypted sway partition and did the update then it detected after that i rebooted but then this showed up when i tried to enter Sway.

reason for my dual boot is i created user kavy on my sway but my brother kavy uses qwerty and my system is encrepted so i needed to enter pasword every single time and change the layout again and again so i decieded to dual boot qtile with sway my brother would use qtile and i would use sway.

also i want to know if anyone succeded in runing wayland on Garuda Qtile.
i am going to buy a new laptop it's hp victus it's model no. is 15-fa0666TX it has intel i5 12th gen and an rtx 3050. I want to know if wayland will work on it or not and if then will qtile wayland will work or not.
my budget is around 70-75k INR which is around 900 USD so if there is any better laptop u can also mention it.

  Kernel: 6.4.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=07fab3f8-95aa-4257-afb0-92f9f4e4d2d1 rw rootflags=subvol=@
    quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: Qtile v: 0.22.1 wm: LG3D vt: 2 dm: SDDM Distro: Garuda Linux
    base: Arch Linux
  Type: Desktop Mobo: INTEL model: H61 serial: <superuser required>
    UEFI: American Megatrends v: 4.6.5 date: 04/08/2022
  Info: model: Intel Core i3-2120 bits: 64 type: MT MCP arch: Sandy Bridge
    gen: core 2 level: v2 built: 2010-12 process: Intel 32nm family: 6
    model-id: 0x2A (42) stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 3120 high: 3300 min/max: 1600/3300 scaling:
    driver: intel_cpufreq governor: performance cores: 1: 3300 2: 2580 3: 3300
    4: 3300 bogomips: 26341
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: NVIDIA GF119 [GeForce GT 610] driver: nvidia v: 390.157
    alternate: nouveau,nvidia_drm non-free: series: 390.xx+ status: legacy-active
    (EOL~late 2022) arch: Fermi code: GF1xx process: 40/28nm built: 2010-16
    pcie: gen: 2 speed: 5 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:104a class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 compositor: Picom v: git-c4107
    driver: X: loaded: nvidia gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 101 s-size: 483x261mm (19.02x10.28")
    s-diag: 549mm (21.61")
  Monitor-1: Unknown-1 mapped: HDMI-0 res: 1920x1080 hz: 60 dpi: 102
    size: 479x260mm (18.86x10.24") modes: 800x600
  API: OpenGL v: 4.6.0 NVIDIA 390.157 renderer: GeForce GT 610/PCIe/SSE2
    direct-render: Yes
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20
    class-ID: 0403
  Device-2: NVIDIA GF119 HDMI Audio driver: snd_hda_intel v: kernel pcie:
    gen: 2 speed: 5 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:0e08 class-ID: 0403
  API: ALSA v: k6.4.12-zen1-1-zen status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 0.3.78 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 03:00.0
    chip-ID: 10ec:8136 class-ID: 0200
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
    v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 2-1.2:3
    chip-ID: 0a12:0001 class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.0
    lmp-v: 6 status: discoverable: no pairing: no class-ID: 7c0104
  Local Storage: total: 1.93 TiB used: 18.15 GiB (0.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: GALAX model: GAMER L TA1D0120A
    size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 61.3 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3500418AS
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: HP35 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WD15SMRW-11YNDS1 size: 1.36 TiB block-size: physical: 512 B
    logical: 512 B type: USB rev: 2.1 spd: 480 Mb/s lanes: 1 mode: 2.0
    tech: HDD rpm: 5400 serial: <filter> fw-rev: 1020 scheme: GPT
  ID-1: / raw-size: 75.35 GiB size: 75.35 GiB (100.00%)
    used: 18.15 GiB (24.1%) fs: btrfs dev: /dev/sdb10 maj-min: 8:26
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 584 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 75.35 GiB size: 75.35 GiB (100.00%)
    used: 18.15 GiB (24.1%) fs: btrfs dev: /dev/sdb10 maj-min: 8:26
  ID-4: /var/log raw-size: 75.35 GiB size: 75.35 GiB (100.00%)
    used: 18.15 GiB (24.1%) fs: btrfs dev: /dev/sdb10 maj-min: 8:26
  ID-5: /var/tmp raw-size: 75.35 GiB size: 75.35 GiB (100.00%)
    used: 18.15 GiB (24.1%) fs: btrfs dev: /dev/sdb10 maj-min: 8:26
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 7.71 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
  System Temperatures: cpu: 40.0 C mobo: N/A gpu: nvidia temp: 47 C
  Fan Speeds (rpm): N/A gpu: nvidia fan: 40%
  Processes: 189 Uptime: 8m wakeups: 0 Memory: total: 8 GiB
  available: 7.71 GiB used: 1.49 GiB (19.3%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1247 libs: 416 tools: pamac,paru Shell: fish v: 3.6.1
  default: Bash v: 5.1.16 running-in: alacritty inxi: 3.3.29
Garuda (2.6.16-1):
  System install date:     2023-08-28
  Last full system update: 2023-08-28
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:

Do they have separate UEFI boot variables?

Is Sway encrypted, but Qtile is not?

Are they sharing an EFI partition?

Please show these outputs:

lsblk -f
sudo parted -l

You may need to boot to the live environment and chroot the Sway installation so you can reinstall the kernels and bootloader, then regenerate the Grub configuration again.


yes Sway is encrypted
i have two drives in ssd sway and in hdd qtile .

sda       8:0    0 111.8G  0 disk
├─sda1    8:1    0   300M  0 part /boot/efi
├─sda2    8:2    0 102.7G  0 part
└─sda3    8:3    0   8.8G  0 part
sdb       8:16   0 465.8G  0 disk
├─sdb1    8:17   0  74.7G  0 part
├─sdb2    8:18   0    10G  0 part
├─sdb3    8:19   0    10G  0 part
├─sdb4    8:20   0    50G  0 part
├─sdb5    8:21   0    10G  0 part
├─sdb6    8:22   0    30G  0 part
├─sdb7    8:23   0    50G  0 part
├─sdb8    8:24   0    20G  0 part
├─sdb9    8:25   0    10G  0 part
└─sdb10   8:26   0  75.3G  0 part /var/cache
sdc       8:32   0   1.4T  0 disk
├─sdc1    8:33   0    66G  0 part /run/media/kavy/AMVs
└─sdc2    8:34   0   1.3T  0 part /run/media/kavy/Anime
zram0   254:0    0   7.7G  0 disk [SWAP]
sudo parted -l
[sudo] password for kavy:
Model: ATA GAMER L TA1D01 (scsi)
Disk /dev/sda: 120GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number  Start   End    Size    File system  Name  Flags
 1      2097kB  317MB  315MB   fat32              boot, esp
 2      317MB   111GB  110GB                root
 3      111GB   120GB  9449MB

Model: ATA ST3500418AS (scsi)
Disk /dev/sdb: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number  Start   End     Size    File system  Name  Flags
 1      1049kB  80.2GB  80.2GB  ext4
10      80.2GB  161GB   80.9GB  btrfs        root
 2      161GB   172GB   10.7GB  ext4
 3      172GB   183GB   10.7GB  btrfs
 4      183GB   236GB   53.7GB  btrfs
 5      236GB   247GB   10.7GB  btrfs
 6      247GB   279GB   32.2GB  btrfs
 7      279GB   333GB   53.7GB  btrfs
 8      333GB   354GB   21.5GB  btrfs
 9      354GB   365GB   10.7GB  btrfs

Model: WD Elements 25A1 (scsi)
Disk /dev/sdc: 1500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number  Start   End     Size    File system  Name  Flags
 2      1049kB  1429GB  1429GB  btrfs
 1      1429GB  1500GB  70.9GB  btrfs

Model: Unknown (unknown)
Disk /dev/zram0: 8281MB
Sector size (logical/physical): 4096B/4096B
Partition Table: loop
Disk Flags:

Number  Start  End     Size    File system     Flags
 1      0.00B  8281MB  8281MB  linux-swap(v1)


BootCurrent: 0000
Timeout: 2 seconds
BootOrder: 0000,0005,0001
Boot0000* Garuda	HD(1,GPT,ad02a3ff-16b1-7947-b91b-dcf44054d5d9,0x1000,0x96000)/File(\EFI\Garuda\grubx64.efi)
Boot0001* Hard Drive 	BBS(HD,,0x0)0000474f00004e4fa9000000010000006f00470041004d0045005200200020004c002000200054004100310044003000310032003000410000000501090002000000007fff040002010c00d041030a0000000001010600021f03120a000000ffff00007fff040001043e00ef47642dc93ba041ac194d51d01b4ce64300440031003500370030003600390045003000450044003000300037003100330032003800350000007fff04000000424f00004e4f99000000010000006f005300540033003500300030003400310038004100530000000501090002000000007fff040002010c00d041030a0000000001010600021f03120a000400ffff00007fff040001043e00ef47642dc93ba041ac194d51d01b4ce65600390052004d004d0042003700300020002000200020002000200020002000200020002000200000007fff04000000424f00004e4fb100000001000000730057004400200045006c0065006d0065006e0074007300200032003500410031002000310030003200300000000501090002000000007fff040002010c00d041030a0000000001010600001a0305060001000305060004007fff040001044000ef47642dc93ba041ac194d51d01b4ce657004400200045006c0065006d0065006e0074007300200032003500410031002000310030003200300000007fff04000000424f
Boot0005* UEFI OS	HD(1,GPT,ad02a3ff-16b1-7947-b91b-dcf44054d5d9,0x1000,0x96000)/File(\EFI\BOOT\BOOTX64.EFI)

Please, do not post screenshots or pictures. Just post terminal logs as text like your garuda-inxi.


okay i will follow it

Missing the -f option! No matter though, I mostly wanted to see if you had two EFI partitions but I can see you do not.

I think you will need to boot to the live ISO and reinstall the bootloader from chroot, such as is described here:


it didn't worked
but i saw the repair grub option in Garuda Welcome then i clicked on it then i clicked on reinstall grub but it didn't worked it showed some error.
then got back into the Garuda Welcome after that i clicked on Repair Grub then again on Repair Grub then my issue got solved

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.