Unable to boot installer on T5600

Hello. I am using ubuntu on desktop as the only OS. I need to install coarrays and was able to to do it in garuda in a virtualbox. Now I want to install garuda instead of ubuntu. I am unable to boot from usb.
Earlier I was able to replace widnows with ubuntu. I am unable to bypass boot sequence.
Please help.

Disable fastboot
Disable secure boot

In bios then try booting from usb

Also make sure to use dd method to write iso to usb

You can use Balens etcher

6 Likes

And
:slight_smile:

1 Like

How did you install Ubuntu without USB booting?
Why can't you boot from USB?
AFAIK it is not possible to install over your only existing system, without booting from USB or a disc.

2 Likes

Use BalenaEtcher
Disable the secure boot
Change boot mode to UEFI

1 Like

The T5600 system came with windows 10 installed on SSD. I downloaded ubuntu iso on my laptop, burned a usb using rufus and booted T5600 without any issues and clean installed ubuntu. Now I want a clean install of garuda (or any arch) but cannot boot from usb.

BIOS is already set on legacy. I do not see a secure boot toggle. I will try changing the boot mode though

Ubuntu can be installed with secure boot enabled 98% of Linux distros can not. Almost all distros except Ubuntu require you to disable secure boot. Ubuntu paid M$ blood money to purchase M$ keys.

Most every independent distro does not have the money to waste to pay M$ off to get their secret keys.

You must disable secure boot.

Sometimes you must set an admin password in the bios before you can disable SB.

4 Likes

Please explain why.

1 Like

I'm also running a DELL Precision T5600 in legacy mode. I had no issues booting from a USB thumb drive with the Garuda image made by balena etcher. I'm on BIOS A19. Running smooth , best distro I've tried so far. Secure Boot is disabled on my setup.

3 Likes

Well it turned out that I was inserting the usb in an ss port. Inserting it in a regular usb port solved the problem. I can reach the first screen, select boot and then I see three little squares on the screen. Nothing happens after that.
In a virtualbox, everything goes smoothly.
I next tried endeavoursos. It goes through and boots live. BUT I cannot connect to internet. Wifi is recognized but unable to connect.

I can go up to first screen followed by three squares on the screen. Then nothing happens.

Press ESC on the three squares.
MHWD use sometimes 2:30 Min to finish hardware search.
Post as text where it stock, if so.

You have Nvidia GPU? You boot with nonfree or free driver?
You use legacy or UEFI?

And which DE you use? GNOME?
Date from ISO?

That's because Ubuntu's provided USB installer doesn't work very well with Arch-based distros (never has, to my mind). Use 'dd' or Balena Etcher, as recommended. Also SuSE's imagewriter, GNOME Disk Utility ('Disks' in Ubuntu), or KDE's isoimagewriter-git (my favorite).

regards

2 Likes
  1. Pressing ESC on three squares moves forward but then stuck at Terminate Plymouth Boot Screen
  2. VGA is NVIDIA GT218 (GeForc 210) rev a2
  3. Tried all combinations of Legacy/UEFI, nonfree/free driver
  4. iso is garuda-kde-barebones-linux-tkg-bmq-201205.iso

Nothing works

Garuda Linux Barebones is made for users who do not want extra software and functionalities and complain about bloat. It contains only the bare minimum of packages needed to get going. (you are on your own, we dont provide any support for Barebones edition.)

Use one of the other DE's.

3 Likes

ok. I will give garuda-dr460nized-linux-tkg-bmq-201205.iso a try.

3 Likes

You will not regret it :smiley:

4 Likes

Yup , you need to use USB 2.0 on the T5600 for the install. I'm running Dragon , you won't regret it.

I have used rufus and dd. Now I am using Balena Etcher