Unable to Boot Back Into Snapshot of System After Issue With Grub

So about a month back, I did a garuda-upgrade and mid-way through the process, my computer got restarted for some reason and I can never boot back into the Garuda system again, I'm guessing it is because some of the packages are out of sync and on different versions (or something like that). I ended up trying to fix it using chroot, but nothing I tried ever worked. Restoring an older snapshot isn't an option as well, because every time I do so, the snapshot does not get restored for some reason. After all that happened, I decided to just move some stuff to windows, such as my files, and use windows from then on.

Since school is starting soon, I want to revert back to using Linux again, so today, I installed another Garuda system onto my laptop SSD, afterwards, I decided to try to boot into a snapshot of my old system but I couldn't because the Grub layout was completely different as I installed a new Garuda Linux. I then proceeded to uninstall the new system in order to try to be able to boot back into a snapshot, I got my old grub layout back, but when I try to boot into one of the snapshots, it displays this (already tried several different snapshots, none worked):

Loading Snapshot: 2022-06-26 19:19:04 @/.snapshot/454/snapshot
Loading Kernel: vmlinuz-linux-zen ...
452: out of range pointer: 0x8883356400

Aborted. Press any key to exit.

Can someone explain to me a way of booting back into the snapshot? That is the only problem I need to resolve, as after I boot back, I just have a few more things to move and save, such as some logins and browser profiles, then I can do a fresh install of Garuda again.

What was the result of chroot?

Please search before you open new help request.


Follow these steps and you should be up and running again quickly:

  1. Boot a live USB
  2. Install btrfs-assistant using pacman
  3. Restore the snapshot you want using btrfs-assistant
  4. Chroot via garuda-chroot -a
  5. Run grub-install --efi-directory /boot/efi && update-grub
  6. Reboot and enjoy? I think?

This solution finally worked, thank you! It fixed both grub (where I get booted straight to the grub terminal and have to manually set some stuff to have it boot properly) and the problem I was having with the snapshots.

1 Like

You're welcome! Don't forget to update your system and ensure everything still works fine after that too.

1 Like

I've tried this already a few weeks prior. Every time I try to open btrfs-assistant through the start menu, it prompts me for my password, but afterward, nothing happens. If I just run btrfs-assistant through the terminal, it shows:

qt.qpa.xcb: could not connect to display :0
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in " " even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, waylang-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

/usr/bin/btrfs-assistant: line 27:    5003 Aborted                    (core dumped) btrfs-assistant-bin ${params}

This is because btrfs-assistant does not support wayland out of the box back on that version you were using.

1 Like

Ahh I see, got it

Could you explain how it could be made so that btrfs-assistant will be able to support the wayland, just incase something like this happens in the future and don't have the time to start from scratch and move everything to a new system.

I think it should support it now.

Another thing you can ensure is that you have working xwayland and just trying to open it now and seeing if it works.

So last night I did a clean install of Garuda once I finished backing up everything. On the new system, when I try to open btrfs-assistant, it still shows the exact same thing in the terminal.

Did you grab a new ISO, or did you use the old one?

1 Like

Newly installed ISO

Do you use Sway or Wayfire?

I use sway

This is a known issue with the wlroots DEs.

A workaround for now is to run from the terminal:

sudo -E btrfs-assistant-bin

In the current version, btrfs-assistant should support sway. What version do you have and how are you launching it.

I don't want to answer for @bourrasque, but mine is 1.6.3 and I took an update yesterday. The behavior is the same, either launching from the terminal or the NWG menu. The workaround with the -E flag still works.

How are you launching it from the terminal and what is the output you are seeing?

For the record, the correct way to launch it from the terminal is btrfs-assistant-launcher without sudo/pkexec.