Ultimate Guide to install Waydroid in any Arch-based distro(especially Garuda)

Same here…
It was working fine, but suddenly, it stopped working once I did a sudo waydroid init -f

It’s working now with linux-zen. Ran sudo waydroid init -f after switching the kernel.
It’s not working with linux-cachyos though.

1 Like

got it to work (on cachyos) had to follow these steps General Troubleshooting - Waydroid

specficly stoping waydroid with
systemctl stop waydroid-container.service
and then factory resetting it with

sudo rm -rf /var/lib/waydroid /home/.waydroid ~/waydroid ~/.share/waydroid ~/.local/share/applications/*aydroid* ~/.local/share/waydroid

another thing I noticed is my /etc/resolv.conf was empty and it was complaining about it in systemctl status waydroid-container.service so I fixed it by systemctl restart NetworkManager.service

didn’t need PSI=1

1 Like

I haven’t read all the posts in here yet, but I just wanted to point out to the OP that if someone starts at the top, they will run the init command (without GAPPS) before they read anything about the GAPPS option. I did that and found that re-initializing to include GAPPS isn’t as easy as it sounds. I think you should maybe mention there are 2 ways to init a little earlier in the OP, before the instruction to init without GAPPS.

That’s my only gripe so far. You sure worked hard on this. Thanks.

I do have another gripe but it has nothing to do with this tutorial. The reason I wantedthis is that my phone broke and I wanted to play Mech Arena and War Robots. Playstore wouldn’t let me get them. Unsupported device or something. They probably didn’t get the 3D acceleration working yet. I hope they are still trying because it works fine in bluestacks. I just won’t have windows in dualboot unless I can put it in a seperate drive. I’m currently playing in a win11 VM with virtualbox, as jenky as that is, but they have the 3D acceleration working and Mech Arena now has a version for PC. No, I’m not trying to run Bluestacks in a VM…lol. I’m surprised to say, though, that giving the VM 6 cores of my 8 and running with my Quadro m2000m as the renderer in my host, Mech Arena is actually playable in the Win11 guest. I didn’t expect that. A few years ago 3D games were unplayabe in Linux host/Windows guest VMs because the 3D acceleration would screw up your performance horribly everywhere in the VM. It was broken. It’s much closer to fixed now, I’d say.

1 Like

I stumbled upon this guide a couple of days ago, and it’s a great way to play WordFeud without having to use my smart phone (which I’m phasing out step by step). Thanks a million!

The WordFeud app does complain about the Playstore not being present, but it works fine anyway. :ok_hand:

1 Like

Thanks for the suggestion.
I have added it.

Did you install the ARM translation libraries?
Installing the appropriate translation libraries should make appear/visible several of the ARM-only games in the Google Play Store.
Otherwise, you can try installing your games from the Aurora store. You will probably find them there.

You can try installing the Playstore if it is an issue…

3 Likes

Ah yes, “sudo waydroid init -s GAPPS -f” worked like a charm. I’m an even happier camper now.

2 Likes

I did not. Thanks. Great suggestion!! Your thread is packed with great, useful information.

EDIT: I had to reinstall Garuda and when I installed Waydroid it gave me connection problems. I tried the .exe Windows installer with wine and Mech Arena is working beautifully with all settings on high. I haven’t tried troubleshooting the Waydroid connection issue yet, but still, a huge thank you for this thread @Austin .

1 Like

So one thing I had to do to get Waydroid to work on my system was to add sys.use_memfd=true to my /var/lib/waydroid/waydroid_base.prop file. Didn’t see this mentioned anywhere else in the post, but thought I’d add it.

I’ve been playing an idle game on Waydroid for a bit, of which I installed from an APK file instead of from the Google Play Store. They recently updated and had a patch and now it says that game isn’t suitable for this device or something. I read somewhere I should install the arm drivers and try again, but after doing that it doesn’t show up at all when I search for it in the play store.

Looking at the same place I downloaded the APK before now has it as a XAPK file, which after some reading is just an archive of multiple files.

Any other libraries or configurations I might be missing on why the Play Store would either tell me it’s not suitable for this device or just not show up for it?

Hello, thank You for that giude. I install everything like in Your tutorial and everything works great. But next day when I launch laptop and start waydroid I get error that Play Store crash again and again. I uninstall it with waydroid-extras but notting happen. Still shows me that crash info. How to fix that?
Regards.

1 Like

There are other ways to install the play store, you can try those and let me know if it solves the issues…

But how to completly remove it?
Look I uninstall with waydroid-extras and still have that crash:

Regards

Now, did you install the waydroid image using any of the above ‘other methods’?
You must have then again installed GApps using the waydroid-extras command.

That would be the reason you still have the Play Store app.

Secondly, did you register your waydroid device with Google after you had installed GApps?

Google Play Store still works fine at my end…

Hello, I don’t understand guide.
I remove everything now and install fresh: sudo pacman -Syu waydroid.
Now I have to:

  1. sudo pacman -S waydroid-image-gapps
    or
  2. sudo waydroid init -s GAPPS -f
    ?
    Or install script and install GAPPS with extras?

Edit.
I start:

  1. sudo waydroid init
  2. sudo waydroid init -s GAPPS

Waydroid started but there’s no Play Store. So I must install it from extras.

You can use any one of the above 3 methods…

I would prefer this one,
sudo waydroid init -s GAPPS -f

After installing GApps, don’t forget to register your waydroid device with Google.

Also, before reinstalling, I would recommend to reset everything and delete all the previous data and Waydroid configs by running,

OK, I know my bed now. I must

[sudo] hasło użytkownika emi:
[11:16:19] Stopping container
[11:16:20] Downloading https://sourceforge.net/projects/waydroid/files/images/system/lineage/waydroid_x86_64/lineage-18.1-20240511-GAPPS-waydroid_x86_64-system.zip/download
[Downloading] 861.21 MB/861.38 MB    19580.79 kbps(approx.)[11:18:13] Validating system image
[11:18:14] Extracting to /var/lib/waydroid/images
[11:18:40] Starting container

Now I have Play Store installed :slight_smile:
Thanks

1 Like

You would have to install the ARM libraries following the steps detailed in the guide (read everything before you start) to be able to discover and install several ARM-only apps from the Play Store or any other source.

Good night…

1 Like

Hey all ,
I’ve been trying to use Waydroid on Dragonised KDE and have been failing again and again , I’ve tried this guide and the original arch guide , I’ve got the zen kernel and also I’m using wayland.
Everything goes smooth , but when I start the waydroid software from launcher it , starts for a second (appears on the taskbar) and then disappears.

This is what I see on waydroid session start:

waydroid session start
[gbinder] Service manager /dev/anbox-binder has appeared
^C^C⏎                                                                                                         

It just stays like that.

I waited for about 8 mins but nothing happened.
I’m also using a laptop so it has both integrated and dedicated graphics.
Tried the gpu_select.sh script from original wayland repo , didn’t help either.
Kindly suggest if there’s any suggestions.

Thanks

Did you try this?

If it still doesn’t work for you maybe try using a different kernel.

Don’t forget to reinitialise Waydroid every time you switch kernels…

And,
garuda welcome 2

Cheers

1 Like