Ultimate Guide to install Waydroid in any Arch-based distro(especially Garuda)


plz Make one for kde

Everything in this guide works for all Desktop Environments, including KDE.
Actually, I was on KDE when I created this guide.

1 Like

@SGS, could you please make this post a wiki?

I have simplified and updated the guide according to the latest version.

1 Like
1 Like

Some help is needed!

I am using the linux-cachyos kernel, which has the binder modules. I installed Waydroid, and it is not starting

> sudo waydroid init 

[11:44:35] Already initialized

> sudo ls -1 /dev/binderfs/

> sudo ls -1 /dev/binder
ls: cannot access '/dev/binder': No such file or directory

> sudo waydroid status
Session:	RUNNING
Container:	STOPPED
Vendor type:	MAINLINE
Session user:	austin(1000)
Wayland display:	wayland-0

> sudo systemctl enable --now waydroid-container
> waydroid session start

[11:36:52] Session is already running

> sudo waydroid container start
ERROR: WayDroid container service is already running

> waydroid show-full-ui
[gbinder] ERROR: Can't open /dev/binder: No such file or directory
[11:37:15] Waiting for binder Service Manager...
[11:38:15] Service Manager never appeared
[11:38:15] Failed to access IPlatform service

> ls /dev/
drwxr-xr-x       - root   16 Apr 17:00  binderfs
lrwxrwxrwx      22 root   16 Apr 17:00  features -> /dev/binderfs/features
lrwxrwxrwx      26 root   16 Apr 17:00  anbox-binder -> /dev/binderfs/anbox-binder
lrwxrwxrwx      28 root   16 Apr 17:00  anbox-hwbinder -> /dev/binderfs/anbox-hwbinder
lrwxrwxrwx      29 root   16 Apr 17:00  anbox-vndbinder -> /dev/binderfs/anbox-vndbinder
lrwxrwxrwx      28 root   16 Apr 17:00  binder-control -> /dev/binderfs/binder-control

Thank you

Did you try symlinking /dev/binder to /dev/binderfs?

Yup, I tried symlinking /dev/binder to /dev/binderfs/anbox-binder, but it gives an error:

[gbinder] ERROR: Can't open /dev/binder: Permission denied
[23:04:15] Failed to add presence handler: None

It is a shot in the dark but you can try changing the line I linked and compiling waydroid.

I found the file at '/usr/lib/waydroid/tools/helpers/lxc.py' and edited it as you suggested.
Still no luck.

I have commented about it on the AUR website: AUR (en) - waydroid


not sure if this is a stupid question but... considering all the stuff already available to be easily installed on Garuda (part of the reason why I'm loving the experience of using this distro), how hard would it be to include Waydroid in those processes?
I mean, I consider myself tech-savvy but also lazy as hell lol I see these huge tutorials for doing stuff and I feel like "meh, maybe another day"...

Yeah, we could do this if we wanted.
We can add binder_linux-dkms as a dependency, but some kernels, like cachyos kernels, already have the necessary kernel modules, so we should ensure that we install the binder dkms only with kernels that don’t have the modules (Zen kernel doesn’t have I suppose).

Then we just have to enable the init service.
I think we can make a similar script as we have for Anbox( anbox-support ).

@dr460nf1r3, Anbox is deprecated now, so I suppose we should remove Anbox, Anbox support from the repositories.
What do you say?

Waydroid currently has some bug or something, and it’s not running/starting as of today.
And the package is marked out-of-date in the aur.
It would have been really nice to see official direct support from Arch for Waydroid.
Adding the necessary kernel modules in arch kernels and Waydroid packaged in the arch repos.
Fedora, Void Linux and Ubuntu already have that support.

1 Like

I say: worry no more :smiley:

Feel free to create a waydroid-support package, I'll add it happily!


Yeah, I can try to making a package myself this time.
But I am waiting for the current bug to get fixed.


Now binder_linux-dkms is installing with errors with my linux-cachyos 6.3.

so it's not really that far fetched an idea as I thought when I suggested it... nice, I don't feel so stupid about asking now :sweat_smile: