Two Garuda install on two different drives

Hey guys, so i kinda effed up...

i had a KDE install of Garuda on one NVME drive. I then wanted to instally garuda sway on a second NVME drive because i wanted to swap Sway for Hyprland, which requires some kernel stuff and i didn't want to risk breaking my main installation.

So, now i am running on my 2nd drive with the second garuda install. While installing i had to chose where to install grub, i chose my first drive bcs i thought it would detect the other garuda install and show me both.

Now that is not the case...i come into grub, and there is only my new installation. The other one is not showing.

os-prober and updating grub didn't find the other installation. What can i do now? I mounted my main drive on the second install in hope that os-prober and grub would find it then but to no avail...i can browse all the files from my main install so i know its still there...any help would be appreciated

btw i assume they both are running with MBR instead of GPT...because i cannot find an efi directory on either boot directories...or is that unrelated?

btw i already found this thread: How to install two instances of Garuda Linux simultaneously

but this didn't help me :-/

Alright - "fixed" it by copying the menuentry from my first grub.cfg into the custom section of my new grub.cfg

Now i can boot. Gotta play around with the submenus so i can properly display all the different options.

Beware grub.cfg is generated by update-grub and will likely be clobbered at the first chance.

Re. MBR vs GPT, you can find out with e.g. sudo parted /dev/device-here print.
While it's common that BIOS boot = MBR and UEFI boot = GPT, that's not necessarily the case.
My latop can't boot UEFI but I formatted in GPT (*), of course I have no EFI directory but a small bios_grub partition (for details see Partitioning - ArchWiki).
(*) GPT + MBR actually, it was MBR but I converted it with gdisk.


Any idea how i can fix it so i have both installs in there whenever grub.cfg gets changed?

I'd boot the first installation, make sure that the os-prober is not disabled in the /etc/default/grub (should be the last line, GRUB_DISABLE_OS_PROBER=false without the # in front of it), and run sudo update-grub. If that doesn't work... well you already found out how to fix it and boot again.
I think the snapshots submenu will only be there for the first install though.

edit: disregard this and see below for the right way.


Just use custom.cfg :slight_smile:

menuentry "Garuda Linux Sway auf nvme0n1p6" {
   insmod btrfs
   search --no-floppy --fs-uuid --set=root cc8c3427-2bdc-407e-ae93-4105b6795059
   configfile /@/boot/grub/grub.cfg
menuentry "Garuda Linux KDE auf nvme0n1p5" {
   insmod btrfs
   search --no-floppy --fs-uuid --set=root fc62cc44-07ab-497b-ac89-15704c290993
   configfile /@/boot/grub/grub.cfg

# /etc/default/grub

Yeah currently i have this solution, but @meanruse said that updates may break that grub.cfg

Or do you mean i should rename grub.cfg to custom.cfg?

Sorry, i never really tinkered around with grub...always horrified me a little bit because it's so easy to "break your system" with it :smiley:

GRUB - ArchWiki

You can add additional custom menu entries by editing /etc/grub.d/40_custom and re-generating /boot/grub/grub.cfg. Or you can create /boot/grub/custom.cfg and add them there. Changes to /boot/grub/custom.cfg do not require re-running grub-mkconfig, since /etc/grub.d/41_custom adds the necessary source statement to the generated configuration file.


Okaaaaaaaay...i guess i understood this.

Let's see if i can practically execute it aswell!

Already, thank you guys so much!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.