Troubles with dual boot

Hi!
Sorry if the following questions will be to dumb, but I've spent several hours yesterday trying to google every single problem I've encountered and most of the answers that I've found didn't work for me.
I'm not at home right now so I can't add screenshots/photos/logs/etc. for now but I'll try to give as much info as I can.

My specs:

CPU: AMD Ryzen 7 5800X
Motherboard: Asus TUF Gaming B550-Plus
RAM: 32GB
SSD: Samsung 970 Evo Plus which I want to use for OS installation
GPU: Nvidia GTX560Ti (yes, ancient GPU on otherwise modern hardware)
and an old Samsung monitor connected via VGA cable.

So I've tried to install Garuda as a second OS (basically dualboot) with Win10. Currently my SSD is partitioned like that: 120GB for Win10 (it also created boot and recovery partitions), 200+ GB is used for my games installation and 120GB are completely free space and that's where I wanted to install Garuda.
At some point I figured out that my SSD uses MBR so I decided to convert it into GPT, so I can make as many partitions as I want. I used AOMEI Partition Assistant for this task and seems like it worked (well, at least it said that all operations are completed successfully). Than in my BIOS I disabled CSM mode and tried to disable Secure Boot. The problem with that is that there's not too many tutorials how to do it in my version of BIOS. The only tutorial I've found is this one (https://wikiscta.scta.uqam.ca/wikiscta/index.php/How_to_Disable_or_Enable_Secure_Boot_on_Your_Computer_via_ASUS_UEFI_BIOS_Utility) and it says that I need just to clear PK key which I did. But now whenever I try to boot Windows it says "The VGA card is not supported by UEFI driver" and than it re-enables CSM. If I try to boot with CSM enabled it doesnt see my SSD and can not boot at all.
OK, not a big problem, I decided that I can install Garuda anyway and than figure out all the Windows problems later. I used rufus for creating a live USB of DR460NIZED GAMING KDE. Now whenever I access Boot Menu from BIOS for some reason I see 3 different entrys for my single flash drive:

  • UEFI silicon-power 16GB
  • UEFI silicon-power 16GB (Partition 2)
  • silicon-power 16GB
    idk if that's suposed to be like that or is there something wrong. Anyway at this point I tried to boot from every single one of those. No matter which one I choose nothing really changes: it actually shows me GRUB, but than the following happens:
  1. if I choose "Boot allowing proprietary drivers (NVIDIA)" it freezes after showing the message

Starting Terminate Plymouth Boot Screen
  1. if I choose "Boot with open source drivers" it freezes almost immediately showing only following message:

starting version 249.2-1 arch
  1. if I try using nomodeset the result is the same as 2.

I might try using etcher and create new live USB when I get home because at this point it's the only idea that comes to my mind.
Anyway that's all info I can think of right now, any help will be greatly appreciated.

Thanks in advance.

Welcome :slight_smile: .

From live ISO post your

inxi -Faz

Check sha1sum or sha256sum

Give Ventoy a try.

And post name of ISO you try to install, please.

4 Likes

Try going to TTY ctrl+alt+F3 and manually start display manager.

sudo systemctl start sddm.service
3 Likes

What should I look for exactly in output of this command?

EDIT: actually now i can attach pictures. Here's my output BEFORE i installed nvidia drivers:


From what I've seen even after driver installation it still says that none of the drivers are loaded.

About the link to a YT video. I was actually following that exact tutorial. The problem is that I constantly get stuck on some black screen while the guy in the video just successfully boots into installer.

It's KDE Dragonized Gaming Edition. Filename is "garuda-dr460nized-gaming-linux-zen-210729.iso".

Nothing happened when I typed the command in.

Tried it. Nothing has changed. Same results as previously.

I also tried running the following command just in case

sudo pacman -Sy nvidia

It downloaded and installed drivers, but still I get stuck after aforementioned Plymouth line. Although there were a few errors so maybe they are the cause of the problem? It says

ERROR: file not found: 'fsck.overlay'

Could you please check in your BIOS if your SATA controller/mode set to AHCI or what? Intel-VMD?
I'm referring to the disk drives not to graphic drivers because sometimes the boot stucks there for wrong SAT mode (i.e. nmve disks are not recognized)

2 Likes

In BIOS, disable fastboot and secure boot.

IDK the ASUS BIOS but look also to something like

AMD Platform Security Processor und use disabled.

3 Likes

These are the wrong drivers for your card. You have a Fermi Nvidia, which means you need 390xx version.
From what I know, these would have been installed from mhwd during booting in the Live

Also, since you are still on Live ISO, you can't install video drivers (especially not with syncing DBs with -y) and wait for success.

You should check your motherboard/laptop user manual for available BIOS settings.

Maybe @TNE can guide you through, as he is the developer/maintainer of mhwd scripts.

2 Likes

We don't install 390xx in live

4 Likes

It is set to AHCI by default.

Already done that.

Didn't find anything like that neither by scrolling through all of the BIOS submenus or by using built-in search function. Either it has some entirely different name or there's no setting like that at all.
At this point I realize how much Asus BIOS sucks in terms of naming it's settings. Everything has it's own name different to everyone else's.

Understood. There was some post on Reddit where someone had similar issue to mine and the answer he got was using those drivers. Lesson learned: don't just trust everything people say on Reddit.

So after a few days I actually progressed a bit. After some fiddling around with BIOS settings and my boot options I managed to boot installer. I used the option of booting with open source drivers and after waiting approximately 20 minutes it actually starts booting. Now I have new issues:

  1. When I click Install Garuda Linux it feels like I'm setting some kind of a timer. While I'm going through installation steps at some point the entire system freezes. Not at any particular step but rather after certain period of time. If I don't click Install Garuda Linux it doesn't seem to do that and I can open folders, launch apps, etc.

I managed to overcome this by just waiting. Once my monitor goes to sleep mode I move my mouse, the monitor wakes up and magically the system unfreezes.
It also froze like that while I was adding the screenshot (see further down the post). Fixed it the same way.

  1. Now that I can proceed with the installation i follow the video tutorial linked above and at first it seems like everything is going ok. It actually goes through the installation process but after some time it gives me the error:
    Screenshot_2
1 Like

Ok, I think I won this battle. Garuda was successfully installed.
Turns out the core of the issue was my Windows installation. As I mentioned in OP originally my SSD was MBR and then I converted it to GPT. I thought that Win10 will figure everything out by itself but no. Even when I used flash drive with Win10 it couldn't repair the system because it couldn't find one on my SSD. I had to reinstall Win10 and make sure that it understands that it is installed on GPT disk. Once I did it I installed Garuda alongside and this time there were no errors.
Now with that said I still have an issue with system freezing once in a while and then unfreezing after monitor wakes up. I guess it has something to do with open source drivers, so I'll have to test it out.

Also in case any newbie like me with the same stupid Asus BIOS will have similar issues to mine, here's the list of settings:

  • Boot -> Boot Configuration - > Fast Boot: Disabled
  • Boot -> CSM -> Launch CSM: Enabled (if you disable it, most likely it will re-enable itself after rebooting)
  • Boot -> Secure Boot -> OS Type: Other OS
  • Boot -> Secure Boot -> Key Management -> PK Management: Delete Key
  • Advanced -> SATA Configuration -> SATA Mode: AHCI

After that booting in UEFI mode with open source drivers option should do the trick, although it needs something like 15-20 minutes to skip this screen

starting version 249.2-1 arch

That's it. Thanks to everyone who answered my questions. You're awesome!

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.