Touchpad Settings Won't Persist

hello! I noticed my touchpad speed settings do not persist and reset everytime I restart or shut down, anyway to fix this?

System:
  Kernel: 5.16.1-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=9909eebf-09bb-400d-b4b0-9ff63a8076ea rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: PRIME Z590-A v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 0402
    date: 01/08/2021
Battery:
  Device-1: hid-04:4b:ed:eb:cc:93-battery model: Claudia's Trackpad
    serial: N/A charge: N/A status: Discharging
  Device-2: hid-e0:eb:40:cd:73:bd-battery model: Claudia Cho’s Keyboard
    serial: N/A charge: N/A status: Discharging
CPU:
  Info: model: 11th Gen Intel Core i9-11900K bits: 64 type: MT MCP
    arch: Rocket Lake family: 6 model-id: 0xA7 (167) stepping: 1
    microcode: 0x40
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 640 KiB desc: d-8x48 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 5100 high: 5299 min/max: 800/5300 scaling:
    driver: intel_pstate governor: performance cores: 1: 5091 2: 4963 3: 5010
    4: 5138 5: 5158 6: 5234 7: 5010 8: 5240 9: 4747 10: 5192 11: 4897
    12: 5269 13: 5164 14: 4946 15: 5242 16: 5299 bogomips: 112128
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel RocketLake-S GT1 [UHD Graphics 750] vendor: ASUSTeK
    driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:4c8a class-ID: 0300
  Device-2: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: XFX Pine driver: amdgpu v: kernel bus-ID: 01:00.0
    chip-ID: 1002:67df class-ID: 0300
  Device-3: Logitech BRIO Ultra HD Webcam type: USB
    driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 2-6:2
    chip-ID: 046d:085e class-ID: 0300 serial: <filter>
  Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
    loaded: amdgpu,ati,intel unloaded: modesetting alternate: fbdev,vesa
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3000x1920 s-dpi: 96 s-size: 791x506mm (31.1x19.9")
    s-diag: 939mm (37")
  Monitor-1: DisplayPort-3 res: 1920x1080 hz: 60 dpi: 70
    size: 698x393mm (27.5x15.5") diag: 801mm (31.5")
  Monitor-2: HDMI-A-2 res: 1080x1920
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Tiger Lake-H HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:43c8 class-ID: 0403
  Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: XFX Pine driver: snd_hda_intel v: kernel bus-ID: 01:00.1
    chip-ID: 1002:aaf0 class-ID: 0403
  Device-3: Blue Microphones Yeti Stereo Microphone type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-13:9 chip-ID: b58e:9e84
    class-ID: 0300 serial: <filter>
  Device-4: Logitech BRIO Ultra HD Webcam type: USB
    driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 2-6:2
    chip-ID: 046d:085e class-ID: 0300 serial: <filter>
  Sound Server-1: ALSA v: k5.16.1-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.20 running: no
  Sound Server-4: PulseAudio v: 15.0 running: no
  Sound Server-5: PipeWire v: 0.3.43 running: yes
Network:
  Device-1: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel
    port: N/A bus-ID: 03:00.0 chip-ID: 8086:15f3 class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Broadcom BCM4352 802.11ac Wireless Network Adapter
    vendor: ASUSTeK driver: wl v: kernel modules: bcma bus-ID: 05:00.0
    chip-ID: 14e4:43b1 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
Bluetooth:
  Device-1: Dynex Bluetooth 4.0 Adapter [Broadcom 1.12 BCM20702A0] type: USB
    driver: btusb v: 0.8 bus-ID: 1-11:8 chip-ID: 19ff:0239 class-ID: fe01
    serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
  Local Storage: total: 11.85 TiB used: 421.41 GiB (3.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 2TB
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 3B2QGXA7 temp: 37.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1B6Q scheme: MBR
  SMART Message: Unknown smartctl error. Unable to generate data.
  ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD100EZAZ-11TDBA0 size: 9.1 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
    rev: 0A83 scheme: GPT
  SMART Message: Unknown smartctl error. Unable to generate data.
  ID-4: /dev/sdc maj-min: 8:32 type: USB vendor: Walgreen model: Infinitive
    size: 28.65 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: 1.00 scheme: GPT
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  ID-1: / raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
    used: 410.42 GiB (22.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 25.8 MiB (8.6%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1
  ID-3: /home raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
    used: 410.42 GiB (22.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-4: /var/log raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
    used: 410.42 GiB (22.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-5: /var/tmp raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
    used: 410.42 GiB (22.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.1 GiB used: 2.5 MiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 48.0 C mobo: N/A gpu: amdgpu temp: 38.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 709
Info:
  Processes: 488 Uptime: 29m wakeups: 6 Memory: 31.1 GiB
  used: 9.18 GiB (29.5%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1788 lib: 463 Shell: fish
  v: 3.3.1 running-in: konsole inxi: 3.3.11

 ╭─[email protected] in ~ via  v17.3.0 took 979ms
 ╰─λ ###  Post your terminal/konsole  in- and output as text (***no*** ***pictures***) from:

 ╭─[email protected] in ~ via  v17.3.0 took 979ms
 ╰─λ ~~~
find-the-command: "~~~" is not found locally, searching in repositories...

find-the-command: command not found: ~~~

 ╭─[email protected] in ~ via  v17.3.0 took 299ms
[πŸ”] Γ— inxi -Faz
System:
  Kernel: 5.16.1-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=9909eebf-09bb-400d-b4b0-9ff63a8076ea rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: PRIME Z590-A v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 0402
    date: 01/08/2021
Battery:
  Device-1: hid-04:4b:ed:eb:cc:93-battery model: Claudia's Trackpad
    serial: N/A charge: N/A status: Discharging
  Device-2: hid-e0:eb:40:cd:73:bd-battery model: Claudia Cho’s Keyboard
    serial: N/A charge: N/A status: Discharging
CPU:
  Info: model: 11th Gen Intel Core i9-11900K bits: 64 type: MT MCP
    arch: Rocket Lake family: 6 model-id: 0xA7 (167) stepping: 1
    microcode: 0x40
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 640 KiB desc: d-8x48 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 4676 high: 5259 min/max: 800/5300 scaling:
    driver: intel_pstate governor: performance cores: 1: 5117 2: 3460 3: 4938
    4: 5227 5: 4901 6: 4961 7: 5121 8: 4947 9: 3135 10: 5259 11: 5004
    12: 2709 13: 5011 14: 5022 15: 5052 16: 4960 bogomips: 112128
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel RocketLake-S GT1 [UHD Graphics 750] vendor: ASUSTeK
    driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:4c8a class-ID: 0300
  Device-2: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: XFX Pine driver: amdgpu v: kernel bus-ID: 01:00.0
    chip-ID: 1002:67df class-ID: 0300
  Device-3: Logitech BRIO Ultra HD Webcam type: USB
    driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 2-6:2
    chip-ID: 046d:085e class-ID: 0300 serial: <filter>
  Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
    loaded: amdgpu,ati,intel unloaded: modesetting alternate: fbdev,vesa
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3000x1920 s-dpi: 96 s-size: 791x506mm (31.1x19.9")
    s-diag: 939mm (37")
  Monitor-1: DisplayPort-3 res: 1920x1080 hz: 60 dpi: 70
    size: 698x393mm (27.5x15.5") diag: 801mm (31.5")
  Monitor-2: HDMI-A-2 res: 1080x1920
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Tiger Lake-H HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:43c8 class-ID: 0403
  Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: XFX Pine driver: snd_hda_intel v: kernel bus-ID: 01:00.1
    chip-ID: 1002:aaf0 class-ID: 0403
  Device-3: Blue Microphones Yeti Stereo Microphone type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-13:9 chip-ID: b58e:9e84
    class-ID: 0300 serial: <filter>
  Device-4: Logitech BRIO Ultra HD Webcam type: USB
    driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 2-6:2
    chip-ID: 046d:085e class-ID: 0300 serial: <filter>
  Sound Server-1: ALSA v: k5.16.1-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.20 running: no
  Sound Server-4: PulseAudio v: 15.0 running: no
  Sound Server-5: PipeWire v: 0.3.43 running: yes
Network:
  Device-1: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel
    port: N/A bus-ID: 03:00.0 chip-ID: 8086:15f3 class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Broadcom BCM4352 802.11ac Wireless Network Adapter
    vendor: ASUSTeK driver: wl v: kernel modules: bcma bus-ID: 05:00.0
    chip-ID: 14e4:43b1 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
Bluetooth:
  Device-1: Dynex Bluetooth 4.0 Adapter [Broadcom 1.12 BCM20702A0] type: USB
    driver: btusb v: 0.8 bus-ID: 1-11:8 chip-ID: 19ff:0239 class-ID: fe01
    serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
  Local Storage: total: 11.85 TiB used: 421.41 GiB (3.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 2TB
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 3B2QGXA7 temp: 37.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1B6Q scheme: MBR
  SMART Message: Unknown smartctl error. Unable to generate data.
  ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD100EZAZ-11TDBA0 size: 9.1 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
    rev: 0A83 scheme: GPT
  SMART Message: Unknown smartctl error. Unable to generate data.
  ID-4: /dev/sdc maj-min: 8:32 type: USB vendor: Walgreen model: Infinitive
    size: 28.65 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: 1.00 scheme: GPT
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  ID-1: / raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
    used: 410.42 GiB (22.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 25.8 MiB (8.6%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1
  ID-3: /home raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
    used: 410.42 GiB (22.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-4: /var/log raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
    used: 410.42 GiB (22.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-5: /var/tmp raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
    used: 410.42 GiB (22.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.1 GiB used: 2.5 MiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 48.0 C mobo: N/A gpu: amdgpu temp: 38.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 709
Info:
  Processes: 488 Uptime: 30m wakeups: 6 Memory: 31.1 GiB
  used: 9.21 GiB (29.6%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1788 lib: 463 Shell: fish
  v: 3.3.1 running-in: konsole inxi: 3.3.11

Maybe check if this helps:

Just found via forum search, I have no idea of what that options psmouse proto=imps in the last post is for. If not working, make sure to revert to the previous status...

Tip of the day: :wink:
If you're fighting against proper formatting of inxi, you might rework your initial post using
~~~
[copy your inxi here]
~~~
That ~~~ is not a linux command :slight_smile:

4 Likes

Btw, do you use touchpad in desktop?
Paste output of

xinput list

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.