Touchpad scrolling sensitivity too high, newbie

Hello. I'm really new to Linux and i recently installed Garuda. The scroll sensitivity is really high and I've read other discussions on it but I can't really figure it out on my own.

System:    Kernel: 5.15.5-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: KDE Plasma 5.23.3
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: HUAWEI product: HN-WX9X v: M1010 serial: <superuser required>
Mobo: HUAWEI model: HN-WX9X-PCB v: M1010 serial: <superuser required> UEFI: HUAWEI v: 1.13
date: 09/04/2020
Battery:   ID-1: BAT0 charge: 10.3 Wh (31.1%) condition: 33.1/41.2 Wh (80.3%) volts: 11.0 min: 11.4
model: DYNAPACK HB4593J6ECW status: Discharging
CPU:       Info: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx bits: 64 type: MT MCP
arch: Zen rev: 1 cache: L2: 2 MiB
flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 33537
Speed: 1222 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 1: 1341 2: 1330
3: 1243 4: 1327 5: 1227 6: 1223 7: 1385 8: 1397
Graphics:  Device-1: AMD Picasso vendor: Huawei driver: amdgpu v: kernel bus-ID: 03:00.0
Device-2: IMC Networks HD Camera type: USB driver: uvcvideo bus-ID: 3-2:3
Display: x11 server: X.Org driver: loaded: amdgpu,ati unloaded: modesetting
resolution: 2160x1440~60Hz
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Huawei driver: snd_hda_intel
v: kernel bus-ID: 03:00.1
Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Huawei
driver: snd_pci_acp3x v: kernel bus-ID: 03:00.5
Device-3: AMD Family 17h HD Audio vendor: Huawei driver: snd_hda_intel v: kernel
bus-ID: 03:00.6
Sound Server-1: ALSA v: k5.15.5-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: & Tele RSH
driver: rtw_8822ce v: N/A port: 2000 bus-ID: 01:00.0
IF: wlp1s0 state: up mac: <filter>
Bluetooth: Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 3-1:2
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:    Local Storage: total: 238.47 GiB used: 8.49 GiB (3.6%)
ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB256HAHQ-00000 size: 238.47 GiB temp: 35.9 C
Partition: ID-1: / size: 53.71 GiB used: 8.45 GiB (15.7%) fs: btrfs dev: /dev/nvme0n1p7
ID-2: /boot/efi size: 96 MiB used: 37 MiB (38.5%) fs: vfat dev: /dev/nvme0n1p1
ID-3: /home size: 53.71 GiB used: 8.45 GiB (15.7%) fs: btrfs dev: /dev/nvme0n1p7
ID-4: /var/log size: 53.71 GiB used: 8.45 GiB (15.7%) fs: btrfs dev: /dev/nvme0n1p7
ID-5: /var/tmp size: 53.71 GiB used: 8.45 GiB (15.7%) fs: btrfs dev: /dev/nvme0n1p7
Swap:      ID-1: swap-1 type: zram size: 6.78 GiB used: 0 KiB (0.0%) dev: /dev/zram0
Sensors:   Message: No sensor data found. Is lm-sensors configured?
Info:      Processes: 273 Uptime: 17m Memory: 6.78 GiB used: 2.2 GiB (32.5%) Init: systemd Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: 1135 Shell: fish v: 3.3.1 inxi: 3.3.09

Hi there, welcome!
Have you already checked in the system settings, searching for both touchpad and mouse?
You could also give a look here:


synclient is your friend. Touchpad Synaptics - ArchWiki

1 Like

theres just so much going on its all overwhelming to me, could u pls explain what i am to do?

i cant find the download button :confused:

Not really? If the KDE mouse/touchpad settings don't give you adequate control you need to use something like synclient which is a command line application.

You can't find a download button because that's not how you install things in Linux.

Open a terminal and type synclient. It will either run or give you the command not found. If your touchpad is compatible it's most likely already installed. You will have to read the docs to learn how to tweak with it. Synclient will let you set all the scroll types, speeds, clicks taps. It's kinda lame the mouse panels never give you all the options it controls but that's how it is.

To install things in an Arch Linux distro (which Garuda is) you will use sudo pacman -S "the thing you want" or pamac-manager for a clicky clicky GUI.

1 Like

Open a "Konsole" (what it's called in KDE)
try typing synclient. if it poops out a bunch of info you're part the way there. If it gives you command not found you will need to install it. So in Konsole type
sudo pacman -S xf86-input-synaptics

The caveat to this is if it wasn't auto installed it may mean your touchpad won't be supported by it. I've yet to see one that wasn't but there's always a first time and I didn't see specifics in the system info dump.

1 Like

do these have anything to do with the sensitivity?

No but there are a million settings past that ... heh do synclient --help and some reading. There is normally options for vert and horizonal scrolling, the speeds, finger triggers yada yada. iirc it even allows that whacky spiral swirl or crank scrolling. I have to use it every time I redo any of the zillion laptops for my roommates because they are lefties. The mouse/touchpad panel will let you set left handed but that doesn't set the tap (which is serious wtf). So I use synclient to set everything up. You'll need to find the scroll settings, enter the new commands a few times till you find what feels right then add the command to your session login.

I gotta jet here in a few but I'll check back before I take off. Hopefully this gets you started though. Just take a deep breath, do some reading. We'll get it figured. May just take some time. But once you know you know.


ill try that out, thanks haha!

tried synclient --help, returned this error
synclient: invalid option -- '-'
Usage: synclient [-h] [-l] [-V] [-?] [var1=value1 [var2=value2] ...]
-l List current user settings
-V Print synclient version string and exit
-? Show this help message
var=value Set user parameter 'var' to 'value'.

-h is probably what you want then :wink: Some things like --help some -h

You can also just read the man page online synclient(1) - Linux man page

Or if you want to read the man(ual) page in your terminal just type man synclient

That man page sucks, I checked a few and none list all the actual options so I wager you will want to do synclient -l to list everything. Then you will have to look for all the scroll options like momentum, speeds, yada.

If there is too much info from the -l option you can try to narrow things like:
synclient -l | grep scroll
or maybe
synclient -l | grep speed
synclient -l | grep WHY WON'T YOU JUST DAMN DO WHAT I WANT :wink:

Hopefully this helps you get under way. Don't worry about being new or overwhelmed. We've all been there. Welcome to Linux and Garuda :wink:

One last thing before I go. This might be silly to mention but don't think you have to note EVERY setting to change the ones you want. When you find the settings you want you don't have to synclient option1 option2 option3 option4 till you have like all 500 options populated. Just synclient VerticalScrollSpeed = 1.2 will do. Also I don't know if VerticalScrollSpeed is a real option just tossing it out as an example to just change what you want to change and you can leave the rest alone.

So for example on my roommates machine I just change
synclient TapButton1=1 TapButton2=3 TapButton3=2
synclient TapButton1=3 TapButton2=3 TapButton3=3

That might look odd but I was lazy the other day and her touch pad sucks. It doesn't do multi touch and I can't remember which tap is the normal tap so I just set left handed in the normal mouse panel in settings then added the synclient so any tap (which her touchpad only accepts one) is button 3, which when set to left handed is the normal "right click" (left click if you're right handed) you expect when taping or tap/hold/drag etc.


Maybe try to change VertScrollDelta like here. Of course with synclient or configuration file.

1 Like

i tried running synclient -l grep scroll, synclient -l grep scroll=100 and synclient VertScrollDelta=100 (looked this up online) among many other commands and this keeps coming up "Couldn't find synaptics properties. No synaptics driver loaded?".

What does it mean and how do I get around it?

i tried synclient VertScrollDelta and synclient VertScrollDelta=100 and this keeps showing up "Couldn't find synaptics properties. No synaptics driver loaded?"


Maybe you need to install as suggested by @anon92996653
sudo pacman -S xf86-input-synaptics

1 Like


Auch... Anyway, always reboot after installing something driver-related (or at least restart X).
If that doesn't help, check if this helps...

sudo ln -s /etc/X11/xorg.conf.d/70-synaptics.conf -> /usr/share/X11/xorg.conf.d/70-synaptics.conf

1 Like

did i do something wrong or am i a lost cause? :joy:
(yes i did restart after installing the thingy)

Just copy and paste terminal output as text here :slight_smile: