Touch pad recognised but can't be used

Trying to follow the forum guide but also writing this on my phone so apologies if I miss anything or its not quite 1 for 1.

Lenovo Yoga Slim 7

Unlocked Bios with S3 enabled

6 core AMD Ryzen 5 4500U Zen 2
Full AMD retpoline

Downloaded the iso went to install no touch pad. Thought maybe it was a bad iso

Searched saw someone with a Toshiba saying edit a conf file and another say they had a Lenovo and it was fine.

Redownloaded iso as a torrent formatted the usb before using Etcher and flashed.

Boot all looks OK still no touch pad :thinking:

Libinput list-devices

Elan touchpad
Kernel /dev/input/events
Group 8
Seat 0 default
Size 104x61
Capability pointer gesture

Tap and drag enabled all other options disabled
Calibration n/a
Accel profile flat adaptive
Scroll method and click method both correct

What is stopping it from working ?

Ubuntu, Debian, Fedora, OpenSuse all worked out of the box.

Would really like to try this distro but I Sort of need the touchpad.

Still trying to find my feet with Linux but thought this project looked amazing thanks for any help you can provide.

Welcome :slight_smile:

Search your model, maybe you must downgrade your BIOS.

https://wiki.archlinux.org/title/Laptop/Lenovo

1 Like

Thank you for your reply

Yes I did see that but that is for the pro model mine is the model above in that list, the ryzen 5 model not ryzen 7. The post suggests everything should be fine apart from the suspend issue but I have fixed that by enabling s3.

Any thoughts as to what could be the cause? If I boot straight back into fedora 34 everything is fine

If there are any commands I can run that would provide more detail to help I can do that too I'm just unsure where to look.

Please write the exact Lenovo name for the helpers
as well as output from

inxi -Faz

please.

Lenovo Yoga Slim 7 (AMD Ryzen 5)

Lenovo Part number:82A2008FAU

           parameters: BOOT_IMAGE=(hd0,gpt2)/vmlinuz-5.13.13-200.fc34.x86_64 root=UUID=d740289e-d35e-4c29-aaec-141ede3861fe ro 
           rootflags=subvol=root rd.luks.uuid=luks-dd58da0f-0956-4e61-9241-d90d9a452106 rhgb quiet 
           Desktop: GNOME 40.4 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 Distro: Fedora release 34 (Thirty Four) 
Machine:   Type: Laptop System: LENOVO product: 82A2 v: Yoga Slim 7 14ARE05 serial: <filter> Chassis: type: 10 
           v: Yoga Slim 7 14ARE05 serial: <filter> 
           Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN serial: <filter> UEFI: LENOVO v: DMCN38WW date: 01/18/2020 
Battery:   ID-1: BAT1 charge: 57.9 Wh (95.4%) condition: 60.7/60.7 Wh (100.0%) volts: 17.1 min: 15.4 model: Celxpert L19C4PF4 
           type: Li-poly serial: <filter> status: Discharging cycles: 3 
CPU:       Info: 6-Core model: AMD Ryzen 5 4500U with Radeon Graphics bits: 64 type: MCP arch: Zen 2 family: 17 (23) 
           model-id: 60 (96) stepping: 1 microcode: 8600106 cache: L2: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 28449 
           Speed: 2421 MHz min/max: 1400/2375 MHz boost: enabled Core speeds (MHz): 1: 2421 2: 1383 3: 1878 4: 1397 5: 1397 
           6: 1397 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Renoir vendor: Lenovo driver: amdgpu v: kernel bus-ID: 03:00.0 
           chip-ID: 1002:1636 class-ID: 0300 
           Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo bus-ID: 1-4:2 chip-ID: 13d3:5419 class-ID: fe01 
           serial: <filter> 
           Display: wayland server: X.Org 1.21.1.2 compositor: gnome-shell driver: loaded: amdgpu 
           note: n/a (using device driver) - try sudo/root display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3") s-diag: 583mm (23") 
           Monitor-1: XWAYLAND0 res: 1920x1080 hz: 60 dpi: 157 size: 310x170mm (12.2x6.7") diag: 354mm (13.9") 
           OpenGL: renderer: AMD RENOIR (DRM 3.41.0 5.13.13-200.fc34.x86_64 LLVM 12.0.1) v: 4.6 Mesa 21.1.7 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Renoir Radeon High Definition Audio vendor: Lenovo driver: snd_hda_intel 
           v: kernel bus-ID: 03:00.1 chip-ID: 1002:1637 class-ID: 0403 
           Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo 
           driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480 
           Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403 
           Sound Server-1: ALSA v: k5.13.13-200.fc34.x86_64 running: yes 
           Sound Server-2: PipeWire v: 0.3.34 running: yes 
Network:   Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 01:00.0 chip-ID: 8086:2723 class-ID: 0280 
           IF: wlp1s0 state: up mac: <filter> 
           IF-ID-1: virbr0 state: down mac: <filter> 
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-4:2 chip-ID: 8087:0029 class-ID: e001 
           Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block: hardware: no software: yes 
           address: see --recommends 
Drives:    Local Storage: total: 953.87 GiB used: 105.01 GiB (11.0%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLB1T0HBLR-000L2 size: 953.87 GiB block-size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 3L1QEXF7 temp: 33.9 C 
           scheme: GPT 
Partition: ID-1: / raw-size: 952.27 GiB size: 952.27 GiB (100.00%) used: 104.73 GiB (11.0%) fs: btrfs dev: /dev/dm-0 
           maj-min: 253:0 mapped: luks-dd58da0f-0956-4e61-9241-d90d9a452106 
           ID-2: /boot raw-size: 1024 MiB size: 975.9 MiB (95.30%) used: 266.8 MiB (27.3%) fs: ext4 dev: /dev/nvme0n1p2 
           maj-min: 259:2 
           ID-3: /boot/efi raw-size: 600 MiB size: 598.8 MiB (99.80%) used: 16.1 MiB (2.7%) fs: vfat dev: /dev/nvme0n1p1 
           maj-min: 259:1 
           ID-4: /home raw-size: 952.27 GiB size: 952.27 GiB (100.00%) used: 104.73 GiB (11.0%) fs: btrfs dev: /dev/dm-0 
           maj-min: 253:0 mapped: luks-dd58da0f-0956-4e61-9241-d90d9a452106 
Swap:      Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
           ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 34.4 C mobo: N/A gpu: amdgpu temp: 33.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 330 Uptime: 25m wakeups: 1 Memory: 14.99 GiB used: 4.31 GiB (28.8%) Init: systemd v: 248 runlevel: 5 
           target: graphical.target tool: systemctl Compilers: gcc: 11.2.1 Packages: note: see --pkg flatpak: 18 Shell: Bash 
           v: 5.1.0 running-in: gnome-terminal inxi: 3.3.06~~~

If you include terminal outputs in your post please use the proper output format in your post. Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.

Please edit your post. :slight_smile:

1 Like

Please try with this blacklist

Source
https://wiki.archlinux.org/title/Lenovo_Yoga_Slim_7_(AMD_Ryzen_7)#Touchpad

Thanks but I'm not sure how to do that from the terminal.

I rebooted into my fedora install loaded garuda in a VM and the touchpad works perfectly while in the VM which seems odd. Same ISO just one is flashed on a USB the other in a VM

For the 3 steps in the linked thread, use

sudo micro /etc/modprobe.d/blacklist.conf

This will create/edit the file, so that you can enter there blacklist elan_i2c, save, exit, reboot.

1 Like

Ok will give it a go now and let you know if it works :slight_smile:

No change sorry issue is still present :upside_down_face: would appear even a noob friendly arch can still be tricky :rofl:

Sorry, the Arch wiki rarely fails.
And misteriously for this user the blacklist seems to have worked

Maybe you could check this arch forum thread. It is not solved, but seems to work with X (you don't have wayland). Not clear to me which one of the two suggestions...
https://bbs.archlinux.org/viewtopic.php?id=267809
Finally you could try different kernels.
The newer the better probably in these cases.
I'd say linux-mainline or even linux-next
You can do this with the Garuda assistant.
No other ideas... :pensive:

It is a brand new laptop and I think the guys are catching up squishing bugs even in linux-next for the majority of the AMD-powered laptops at the moment. Probably just keep the image as a VM rotation and wait for a few updates, then when most current issues are resolved look at switching again but for now, the current distro is rock solid. Love the work though and even in the VM, it is the best-looking distro out currently with the most baked-in functionality I've seen.