Top bar disappears or loses transparency randomly

The top bar in the Plasma desktop randomly loses its transparency and becomes black or sometimes disappears altogether. At times it is fixed by a reboot, at times it's not. Please help me fix this. Thanks!

Output for garuda-inxi

System:
  Kernel: 5.16.10-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=8dcf10f3-a757-48a0-be6b-617f5baccb56 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Console: pty pts/1 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
    base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 80QQ v: Lenovo ideapad 100-15IBD
    serial: <filter> Chassis: type: 10 v: Lenovo ideapad 100-15IBD
    serial: <filter>
  Mobo: LENOVO model: Nano 5B6 v: NO DPK serial: <filter>
    UEFI-[Legacy]: LENOVO v: E0CN45WW date: 01/13/2016
Battery:
  ID-1: BAT0 charge: 16.8 Wh (100.0%) condition: 16.8/30.1 Wh (55.7%)
    volts: 16.1 min: 14.4 model: ANYO 15S4A01 type: Li-poly serial: <filter>
    status: Full
CPU:
  Info: model: Intel Core i3-5005U socket: BGA1168 (U3E1) note: check
    bits: 64 type: MT MCP arch: Broadwell family: 6 model-id: 0x3D (61)
    stepping: 4 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1440 high: 1894 min/max: 500/1900 base/boost: 2000/2000
    scaling: driver: intel_cpufreq governor: schedutil volts: 0.8 V
    ext-clock: 100 MHz cores: 1: 1098 2: 1611 3: 1159 4: 1894 bogomips: 15963
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel HD Graphics 5500 vendor: Lenovo driver: i915 v: kernel
    bus-ID: 00:02.0 chip-ID: 8086:1616 class-ID: 0300
  Device-2: IMC Networks Lenovo EasyCamera type: USB driver: uvcvideo
    bus-ID: 2-6:3 chip-ID: 13d3:5744 class-ID: 0e02
  Display: server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
    loaded: intel unloaded: modesetting alternate: fbdev,vesa display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
    s-diag: 414mm (16.3")
  Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5")
    diag: 389mm (15.3")
  OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2)
    v: 4.6 Mesa 21.3.6 direct render: Yes
Audio:
  Device-1: Intel Broadwell-U Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
  Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
    class-ID: 0403
  Sound Server-1: ALSA v: k5.16.10-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: yes
  Sound Server-3: PipeWire v: 0.3.47 running: yes
Network:
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Lenovo
    driver: r8169 v: kernel port: 4000 bus-ID: 02:00.0 chip-ID: 10ec:8136
    class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Lenovo
    driver: rtl8723be v: kernel port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:b723
    class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
Bluetooth:
  Device-1: Realtek RTL8723B Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 2-7:4 chip-ID: 0bda:b728 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
  Local Storage: total: 409.89 GiB used: 19.36 GiB (4.7%)
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WDS120G2G0A-00JH30 family: WD Blue / Red / Green SSDs
    size: 111.8 GiB block-size: physical: 512 B logical: 512 B sata: 3.2
    speed: 6.0 Gb/s type: SSD serial: <filter> rev: 0000 temp: 28 C
    scheme: MBR
  SMART: yes state: enabled health: PASSED on: 225d 22h cycles: 2315
  ID-2: /dev/sdb maj-min: 8:16 vendor: Toshiba model: MK3276GSX
    family: 2.5" HDD MK..76GSX size: 298.09 GiB block-size: physical: 512 B
    logical: 512 B sata: 2.6 speed: 3.0 Gb/s type: HDD rpm: 5400
    serial: <filter> rev: 1X temp: 27 C scheme: MBR
  SMART: yes state: enabled health: PASSED cycles: 229
Partition:
  ID-1: / raw-size: 111.79 GiB size: 111.79 GiB (100.00%)
    used: 19.36 GiB (17.3%) fs: btrfs block-size: 4096 B dev: /dev/sda1
    maj-min: 8:1
  ID-2: /home raw-size: 111.79 GiB size: 111.79 GiB (100.00%)
    used: 19.36 GiB (17.3%) fs: btrfs block-size: 4096 B dev: /dev/sda1
    maj-min: 8:1
  ID-3: /var/log raw-size: 111.79 GiB size: 111.79 GiB (100.00%)
    used: 19.36 GiB (17.3%) fs: btrfs block-size: 4096 B dev: /dev/sda1
    maj-min: 8:1
  ID-4: /var/tmp raw-size: 111.79 GiB size: 111.79 GiB (100.00%)
    used: 19.36 GiB (17.3%) fs: btrfs block-size: 4096 B dev: /dev/sda1
    maj-min: 8:1
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 3.75 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 54.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 233 Uptime: 5m wakeups: 1 Memory: 3.75 GiB
  used: 1.77 GiB (47.3%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1487 lib: 362
  Shell: garuda-inxi (sudo) default: Bash v: 5.1.16 running-in: alacritty
  inxi: 3.3.12
Garuda (2.5.4-2):
  System install date:     2022-02-13
  Last full system update: 2022-02-19
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:

Consider that you can reset latte (panel and dock) to the default setting from the Garuda Assistant + log off/on.
Did you happen to add widgets to your panel?
If so, you could try removing them and check if the panel becomes stable. Then you add them one-by-one to try and find a possible culprit.

2 Likes

Hi, I haven't added any widgets to the panel. I'm resetting it to the default setting and trying again. Thanks!

Tried resetting the configs but I still get a black bar

you probably played a game and your composiiting was disabled.
go to plasma systemsettings -> screens -> compositor and enable it

3 Likes

Hi, I just checked, the compositor is turned on. I didn't play a game, although I've noticed this occurs frequently after I full screen a window.

This might be a mix of properties and themes, e g. for color scheme. Maybe try to give a look here:

1 Like

I also have a similar problem to yours. From a fresh install from ISO the top latte panel's translucency is erratic. This happens on 1 physical machine and 1 VM, but very very very rarely happens on my primary machine (thank god).

I believe this has something to do with inconsistencies in latte's features. Now how do I paste a picture again so I don't get fired at by doing it the wrong way.... ha, funny, I didn't find anything searching the forums nor the wiki, I must be looking in the wrong place. Oh well let's use some elbow grease then:

Right-click on Latte's top bar, APPEARENCE tab and then at the bottom Prefer opaque background when touching any window + Hide background when not needed + Busy Opacity slider a little bit up.

These settings will play a role on how the panel's translucency behaves.
See if any change there suits your needs. If it still doesn't behave as it should, I suggest to open an issue at latte's github page. Oh no wait, they moved it to KDE bugtracker now Log in to KDE Bugtracking System

2 Likes

Hi, all of the options you mentioned are turned on by default in my install. I think I'll open an issue, maybe?

Try turning them off. If it gets stable when off (of course it will have a black or-so background all the time then) and when you re-enable it gets unstable, then yes opening an issue would be what I'd do in that situation.

4 Likes

Turning them off does make the bar stable. Though I don't get the dynamic color changing, I still get the transparent bar whether there are apps opened or not. Works for me. Thanks for the suggestion!

Same behaviour for me as well at that other machine I have.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.