Timeshift-autosnap not working , and pacman is not installing anything

Selected default snapshot type: BTRFS

timeshift-autosnap not working , and pacman is not installing anything

E: System disk not found!
Unable to run timeshift-autosnap! Please close Timeshift and try again. Script will now exit...
error: command failed to execute correctly
error: failed to commit transaction (failed to run transaction hooks)
Errors occurred, no packages were upgraded.

2 Likes

Please close Timeshift and try again.

okay
I'll try it again

was not running

:: Running pre-transaction hooks...
(1/1) Creating Timeshift snapshot before upgrade...
E: ts: Failed to get partition list.
First run mode (config file not found)
Selected default snapshot type: BTRFS
E: System disk not found!
Unable to run timeshift-autosnap! Please close Timeshift and try again. Script will now exit...
error: command failed to execute correctly
error: failed to commit transaction (failed to run transaction hooks)
Errors occurred, no packages were upgraded.

more info now

Do not type/post like in chat style, please
If you include terminal outputs in your post please use the proper output format in your post. Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.

Try reboot or

sudo killall timeshift

@mrsentry did you try reboot?

 ╰─λ sudo killall timeshift
[sudo] password for string:
timeshift: no process found ~~~
1 Like

Yes I rebooted twice

This is the part to be investigated, I guess

2 Likes

Do you change btrfs to ext4 or something?

Edit:

sudo lsblk --paths --tree --include 8 --output uuid,name,fstype,label,mountpoint
1 Like

No sir, nothing at all

╰─λ sudo lsblk --paths --tree --include 8 --output uuid,name,fstype,label,mountpoint
[sudo] password for string:
UUID                                 NAME        FSTYPE LABEL      MOUNTPOINT
                                     /dev/sda
2FAA-3F0C                            ├─/dev/sda1 vfat   EFI
67B3696C607D3B9C                     ├─/dev/sda2 ntfs   fail
09E2024909E20249                     └─/dev/sda3 ntfs   Old-D      /run/media/string/Old-D
                                     /dev/sdb
B4B43C87B43C4E5C                     ├─/dev/sdb1 ntfs   baracuda
1A74B2C174B29EC7                     └─/dev/sdb2 ntfs   ■■■■■■
                                     /dev/sdc
0EBD11360EBD1136                     ├─/dev/sdc1 ntfs   duh
10251A3110251A31                     └─/dev/sdc2 ntfs   Otherhalf
                                     /dev/sdd
7C7E151A7E14CF30                     └─/dev/sdd1 ntfs   PNY-SSD
                                     /dev/sde
B6A6B1FAA6B1BAE7                     └─/dev/sde1 ntfs   New Volume
                                     /dev/sdf
                                     ├─/dev/sdf1
844CF68D4CF6796E                     ├─/dev/sdf2 ntfs   New Backup
26E8B915E8B8E3E9                     └─/dev/sdf5 ntfs   SHIT

My main 2 systems are on a nvme drive

My main systems Linux and win10 are on a nvme drive

Since we don't know when the error started, I would say try a restoration (last working snapshot).

sudo timeshift --list

But there is no Garuda, post always in and output from terminal.

 ╰─λ sudo timeshift --list
[sudo] password for string:
E: ts: Failed to get partition list.
First run mode (config file not found)
Selected default snapshot type: BTRFS
E: ts: Failed to get partition list.

** (process:306590): CRITICAL **: 09:19:43.696: snapshot_repo_construct_from_device: assertion 'dev != NULL' failed

** (process:306590): CRITICAL **: 09:19:43.697: snapshot_repo_print_status: assertion 'self != NULL' failed

** (process:306590): CRITICAL **: 09:19:43.697: snapshot_repo_has_snapshots: assertion 'self != NULL' failed
No snapshots found

SGS I have to go for a few be back later today, Thank You for Your help. sorry i cannot help it

There is no Btrfs, there is no Timeshift, there is no Garuda Linux.

Which OS are you booting into?

Did we already see inxi -azF?

All those partitions are NTFS. Where is your Linux installation?

1 Like

Yes! it is installed on NTFS! :rofl:

3 Likes

This is really strange.
They are not shown above and also no btrfs partition is shown.

Did you happen to make any important update recently?
Especially a BIOS update, that might have reset some important parameters?
I remember some systems need certain settings to show nvme disks, like Sata mode ahci or vdm off.
Maybe also a Windows update can do such nasty things.

1 Like

~~~  ╭─[email protected] in /home/string via  v3.9.5 took 1ms
[🔴] × df -t btrfs
Filesystem     1K-blocks     Used Available Use% Mounted on
/dev/nvme0n1p4 211088728 71361456 137963264  35% /
/dev/nvme0n1p4 211088728 71361456 137963264  35% /home
/dev/nvme0n1p4 211088728 71361456 137963264  35% /root
/dev/nvme0n1p4 211088728 71361456 137963264  35% /srv
/dev/nvme0n1p4 211088728 71361456 137963264  35% /var/cache
/dev/nvme0n1p4 211088728 71361456 137963264  35% /var/log
/dev/nvme0n1p4 211088728 71361456 137963264  35% /var/tmp
~~~lsblk --paths --tree --include 8 --output uuid,name,fstype,label,mountpoint~~~

~~~Attached is the output from inxi -azF rename the file .txt~~~

It looks like your nvme is not shown in lsblk.
According to some search, you could try to use pci=nomsi kernel parameter at boot...

does garuda support ntfs