System wont start after update

Kernel: 6.3.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=9dce7a9d-4c57-49da-b0c8-ab53fb864b71 rw rootflags=subvol=@
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 sysrq_always_enabled=1 ibt=off
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: Gigabyte model: GA-78LMT-S2 R2 v: sex
serial: <superuser required> BIOS: Award v: F3 date: 11/07/2017
Info: model: AMD FX-8300 bits: 64 type: MT MCP arch: Piledriver level: v2
built: 2012-13 process: GF 32nm family: 0x15 (21) model-id: 2 stepping: 0
microcode: 0x6000852
Topology: cpus: 1x cores: 8 smt: enabled cache: L1: 384 KiB
desc: d-8x16 KiB; i-4x64 KiB L2: 8 MiB desc: 4x2 MiB L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 3420 high: 3623 min/max: 1400/3300 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3300 2: 3300
3: 3300 4: 3300 5: 3300 6: 3617 7: 3623 8: 3622 bogomips: 53152
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: NVIDIA GP107 [GeForce GTX 1050] vendor: Micro-Star MSI
driver: nvidia v: 535.54.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
status: current (as of 2023-05) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-21 pcie: gen: 2 speed: 5 GT/s lanes: 16
bus-ID: 01:00.0 chip-ID: 10de:1c81 class-ID: 0300
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 92 s-size: 530x301mm (20.87x11.85")
s-diag: 610mm (24")
Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 92
size: 531x299mm (20.91x11.77") diag: 609mm (23.99") modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 535.54.03 renderer: NVIDIA GeForce GTX
1050/PCIe/SSE2 direct-render: Yes
Device-1: AMD SBx00 Azalia vendor: Gigabyte driver: snd_hda_intel v: kernel
bus-ID: 00:14.2 chip-ID: 1002:4383 class-ID: 0403
Device-2: NVIDIA GP107GL High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
Device-3: Goldvish S.A. GH510 driver: hid-generic,snd-usb-audio,usbhid
type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 6-2:2
chip-ID: 1c1f:231b class-ID: 0300 serial: <filter>
API: ALSA v: k6.3.9-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 0.3.71 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: de00 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 6-3:3
chip-ID: 0a12:0001 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Local Storage: total: 6.02 TiB used: 3.86 TiB (64.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DM010-2EP102
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: CC43 scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Patriot model: Burst size: 111.79 GiB
block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s tech: SSD
serial: <filter> fw-rev: 61.2 scheme: MBR
ID-3: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST3500312CS
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: <unknown>
tech: HDD rpm: 5900 serial: <filter> fw-rev: SC13 scheme: GPT
ID-4: /dev/sdd maj-min: 8:48 vendor: Seagate model: Basic size: 4.55 TiB
block-size: physical: 4096 B logical: 512 B type: USB rev: 2.1 spd: 480 Mb/s
lanes: 1 mode: 2.0 tech: N/A serial: <filter> fw-rev: 0712
ID-1: / raw-size: 111.79 GiB size: 111.79 GiB (100.00%)
used: 55.55 GiB (49.7%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
ID-2: /home raw-size: 111.79 GiB size: 111.79 GiB (100.00%)
used: 55.55 GiB (49.7%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
ID-3: /var/log raw-size: 111.79 GiB size: 111.79 GiB (100.00%)
used: 55.55 GiB (49.7%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
ID-4: /var/tmp raw-size: 111.79 GiB size: 111.79 GiB (100.00%)
used: 55.55 GiB (49.7%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.62 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 31.5 C mobo: N/A gpu: nvidia temp: 40 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 35%
Processes: 271 Uptime: 24m wakeups: 0 Memory: available: 15.62 GiB
used: 3.95 GiB (25.3%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 13.1.1 Packages: 1630 pm: pacman pkgs: 1600
libs: 464 tools: pamac,paru pm: flatpak pkgs: 30 Shell: fish v: 3.6.1
running-in: konsole inxi: 3.3.27
Garuda (2.6.16-1):
System install date:     2023-05-16
Last full system update: 2023-06-24
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       <superuser required>
Failed units:

after an update wont boot in to kde but before the update works fine
what i have done to try to fix it: refreshed keyrings and removed orphans
Packages to update:
autorandr-1.14-1 ddcutil-1.4.1-1 i2c-tools-4.3-4 lib32-brotli-1.0.9-12
lib32-libpng-1.6.40-1 lib32-libssh2-1.11.0-1 lib32-mesa-23.1.3-1 lib32-sdl2-2.28.0-1
libopenmpt-0.7.2-1 libpng-1.6.40-1 libssh2-1.11.0-1 mesa-23.1.3-1 ostree-2023.4-1
pamac-aur-11.0.1-1 pcsclite-2.0.0-1 powerdevil-5.27.6-3 python-cryptography-41.0.1-2
sddm-0.20.0-1 sdl2-2.28.0-1 wine-8.11-1 wolfssl-5.6.3-1

Hi there, welcome to the forum.
Try removing one of these two

When you are in the grub line that you want to use press button E, delete a quiet in the line starting with linux then CTRL+x


No change still wont start the gui

Instead of the quiet quiet try removing splash this time


Ops, THX, I was thinking to that thread but clearly made confusion...


thanks removing splash worked

1 Like

Do you have plymouth-git installed in your system? If yes try changing to plymouth that should fix your issue permanently.


I did a fresh install of KDE Dragonized Gaming Edition today and plymouth-git is the default. I tried swapping to plymouth (22.02.122-7) and rebooting but that didn't fix it. I'm still on plymouth but ended up having to remove splash from my kernel params.

The splash parameter is for plymouth. Did you rebuild your initramfs after changing from plymouth-git to plymouth? I am asking because I have plymouth installed and updated my system yesterday and haven't faced this issue at all.

  1. List all available themes in plymouth
plymouth-set-default-theme -l

which should give something like this

  1. The default for KDE dr460nized is dr460nized set it as plymouth's theme:
sudo plymouth-set-default-theme dr460nized

Replace the dr460nized here with whatever theme you want or is available in the list above.

This should set the theme to default dr460nized

  1. Rebuild your initramfs
sudo dracut-rebuild

restart your system and check if adding splash back to grub kernel parameters works. If it does you can make it permanent again if it doesn't well no harm done you can just reboot normally.

Edit: Thanks for @Jeshu for pointing out the errors in the instructions and that they don't work for people without mkinitcpio. I have changed them and thrice checked them on my system this time sorry for the trouble caused. :sweat:



To write debug output into /var/log/plymouth-debug.log, add the following kernel parameter:


If someone with this Plymouth issue could come forward with a debug log, we could take a look and see if we can figure out what the problem is.

1 Like

Thank you! No, I did not rebuild initramfs. Thank you for the directions to rebuild. Iā€™m away from my desktop but will do this later and report back with splash reinserted.

I know just enough to be dangerous and spent most of my time trying to fix lutris and only a few minutes on this. :slight_smile:

I was able to rebuild my initramfs with plymouth instead of plymouth-git. Adding "splash" back into the bootloader options works perfectly.

The issue here is that plymouth-git and splash seem to be causing the problem. Once switched to plymouth and rebulding initramfs, the issue seems to be resolved.

I had done a fresh install and it seems the current installer includes plymouth-git instead of plymouth. Which one is correct for the installer?

1 Like

Garuda ships plymouth-git out of the box since the plymouth package doesn't recieve updates frequently enough. But living in the bleeding edge world has some disadvantages like this.


I reverted to plymouth-git to help track this down. I have the plymouth-debug log handy, not sure how to upload it. Suggestions welcome!

Scroll up to the top-right corner of this or any other page in the forum to find a link to the Garuda PrivateBin instance where you can paste the log, then link the URL here in the forum thread

1 Like

Here's my plymouth-debug.log. Thank you!!!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.