System update is failing

Hey everyone I am updating my system for the first time after September. I am seeing some conflicts that are causing the update failure. I tried searching the forum and I see a few more have faced similar issue. Though the suggestions there didn’t help. Hence posting it here for help.

Kernel: 6.4.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=e08e8206-5d13-4e01-89e5-8f08e622ebd5 rw rootflags=subvol=@
quiet rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=348a3f97-571a-42b1-a086-75c438dd0c8b loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.7 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Portable System: Dell product: Inspiron 3543 v: A13
serial: <superuser required> Chassis: type: 8 serial: <superuser required>
Mobo: Dell model: 03YYK8 v: A00 serial: <superuser required> UEFI: Dell
v: A13 date: 09/02/2020
ID-1: BAT0 charge: 41.5 Wh (100.0%) condition: 41.5/41.6 Wh (99.8%)
volts: 16.4 min: 14.6 model: SMP-LG2.85 DELL 1C12X31 type: Unknown
serial: <filter> status: full
Info: model: Intel Core i5-5200U bits: 64 type: MT MCP arch: Broadwell
gen: core 5 level: v3 note: check built: 2015-18 process: Intel 14nm
family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 2573 high: 2700 min/max: 500/2700 scaling:
driver: intel_cpufreq governor: performance cores: 1: 2700 2: 2700 3: 2195
4: 2700 bogomips: 17558
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel HD Graphics 5500 vendor: Dell driver: i915 v: kernel
arch: Gen-8 process: Intel 14nm built: 2014-15 ports: active: eDP-1
empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:1616 class-ID: 0300
Device-2: NVIDIA GK208BM [GeForce 920M] vendor: Dell driver: N/A
alternate: nouveau, nvidia_drm, nvidia non-free: series: 470.xx+
status: legacy-active (EOL~2023/24) arch: Kepler code: GKxxx
process: TSMC 28nm built: 2012-18 pcie: speed: Unknown lanes: 63 link-max:
gen: 6 speed: 64 GT/s bus-ID: 08:00.0 chip-ID: 10de:1299 class-ID: 0302
Device-3: Microdia Integrated_Webcam_HD driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-1.5:3
chip-ID: 0c45:670b class-ID: 0e02
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.0
compositor: kwin_x11 driver: X: loaded: modesetting dri: iris gpu: i915
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1280x720 s-dpi: 96 s-size: 338x190mm (13.31x7.48")
s-diag: 388mm (15.27")
Monitor-1: eDP-1 model: Samsung 0x5441 built: 2013 res: 1280x720 hz: 60
dpi: 95 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
ratio: 16:9 modes: 1366x768
API: OpenGL v: 4.6 Mesa 23.1.6-arch1.4 renderer: Mesa Intel HD Graphics
5500 (BDW GT2) direct-render: Yes
Device-1: Intel Broadwell-U Audio vendor: Dell driver: snd_hda_intel
v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Dell
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
class-ID: 0403
Device-3: NVIDIA GK208 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
speed: Unknown lanes: 63 link-max: gen: 6 speed: 64 GT/s bus-ID: 08:00.1
chip-ID: 10de:0e0f class-ID: 0403
API: ALSA v: k6.4.12-zen1-1-zen status: kernel-api tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 0.3.79 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Broadcom BCM43142 802.11b/g/n vendor: Dell Wireless 1704 802.11n
+ BT 4.0 driver: wl v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 bus-ID: 06:00.0 chip-ID: 14e4:4365 class-ID: 0280
IF: wlp6s0 state: up mac: <filter>
Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 4000
bus-ID: 07:00.0 chip-ID: 10ec:8136 class-ID: 0200
IF: enp7s0 state: down mac: <filter>
IF-ID-1: enp0s29u1u3 state: unknown speed: -1 duplex: half mac: <filter>
IF-ID-2: virbr0 state: down mac: <filter>
Device-1: Broadcom BCM43142 Bluetooth 4.0 driver: btusb v: 0.8 type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-1.6:4
chip-ID: 0a5c:21d7 class-ID: fe01 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: N/A
Local Storage: total: 670.7 GiB used: 545.65 GiB (81.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SQ500S37480G
size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: B1H5 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SA400S37240G
size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 0102 scheme: GPT
ID-1: / raw-size: 150 GiB size: 150 GiB (100.00%) used: 64.52 GiB (43.0%)
fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-2: /boot/efi raw-size: 501 MiB size: 500 MiB (99.80%)
used: 580 KiB (0.1%) fs: vfat dev: /dev/sda2 maj-min: 8:2
ID-3: /home raw-size: 292.64 GiB size: 292.64 GiB (100.00%)
used: 264.8 GiB (90.5%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
ID-4: /var/log raw-size: 150 GiB size: 150 GiB (100.00%)
used: 64.52 GiB (43.0%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-5: /var/tmp raw-size: 150 GiB size: 150 GiB (100.00%)
used: 64.52 GiB (43.0%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 7.67 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
ID-2: swap-2 type: partition size: 4 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda1 maj-min: 8:1
System Temperatures: cpu: 53.0 C mobo: 50.0 C
Fan Speeds (rpm): cpu: 0
Processes: 238 Uptime: 10m wakeups: 1 Memory: total: 8 GiB
available: 7.67 GiB used: 2.75 GiB (35.8%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: pm: pacman pkgs: 1802 libs: 421 tools: octopi,paru Shell: fish
v: 3.6.1 running-in: konsole inxi: 3.3.29
Garuda (2.6.16-1):
System install date:     2023-08-02
Last full system update: 2023-09-07
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       Probably (Run as root to verify)
Failed units:            nmb.service smb.service

Below is the terminal output of the failure

:: Synchronizing package databases...
garuda is up to date
core is up to date
extra                                   8.2 MiB   757 KiB/s 00:11 [------------------------------------] 100%
multilib is up to date
chaotic-aur                             2.6 MiB   193 KiB/s 00:14 [------------------------------------] 100%

--> Refreshing mirrorlists using reflector, please be patient..🍵
[2023-10-31 18:44:17] WARNING: failed to rate http(s) download ( The read operation timed out
[2023-10-31 18:44:29] WARNING: failed to rate http(s) download ( Download timed out after 5 second(s).
[2023-10-31 18:44:47] WARNING: failed to rate http(s) download ( Download timed out after 5 second(s).
[2023-10-31 18:44:54] WARNING: failed to rate http(s) download ( Download timed out after 5 second(s).
:: Synchronizing package databases...
garuda downloading...
core downloading...
extra downloading...
multilib downloading...
chaotic-aur downloading...
:: Starting full system upgrade...
:: Replace attica with extra/attica5? [Y/n] y
:: Replace baloo with extra/baloo5? [Y/n] y
:: Replace bluez-qt with extra/bluez-qt5? [Y/n] y
:: Replace exa with extra/eza? [Y/n] y
:: Replace frameworkintegration with extra/frameworkintegration5? [Y/n] y
:: Replace kactivities with extra/kactivities5? [Y/n] y
:: Replace kactivities-stats with extra/kactivities-stats5? [Y/n] y
:: Replace karchive with extra/karchive5? [Y/n] y
:: Replace kauth with extra/kauth5? [Y/n] y
:: Replace kbookmarks with extra/kbookmarks5? [Y/n] y
:: Replace kcalendarcore with extra/kcalendarcore5? [Y/n] y
:: Replace kcmutils with extra/kcmutils5? [Y/n] y
:: Replace kcodecs with extra/kcodecs5? [Y/n] y
:: Replace kcompletion with extra/kcompletion5? [Y/n] y
:: Replace kconfig with extra/kconfig5? [Y/n] y
:: Replace kconfigwidgets with extra/kconfigwidgets5? [Y/n] y
:: Replace kcontacts with extra/kcontacts5? [Y/n] y
:: Replace kcoreaddons with extra/kcoreaddons5? [Y/n] y
:: Replace kcrash with extra/kcrash5? [Y/n] y
:: Replace kdbusaddons with extra/kdbusaddons5? [Y/n] y
:: Replace kde-servicemenus-pdf with chaotic-aur/kf5-servicemenus-pdf? [Y/n] y
warning: kde-servicemenus-pdf-encrypt-decrypt: local (1-1.3) is newer than chaotic-aur (1-1)
:: Replace kdeclarative with extra/kdeclarative5? [Y/n] y
:: Replace kded with extra/kded5? [Y/n] y
:: Replace kdesu with extra/kdesu5? [Y/n] y
:: Replace kdnssd with extra/kdnssd5? [Y/n] y
:: Replace kdoctools with extra/kdoctools5? [Y/n] y
:: Replace kfilemetadata with extra/kfilemetadata5? [Y/n] y
:: Replace kglobalaccel with extra/kglobalaccel5? [Y/n] y
:: Replace kguiaddons with extra/kguiaddons5? [Y/n] y
:: Replace kholidays with extra/kholidays5? [Y/n] y
:: Replace ki18n with extra/ki18n5? [Y/n] y
:: Replace kiconthemes with extra/kiconthemes5? [Y/n] y
:: Replace kidletime with extra/kidletime5? [Y/n] y
:: Replace kimageformats with extra/kimageformats5? [Y/n] y
:: Replace kio with extra/kio5? [Y/n] y
:: Replace kirigami-addons with extra/kirigami-addons5? [Y/n] y
:: Replace kitemmodels with extra/kitemmodels5? [Y/n] y
:: Replace kitemviews with extra/kitemviews5? [Y/n] y
:: Replace kjobwidgets with extra/kjobwidgets5? [Y/n] y
:: Replace knewstuff with extra/knewstuff5? [Y/n] y
:: Replace knotifications with extra/knotifications5? [Y/n] y
:: Replace knotifyconfig with extra/knotifyconfig5? [Y/n] y
:: Replace kpackage with extra/kpackage5? [Y/n] y
:: Replace kparts with extra/kparts5? [Y/n] y
:: Replace kpeople with extra/kpeople5? [Y/n] y
:: Replace kpty with extra/kpty5? [Y/n] y
:: Replace kquickcharts with extra/kquickcharts5? [Y/n] y
:: Replace krunner with extra/krunner5? [Y/n] y
:: Replace kservice with extra/kservice5? [Y/n] y
:: Replace ktexteditor with extra/ktexteditor5? [Y/n] y
:: Replace ktextwidgets with extra/ktextwidgets5? [Y/n] y
:: Replace kunitconversion with extra/kunitconversion5? [Y/n] y
:: Replace kwallet with extra/kwallet5? [Y/n] y
:: Replace kwayland with extra/kwayland5? [Y/n] y
:: Replace kwidgetsaddons with extra/kwidgetsaddons5? [Y/n] y
:: Replace kwindowsystem with extra/kwindowsystem5? [Y/n] y
:: Replace kxmlgui with extra/kxmlgui5? [Y/n] y
y:: Replace libinput_gestures_qt with chaotic-aur/libinput-gestures-qt? [Y/n]
y:: Replace modemmanager-qt with extra/modemmanager-qt5? [Y/n]
:: Replace networkmanager-qt with extra/networkmanager-qt5? [Y/n] y
y:: Replace plasma-framework with extra/plasma-framework5? [Y/n]
:: Replace prison with extra/prison5? [Y/n] y
:: Replace purpose with extra/purpose5? [Y/n] y
y:: Replace qqc2-desktop-style with extra/qqc2-desktop-style5? [Y/n]
:: Replace solid with extra/solid5? [Y/n] y
:: Replace sonnet with extra/sonnet5? [Y/n] y
:: Replace sweet-kde-theme-git with chaotic-aur/plasma5-themes-sweet-kde-git? [Y/n] y
:: Replace sweet-theme-full-git with chaotic-aur/plasma5-themes-sweet-full-git? [Y/n] y
:: Replace syndication with extra/syndication5? [Y/n] y
:: Replace syntax-highlighting with extra/syntax-highlighting5? [Y/n] y
:: Replace threadweaver with extra/threadweaver5? [Y/n] y
warning: virt-manager-meta: local (5-4.2) is newer than garuda (5-4)
warning: whoogle-git: local (_r749.g92e8ede-1) is newer than chaotic-aur (0.8.3.r25.gcdf0b50-1)
yresolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing kio breaks dependency 'kio' required by kipi-plugins
:: removing plasma-framework breaks dependency 'plasma-framework' required by latte-dock-git
:: removing knewstuff breaks dependency 'knewstuff' required by latte-dock-git
:: removing kxmlgui breaks dependency 'kxmlgui' required by libkipi
:: removing kservice breaks dependency 'kservice' required by libkipi
:: removing kauth breaks dependency 'kauth' required by samba-mounter-git
:: removing kcmutils breaks dependency 'kcmutils' required by samba-mounter-git
:: removing kconfig breaks dependency 'kconfig' required by samba-mounter-git
:: removing kio breaks dependency 'kio' required by samba-mounter-git
:: removing ki18n breaks dependency 'ki18n' required by samba-mounter-git
:: removing solid breaks dependency 'solid' required by samba-mounter-git

Everything is covered, although in different topics…

sudo pacman -R kipi-plugins latte-dock-git libkipi samba-mounter-git 

Then again


The your suggestion should work but I got a new issue at the end of the update. Not sure why.

(775/775) checking keys in keyring                                 [------------------------------------] 100%
(775/775) checking package integrity                               [------------------------------------] 100%
(775/775) loading package files                                    [------------------------------------] 100%
(775/775) checking for file conflicts                              [------------------------------------] 100%
error: failed to commit transaction (conflicting files)
cachyos-ananicy-rules-git: /etc/ananicy.d/ananicy.conf exists in filesystem
Errors occurred, no packages were upgraded.

Normally (but check the tutorial, it is very well done):

sudo pacman -S cachyos-ananicy-rules-git --overwrite '*'

Then update again.
Or if you really want to use the brute force :slight_smile:

garuda-update -- --overwrite '*'

Thanks @filo your suggestion seems to have resolved the issue.

1 Like

How angry I am! For several years of using Garuda, I have never seen such a crude and unfinished new version of this System with many bugs! updates are not installed, many programs are not in the repositories, animated effects, mouse cursors freeze, and much more. I reinstalled the version from the previous image and everything was fine!

As I mentioned in my intial post, there are several topics about this problem.
But one of them is an Announcement, so should be read:

All this stuff is the result of Arch packaging renaming activities for KDE, which have been promptly handled by Garuda with the garuda-update package.
All the rest, for example the bunch of packages to be removed here, are due to AUR packages not promptly updated by their maintainers according to the renamings above.
None of these are in the responsibility of the Garuda team or manageable in a different way.
The “bugs” must be due to something else, and should be addressed with proper and specific topics (garuda-inxi, logs, etc.), otherwise nothing can be fixed.


How rude.


Seriously, you are angry because you had to resolve a couple package conflicts? I hate to break it to you, but if you are using KDE there is bound to be even more of this as we move into Plasma 6. :eyes:

Maybe this will be more your speed: Download Linux Mint 21.2 - Linux Mint



I’ll tell it like it is…Yes, I’ve been working on Linux Mint 21.2 and earlier versions for 12 years or even more! And I will say that this Linux distribution is no easier to work with than Garuda and is even better in terms of flexibility of settings. Nevertheless, I like Garuda and I will choose which System to work in myself! And if you want to listen only to flattering reviews of Garuda, then you obviously don’t care about this distribution and you also don’t care that users choose Garuda!

Adding comments like “how angry I am” and talking about how “unfinished and crude” it is doesn’t exactly contribute to someone listening to your “feedback” as it does not help with solving the problem at all. There is a distinct difference between constructive feedback (which can of course hold valid negative criticism) and useless utterances.

Blaming the new version for these packaging issues is also unfair, as they would’ve taken place also without this being called a new version. This is an Arch-based distribution after all and since you are not running pure Arch you might not realize a lot of other things already been taken care of for you.

So, either add useful comments or don’t comment at all, thanks.


Then you know Mint. But you do not know Garuda–not in the same way you know Mint.

But stick around. Immerse yourself in the way things are done in Garuda, and I’ll tell you this for a fact–your voice can have more input into the future direction of Garuda than would ever be possible in Mint.

But you’ve got to be nice about it. Or if not nice, then just decent. And if you can’t be decent, we’d be better off not hearing from you at call. :slight_smile:


If decency for you is sweet flattery and you only listen to pleasant things, then I feel sorry for you! Know how to listen and accept a slightly different point of view and opinion of users. Only a true friend can tell the truth, and only enemies will lie sweetly that everything will be fine!

Accepted! You are partly right!

State words & thoughts not by me, why don’t you? Your divination is not doing very well so far.

‘Decency’ would be a very foreign concept to you, based on how you have acted here.

I Dub Thee TROLL!

And I predict your stay here will be short.

Thread is solved since 2 days.