System stuttering, heavy lag. Freezes upon restart on load

Hey guys, a bit new to linux and Arch in general but have some experience with Debian based systems. Everything was running smoothly on my system for about 2 days, updated some packages and whatnot and a day later I had a nap with a stream running and the system was laggy mouse barely moved, audio still played but couldn't navigate it was so bad. So I hard rebooted and everything starts out fine, but as the loading bar on the screen nears 100% the dragon stops animation and everything freezes. I tried restarting and running a memory test also tried to open with other options in advanced and same story...

Aside from plugging in the flash and running terminal what would I be looking for as to what went wrong or why it was/is acting that way??? It's mind boggling because everything was running so smoothly after I set up everything.

Thanks

Why do you not post your inxi?
You do not read the template?

Again, read

please
and post terminal in- and output from

inxi -Fza

as text!

Even if you personally think it is unnecessary.

and
:slight_smile:

4 Likes

not sure how to do that when the whole system freezes up, as I said, I'm new but I'm certain pressing anything isn't doing anything with the system.

Try booting into / restoring a snapshot taken before your latest update and provide the information please.

2 Likes

Sorry guys, Forgive my ignorance, I thought I had tried all previous images. One of them worked. There is the information:

Kernel: 5.13.4-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/timeshift-btrfs/snapshots/2021-07-24_19-00-02/@/boot/vmlinuz-linux-zen  
root=UUID=6e068ae4-252a-4678-a46c-8bc955e31d59 quiet splash rd.udev.log_priority=3
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
resume=UUID=1be79113-bac2-40b6-88bd-a7a1a209294c loglevel=3
rootflags=defaults,noatime,space_cache,autodefrag,compress=zstd,ssd,subvol=timeshift-btrfs/snapshot
s/2021-07-24_19-00-02/@
Desktop: KDE Plasma 5.22.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Desktop Mobo: ASRock model: X470 Gaming K4 serial: <filter>  
UEFI-[Legacy]: American Megatrends v: P1.00 date: 03/27/2018  
CPU:       Info: 8-Core model: AMD Ryzen 7 2700 bits: 64 type: MT MCP arch: Zen+ family: 17 (23)  
model-id: 8 stepping: 2 microcode: 800820D cache: L2: 4 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 102196  
Speed: 2421 MHz min/max: 1550/3200 MHz boost: enabled Core speeds (MHz): 1: 2421 2: 2585  
3: 3025 4: 2467 5: 2402 6: 2403 7: 3947 8: 2642 9: 2409 10: 2402 11: 2405 12: 2407 13: 2407  
14: 2409 15: 2409 16: 2904  
Vulnerabilities: Type: itlb_multihit status: Not affected  
Type: l1tf status: Not affected  
Type: mds status: Not affected  
Type: meltdown status: Not affected  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2  
mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling  
Type: srbds status: Not affected  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: eVga.com. driver: nvidia v: 470.57.02  
alternate: nouveau,nvidia_drm bus-ID: 26:00.0 chip-ID: 10de:1c03 class-ID: 0300  
Display: x11 server: X.Org 1.20.12 compositor: kwin_x11 driver: loaded: nvidia display-ID: :0  
screens: 1  
Screen-1: 0 s-res: 1920x1080 s-dpi: 92 s-size: 530x301mm (20.9x11.9") s-diag: 610mm (24")  
Monitor-1: DVI-D-0 res: 1920x1080 hz: 60 dpi: 92 size: 531x298mm (20.9x11.7") diag: 609mm (24")  
OpenGL: renderer: NVIDIA GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 470.57.02  
direct render: Yes  
Audio:     Device-1: NVIDIA GP106 High Definition Audio vendor: eVga.com. driver: snd_hda_intel v: kernel  
bus-ID: 26:00.1 chip-ID: 10de:10f1 class-ID: 0403  
Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel v: kernel  
bus-ID: 28:00.3 chip-ID: 1022:1457 class-ID: 0403  
Sound Server-1: ALSA v: k5.13.4-zen2-1-zen running: yes  
Sound Server-2: JACK v: 0.125.0 running: no  
Sound Server-3: PulseAudio v: 14.2 running: yes  
Sound Server-4: PipeWire v: 0.3.32 running: no  
Network:   Device-1: Intel I211 Gigabit Network vendor: ASRock driver: igb v: kernel port: f000  
bus-ID: 1f:00.0 chip-ID: 8086:1539 class-ID: 0200  
IF: enp31s0 state: up speed: 1000 Mbps duplex: full mac: <filter>  
IF-ID-1: anbox0 state: down mac: <filter>
Drives:    Local Storage: total: 2.04 TiB used: 25.52 GiB (1.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37240G size: 223.57 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 71B1 scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST2000DM006-2DM164 size: 1.82 TiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200
serial: <filter> rev: CC26 scheme: MBR
Partition: ID-1: / raw-size: 206.38 GiB size: 206.38 GiB (100.00%) used: 25.52 GiB (12.4%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 206.38 GiB size: 206.38 GiB (100.00%) used: 25.52 GiB (12.4%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 206.38 GiB size: 206.38 GiB (100.00%) used: 25.52 GiB (12.4%)
fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 206.38 GiB size: 206.38 GiB (100.00%) used: 25.52 GiB (12.4%)
fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 17.19 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda2
maj-min: 8:2
ID-2: swap-2 type: zram size: 15.56 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 32.0 C mobo: N/A gpu: nvidia temp: 52 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 7%
Info:      Processes: 360 Uptime: 1m wakeups: 0 Memory: 15.56 GiB used: 1.72 GiB (11.1%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1620 lib: 489 Shell: fish
v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

If you include terminal outputs in your post please use the proper output format in your post. Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.

2 Likes

now currently restarted after using timeshift to recover an old image and I don't have permission to open certain programs

Please open terminal and start the certain programs in terminal and post in and output from terminal as text, please.

Can you please post the output of

sudo btrfs filesystem usage /
sysctl vm.swappiness
sysctl vm.vfs_cache_pressure

You would also need to monitor your system temps when you experience stutter because higher temps could de-crease performance.

VFS cache and Swappiness - FAQ and Tutorials - Garuda Linux Forum

Why "sudo" for sysctl?

1 Like

I apologize i am getting careless.

1 Like