System gives black screen after going to sleep for 3 times

Hello Garuda users.
I use Garuda KDE Dr460nized and recently found a issue, after the system goes to sleep for 3 consecutive times. No matter how that happens (by selecting sleep from application launcher or pressing power button) the 3rd time waking up the laptop leaves the laptop with a black screen. No login window nothing just a black screen and a mouse and this happens exactly the 3rd time machine goes to sleep.

I tried pressing ctrl+alt+F2 to get tty and tried:

killall kwin_x11
sudo systemctl restart sddm

with varying permutations each time just to see if a particular order works.
Which does nothing I just get an error that I failed to restart the sddm service and eventually leads me to reboot.
I tried this a bunch of times with the same result after 3rd sleep machine just goes black screen with no way out but reboot.
I tried googling my problem but received next to no answer in any issues similar to me. (black screen after sleep).

Is there truly no solution for this??

garuda-inxi:

System:
Kernel: 6.0.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=6a7bcee6-f3ae-4c03-b6b0-7cb27fb4c8d4 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=1b9b6f2d-a19b-4eee-b2bf-6af31dfdf566 loglevel=3
Desktop: KDE Plasma v: 5.26.3 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Convertible System: LENOVO product: 81X1 v: IdeaPad Flex 5 14IIL05
serial: <superuser required> Chassis: type: 31 v: IdeaPad Flex 5 14IIL05
serial: <superuser required>
Mobo: LENOVO model: LNVNB161216 v: SDK0Q55722 WIN
serial: <superuser required> UEFI: LENOVO v: ECCN41WW date: 06/27/2022
Battery:
ID-1: BAT0 charge: 9.0 Wh (21.2%) condition: 42.4/52.6 Wh (80.5%)
volts: 10.9 min: 11.5 model: Sunwoda L19D3PD6 type: Li-poly serial: <filter>
status: discharging cycles: 1211
Device-1: wacom_battery_0 model: Wacom HID 5218 serial: N/A charge: 0%
rechargeable: yes status: N/A
CPU:
Info: model: Intel Core i7-1065G7 bits: 64 type: MT MCP arch: Ice Lake
gen: core 10 level: v4 note: check built: 2019-21 process: Intel 10nm
family: 6 model-id: 0x7E (126) stepping: 5 microcode: 0xB6
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 2 MiB desc: 4x512 KiB L3: 8 MiB
desc: 1x8 MiB
Speed (MHz): avg: 1172 high: 1500 min/max: 400/3900 scaling:
driver: intel_pstate governor: powersave cores: 1: 1000 2: 985 3: 1500
4: 1000 5: 1500 6: 998 7: 1500 8: 896 bogomips: 23961
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: Enhanced IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: SW sequence
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel Iris Plus Graphics G7 vendor: Lenovo driver: i915 v: kernel
arch: Gen-11 process: Intel 10nm built: 2019-21 ports: active: eDP-1
empty: DP-1, DP-2, DP-3, HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:8a52
class-ID: 0300
Device-2: NVIDIA GP108M [GeForce MX330] vendor: Lenovo driver: nvidia
v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 520.xx+
status: current (as of 2022-10) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-21 pcie: gen: 1 speed: 2.5 GT/s lanes: 4
link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1d16
class-ID: 0302
Device-3: Acer Integrated Camera type: USB driver: uvcvideo bus-ID: 3-2:2
chip-ID: 5986:212a class-ID: 0e02
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: ChiMei InnoLux 0x1406 built: 2019 res: 1920x1080
hz: 60 dpi: 158 gamma: 1.2 size: 309x173mm (12.17x6.81") diag: 354mm (13.9")
ratio: 16:9 modes: 1920x1080
API: OpenGL v: 4.6 Mesa 22.2.3 renderer: Mesa Intel Iris Plus Graphics
(ICL GT2) direct render: Yes
Audio:
Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Lenovo
driver: sof-audio-pci-intel-icl
alternate: snd_hda_intel,snd_sof_pci_intel_icl bus-ID: 00:1f.3
chip-ID: 8086:34c8 class-ID: 0401
Sound API: ALSA v: k6.0.8-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
Device-1: Intel Ice Lake-LP PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:34f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 3-10:4 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
Local Storage: total: 476.94 GiB used: 27.33 GiB (5.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZALQ512HALU-000L2 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 3L1QFXV7 temp: 30.9 C scheme: GPT
Partition:
ID-1: / raw-size: 459.82 GiB size: 459.82 GiB (100.00%)
used: 27.33 GiB (5.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 459.82 GiB size: 459.82 GiB (100.00%)
used: 27.33 GiB (5.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 459.82 GiB size: 459.82 GiB (100.00%)
used: 27.33 GiB (5.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 459.82 GiB size: 459.82 GiB (100.00%)
used: 27.33 GiB (5.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 16.82 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: swap-2 type: zram size: 15.29 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 58.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 294 Uptime: 17m wakeups: 4 Memory: 15.29 GiB
used: 4.74 GiB (31.0%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1305
libs: 357 tools: octopi,pamac,paru Shell: fish v: 3.5.1 default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.23
Garuda (2.6.9-1):
System install date:     2022-11-12
Last full system update: 2022-11-13
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

Oh, I actually found an exception to my own problem. Closing my laptop lid and then opening it just immediately gives me a black screen no need to wait for the 3rd time.

SDDM is the display manager. I don't believe SDDM handles the lock screen, only the login screen.

You need to boot into Windows and disable "fast startup" in the advance power options menu. See here:

2 Likes

thanks for answering, as for the windows dual boot, I have completely erased windows. I don't have it. Hence, I can't go into windows. Running sudo os-prober too gives no output. So I don't think that should be the problem.

Gotcha, there must just be a few lingering files on the EFI partition or something like that.

What is the output of:

cat /sys/power/mem_sleep

Have you tried any other kernels yet, such as LTS or mainline?

Just curious: if you disable power save tweaks and reboot, does the issue persist?

3 Likes

Here:

cat /sys/power/mem_sleep
File: /sys/power/mem_sleep
s2idle [deep]

I haven't yet but I will try and tell.

I am assuming this is not controlled by any GUI?? Is there any command for this or can you link the doc where I can find the command.

Btw, I tried startx command in tty2 as well but that just made my tty2 go blank. The command generated some logs but it was too fast to read and then the tty2 just black screened. I tried killall kwin_x11 from tty3 with no luck so just had to reboot again.

These values determine whether the machine suspends to RAM or suspends to disk. Try switching to s2idle (suspend to RAM):

sudo echo s2idle | sudo tee /sys/power/mem_sleep

Test and see if it resolves the issue. If it does and you'd like to make it permanent, add to your kernel parameters:

mem_sleep_default=s2idle

You can do that right from Garuda Boot Options:

The drawback is RAM needs to be constantly powered, so while suspending in this mode your machine will continue to draw from the battery. Bear this in mind if you tend to leave your computer for long periods of time without shutting it down or plugging it in.

Actually you can manage this from Garuda Assistant, under the Settings tab:

My offhand guess would be you have either a kernel bug or a firmware bug, so getting onto a different kernel and/or updating your BIOS will be the best long-term fixes without sacrificing power saving features. Your BIOS version is relatively recent, but it can't hurt to check on the Lenovo website to see if they have released any bug fix updates .

5 Likes

Thankyou so much for helping me!! :smile: :smile: it was probably a kernel bug. I switched to linux-lts and all the sleep related issues are gone like magic now. Thankyou so much for helping!!. :smile: .
Could you tell me if there is a way to set the default kernel to boot into garuda? I wish to set it to linux-lts from linux-zen.

You can change it in Garuda Boot Options, with the "Boot to" drop-down menu. :slightly_smiling_face:

3 Likes

Thankyou very much for helping!! :smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.