Bluetooth headphones connection error

I have my Bluetooth earphones and they do not connect to the laptop after a reboot. Every time I delete the instance (PTron BT) and reconfigure the device through the KDE settings app, it works. I can watch YouTube videos, and sound comes fine. My headphones' volume control buttons also control volume without a problem. But every time I reboot the computer, bluetooth breaks. Then I get the following error in the settings menu :

Then forgetting the headphones and repairing works. So is there a way to fix this?

My garuda-inxi is follows:

Kernel: 5.19.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=0504164e-7c45-4bb6-8b98-0b9c553029c2 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=24bf752a-dccf-4e7c-ad66-fbc296ec6364 loglevel=3
Console: pty pts/0 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
base: Arch Linux
Type: Laptop System: Dell product: Dell G15 5510 v: N/A serial:
Chassis: type: 10 serial:
Mobo: Dell model: 0WCM79 v: A01 serial: UEFI: Dell v: 1.15.0
date: 08/05/2022
ID-1: BAT0 charge: 53.8 Wh (98.0%) condition: 54.9/54.9 Wh (100.0%)
volts: 12.8 min: 11.4 model: BYD DELL DVG8M1A type: Li-poly
serial: status: not charging
Info: model: Intel Core i5-10500H bits: 64 type: MT MCP arch: Comet Lake
gen: core 10 level: v3 built: 2020 process: Intel 14nm family: 6
model-id: 0xA5 (165) stepping: 2 microcode: 0xF0
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 3104 high: 4400 min/max: 800/4500 base/boost: 2772/2500
scaling: driver: intel_pstate governor: powersave volts: 0.8 V
ext-clock: 100 MHz cores: 1: 2500 2: 2500 3: 4300 4: 2500 5: 2500 6: 2500
7: 4400 8: 4389 9: 4160 10: 2500 11: 2500 12: 2500 bogomips: 59998
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: Enhanced IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: SW sequence
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Dell driver: i915
v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:9bc4 class-ID: 0300
Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: Dell
driver: nvidia v: 515.76 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-08) arch: Turing code: TUxxx
process: TSMC 12nm built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 8
link-max: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.0
chip-ID: 10de:1f9d class-ID: 0300
Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
bus-ID: 1-5:2 chip-ID: 0c45:6a09 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
unloaded: nouveau alternate: fbdev,intel,nv,vesa gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: Najing CEC Panda 0x005f built: 2021
res: 1920x1080 hz: 120 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 22.1.7
direct render: Yes
Device-1: Intel Comet Lake PCH cAVS vendor: Dell
driver: sof-audio-pci-intel-cnl
alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl
bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0401
Device-2: NVIDIA driver: snd_hda_intel v: kernel pcie: gen: 3
speed: 8 GT/s lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403
Sound Server-1: ALSA v: k5.19.12-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.58 running: yes
Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
IF: wlp0s20f3 state: up mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Dell driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-14:3 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address:
Local Storage: total: 1.38 TiB used: 41.85 GiB (3.0%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: PM991a NVMe
512GB size: 476.94 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: rev: 26304039
temp: 32.9 C scheme: GPT
SMART: yes health: PASSED on: 7d 22h cycles: 182 read-units: 5,743,303
[2.94 TB] written-units: 5,660,115 [2.89 TB]
ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Western Digital model: WD
Elements 25A2 drive model: WD10JMVW-11AJGS4 family: Elements / My
Passport (USB, AF) size: 931.48 GiB block-size: physical: 4096 B
logical: 512 B sata: 3.0 speed: 3.0 Gb/s type: HDD rpm: 5400
serial: drive serial: rev: 1014 drive rev: 01.01A01
temp: 36 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 47d 17h cycles: 358
ID-1: / raw-size: 70 GiB size: 70 GiB (100.00%) used: 21.02 GiB (30.0%)
fs: btrfs block-size: 4096 B dev: /dev/sda3 maj-min: 8:3
ID-2: /boot/efi raw-size: 401 MiB size: 400.2 MiB (99.80%) used: 608 KiB
(0.1%) fs: vfat block-size: 512 B dev: /dev/sda4 maj-min: 8:4
ID-3: /home raw-size: 200 GiB size: 200 GiB (100.00%) used: 20.84 GiB
(10.4%) fs: btrfs block-size: 4096 B dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 70 GiB size: 70 GiB (100.00%) used: 21.02 GiB
(30.0%) fs: btrfs block-size: 4096 B dev: /dev/sda3 maj-min: 8:3
ID-5: /var/tmp raw-size: 70 GiB size: 70 GiB (100.00%) used: 21.02 GiB
(30.0%) fs: btrfs block-size: 4096 B dev: /dev/sda3 maj-min: 8:3
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.41 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda1 maj-min: 8:1
System Temperatures: cpu: 67.0 C pch: 61.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 351 Uptime: 26m wakeups: 2055 Memory: 15.41 GiB used: 3.78 GiB
(24.5%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1651 libs: 496
tools: octopi,paru,yay Shell: garuda-inxi (sudo) default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.21
Garuda (2.6.8-1):
System install date: 2022-09-12
Last full system update: 2022-10-03
Is partially upgraded: No
Relevant software: NetworkManager
Windows dual boot: Yes
Snapshots: Snapper
Failed units:


Any help will be hugely appreciated. Thanks

Here's a link to the screenshot of the KDE settings app - Imgur: The magic of the Internet

Update, I found that this happens only after I use Windows. Garuda works fine on its own, but after I boot into Windows and back, the headphones do not connect. So how to fix it?

I get this some times with my network adapter
just boot garuda and then shutdown then boot into garuda again.
it would seen windows does not always want to release the hardware


This is right, Windows can hold on to hardware resources while hibernating, including the network card.

Make sure you have disabled the fast startup option in the "Choose what the power buttons do" menu in Control Panel, and ensure the power button actually shuts down the computer instead of hibernation or something else. You have to enable changing settings that are unavailable to do it.

I'm not sure how up to date this image is, but here it is:


So I figured out the solution with some googling. Turns out that the Bluetooth adapter uses specific pairing codes to pair with a device. Now I had 1 pairing code for Garuda. But when I booted into Windows and paired them, a new pairing code overwrites the old one.

I fixed it by following the tutorial.

Can you link to the tutorial that solved your issue, for the benefit of future forum searchers?


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.