System Does not Boot

During boot I keep getting stuck at the screen:

Loading Linux Kernel

There's another thing it's loading but I forget the name.

I went search through the forums here and found someone with the same problem. I tried using the solution on there. I'm booted into the Garuda live environment from USB and in Garuda Boot Repair I repaired the GRUB configuration file. When I look at the reinstall option I don't know whether to select MBR or root.

Then I tried to reinstall or refresh the linux kernel headers I think. But the command that was shared in that post I think is old. It's using -Syu and it fails to do anything.

Help please =)

Why so mysterious?
Was it the thread Computer doesn’t boot, boots to a black screen, or stops at a message ?

You can post the garuda-inxi from live ISO.

2 Likes

Apologies

System:
  Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=garuda misolabel=GARUDA_LXQTKWIN_TALON quiet
    systemd.show_status=1 ibt=off systemd.unified_cgroup_hierarchy=1
    driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=1
  Desktop: LXQt v: 1.1.0 tk: Qt v: 5.15.6 info: cairo-dock, lxqt-panel
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Convertible System: LENOVO product: 81EM v: Lenovo ideapad FLEX
    6-14IKB serial: <superuser required> Chassis: type: 31 v: Lenovo ideapad
    FLEX 6-14IKB serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN
    serial: <superuser required> UEFI-[Legacy]: LENOVO v: 7QCN46WW
    date: 11/26/2020
Battery:
  ID-1: BAT0 charge: 33.8 Wh (100.0%) condition: 33.8/45.5 Wh (74.2%)
    volts: 8.4 min: 7.7 model: CPT-COS L17C4PB0 type: Li-poly serial: <filter>
    status: full
  Device-1: wacom_battery_0 model: Wacom HID 517D serial: N/A charge: 0%
    rechargeable: yes status: N/A
CPU:
  Info: model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 8 level: v3 note: check built: 2017 process: Intel 14nm family: 6
    model-id: 0x8E (142) stepping: 0xA (10) microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 1550 high: 1800 min/max: 400/3400 scaling:
    driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 1800
    4: 1800 5: 1800 6: 1800 7: 1800 8: 1800 bogomips: 28800
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
    vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel
    arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1
    empty: DP-1,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:5917 class-ID: 0300
  Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-8:5 chip-ID: 13d3:56b2 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: kwin_x11 driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: AU Optronics 0x403d built: 2016 res: 1920x1080
    hz: 60 dpi: 158 gamma: 1.2 size: 309x173mm (12.17x6.81")
    diag: 354mm (13.9") ratio: 16:9 modes: 1920x1080
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_soc_avs
    bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
  Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: Lenovo
    ThinkPad E595 driver: rtw_8822be v: N/A modules: rtw88_8822be pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 01:00.0
    chip-ID: 10ec:b822 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
Bluetooth:
  Device-1: Realtek RTL8822BE Bluetooth 4.2 Adapter type: USB driver: btusb
    v: 0.8 bus-ID: 1-7:4 chip-ID: 0bda:b023 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 2 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 176.97 GiB used: 0 KiB (0.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZVLW128HEGR-000L2 size: 119.24 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 4L1QCXB7 temp: 29.9 C scheme: MBR
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: SanDisk model: Cruzer Glide
    size: 57.73 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: 1.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  Message: No partition data found.
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.55 GiB used: 285.2 MiB (3.7%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 41.0 C pch: 40.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 218 Uptime: 41m wakeups: 3 Memory: 7.55 GiB used: 2.48 GiB
  (32.9%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1184 libs: 305
  tools: octopi,paru Shell: Bash v: 5.1.16 running-in: qterminal inxi: 3.3.22
warning: database file for 'garuda' does not exist (use '-Sy' to download)
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
warning: database file for 'chaotic-aur' does not exist (use '-Sy' to download)
Garuda (2.6.8-1):
  System install date:     2022-11-04
  Last full system update: 2022-11-04 ↻
  Is partially upgraded:   No                                                                                   
  Relevant software:       NetworkManager
  Windows dual boot:       <superuser required>
  Snapshots:               Snapper
  Failed units:            snapper-cleanup.service

CTRL ALT F2 doesn't work. I came across that post first. There is another post on this topic that was where I got the info to fix the grub loader.

This information isn't specific enough to be useful. Instead of "I think I did this, whatever I did didn't work" you should copy and paste the exact commands and outputs into the thread so we can see what is happening.

2 Likes

Why don't you try restoring the latest working snapshot and then garuda-update again?

3 Likes

Sorry in a big rush today with the non-tech aspect of my life lol.
Okay this is the more detailed version:

When I turn on my laptop it makes it to the grub loader, counts down and then boots the operating system like normal. Then on the next screen its all black and it says:

Loading Linux linux-zen
Loading initial ramdisk

My system hangs at this point and doesn't load any further.
This is something that happens with my system occasionally but powering off and powering back on usually corrects this. I think it's probably important to know that this has happened to me after a fresh install no dual booting or fancy settings like that but a clean fresh install and after a reboot the system hangs on this screen. Again this has corrected itself in the past by powering down and back on again.

The Things I've tried:
Paitence, I've tried to walk away and come back a while later to see if it's just taking it's sweet time or something.

I've read the article here: Computer doesn’t boot, boots to a black screen, or stops at a message

This article was posted above but I may be misunderstanding the instructions. It says:

The first thing to try

Switch to a text console with CTRL+ALT+F2, log in with your normal username and password, then run a full update:

I tried doing that at the screen it is hanging on

Loading Linux linux-zen
Loading initial ramdisk

It doesn't do anything. I don't know when exactly to do that so that's an issue.

So I moved on from that article to this one:

I followed this advice from that post:
The easier way to chroot is to boot into a Garuda live USB and do a grub repair from within Garuda Assistant. Then run grub-update.

In the Garuda Boot Repair assistant I'm not sure what to select to I selected "Repair GRUB configuration file"

If I needed to "Reinstall GRUB bootloader on ESP,MBR, or PBR(root)
I don't know which setting to select MBR, root, or ESP so I left it alone.

When I type grub-update:

[[email protected] ~]$ grub-update
bash: grub-update: command not found

I probably am not understanding the instructions.

and finally I tried to follow this:

You may also want to reinstall the Zen kernel from the chroot:

pacman -Syu linux-zen linux-zen-headers

But now that I'm thinking about it I'm not sure what it means by "from the chroot"
That's how far I've gotten and I need help because I don't exactly understand the instruction even though I have found them.

When you boot from live media, you don't have the normal system disks mounted. That means if you make a change (install or reinstall a package, for example) it only does it on the temporary live system you've set up. The chroot (change root) tool is a way of telling your system you want to run commands using a different system root.

An easy way to set it up is to use the chroot GUI tool (looks like this):

If that doesn't work, you'll have to use the manual instructions.

I do not think you have an EFI partition, based on the fact that you are booted into legacy mode:

I am assuming you installed with this same media.

So, no EFI partition means try the MBR instructions.

Once you are inside the chroot, reinstalling Grub or the kernel will work on your normal system (not the temporary live media one). You will also be elevated to root, which is why sudo is missing from the commands you see listed in those threads.

4 Likes

Just a thought ?
Make sure fast boot and secure boot is disabled

3 Likes

Okay got a moment to look at this again.

First when I enter chroot as described above the terminal shows this:

grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your device.map.
==> Mounting (Garuda_Linux) [/dev/nvme0n1p1]
 --> mount: [/mnt]
 --> mount: [/mnt/home]
 --> mount: [/mnt/root]
 --> mount: [/mnt/srv]
 --> mount: [/mnt/var/cache]
 --> mount: [/mnt/var/log]
 --> mount: [/mnt/var/tmp]
[[email protected] /]# 

I think it's working can you confirm?

Second I tried to run the Garuda Boot repair and it popped up an error message that said:

"Could not set up chroot environment. Please double-check the selected location."

Okay so for Location:
nvme0n1 119.2G
That's definitely my hard drive.

For root location these are the options:
nvme0n1p1 81.1G btrfs /mnt/var/tmp
nvme0n1p2 8.8G swap
sda1 2.4G iso9660 <---Live usb
sda2 4M vfat MISO_EFI

I've tried running it on:
nvme0n1p1 81.1G btrfs /mnt/var/tmp

It just throws an error.

After I post this I'm going to take a look at TilliDie's recommendation and look to see if I have fast boot and secure boot disable in the bios? That's in the bios right? lol.

Update:

Power cycled to check my bios and I don't have those options in my bios.
I thought I'd try again to boot into my system and it decided to let me in. So for now I'm back into my system. Can we continue to try to troubleshoot this as it happens here and there where I'm basically locked out of my system and that is no fun.

That's lucky you got back in. I would make sure you bring your system fully up to date while you have the chance.

garuda-update

It may be worthwhile to reinstall Grub as well.

sudo grub-install
1 Like

I had the same thing happen to me

After tring different thing i ended up reinstalling but could not install with nvidia enabled so i installed with out nvidia and it working fine. even though i have a nvidia card i don't think i'm going to install there driver.
I was wondering if you by chance have installed there driver when you did the install? as it seamed to cause my problem. but it looks like you are using Intel onboard graphic if i'm reading your inxi right so you would not need it.

I’ll try to answer your question but I’m not sure I understand it exactly. When I initially loaded the iso I selected the option to “allow proprietary drivers.” It’s the default selection if I remember correctly.

[[email protected] ~]$ sudo grub-install
[sudo] password for genxi:            
Installing for i386-pc platform.
grub-install: error: install device isn't specified.

????

Please post the output of

lsblk -f

and

sudo parted -l

@Rastin I think your issue is altogether unrelated. Typically reinstalling is unnecessary, but what's done is done.

For next time, if you take an update that breaks your system you should try to restore a snapshot from the Grub menu. Every time you update your system, a snapshot gets automatically created for you to preserve the system state as it was before the update.

If you need help getting the proper Nvidia driver installed, please open up a new thread and post your garuda inxi along with a description of what's going on.

[[email protected] ~]$ lsblk -f
NAME        FSTYPE FSVER LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
zram0                                                                              [SWAP]
nvme0n1                                                                            
├─nvme0n1p1 btrfs              dd3b181e-c334-4d28-8cdd-b1a1db3e6edc   55.8G    30% /var/tmp
│                                                                                  /var/log
│                                                                                  /var/cache
│                                                                                  /srv
│                                                                                  /root
│                                                                                  /home
│                                                                                  /
└─nvme0n1p2 swap   1     swap  d4e754ff-8b48-4291-8a95-9edf974158a9
Model: SAMSUNG MZVLW128HEGR-000L2 (nvme)
Disk /dev/nvme0n1: 128GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system     Flags
 1      1049kB  87.1GB  87.1GB  primary  btrfs           boot
 2      119GB   128GB   9449MB  primary  linux-swap(v1)  swap


Model: Unknown (unknown)
Disk /dev/zram0: 8103MB
Sector size (logical/physical): 4096B/4096B
Partition Table: loop
Disk Flags: 

Number  Start  End     Size    File system     Flags
 1      0.00B  8103MB  8103MB  linux-swap(v1)

Alright then, let's try this:

sudo grub-install --target=i386-pc /dev/nvme0n1
2 Likes
[[email protected] ~]$ sudo grub-install --target=i386-pc /dev/nvme0n1
[sudo] password for genxi:            
Installing for i386-pc platform.
Installation finished. No error reported.

Looks good to me. :slightly_smiling_face:

Now run:

sudo update-grub