System Break after update

Something in this update break my system, don't know it's a bug or something else... I have to use timeshift to restore everything back...
So I think everyone should stop updating the system until the fix comes...

╭─dd at cypher in ⌁
╰─λ sudo pacman -Syu
[sudo] password for dd:
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 chaotic-aur is up to date                 0.0   B  0.00   B/s 00:00 [c o  o  o  o  o  o  o  o  o  o  o  o  ]   0%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (43) bluedevil-1:5.21.0-1  breeze-5.21.0-1  ddcutil-1.0.1-1  elfutils-0.183-3
              garuda-common-settings-r95.9eef8c4-1  garuda-dr460nized-r152.308bb5a-1  kactivitymanagerd-5.21.0-1
              kde-cli-tools-5.21.0-1  kde-gtk-config-5.21.0-1  kdecoration-5.21.0-1  kdeplasma-addons-5.21.0-1
              khotkeys-5.21.0-1  kinfocenter-5.21.0-1  kmenuedit-5.21.0-1  kscreen-5.21.0-1
              kscreenlocker-5.21.0-1  ksysguard-5.21.0-1  kwallet-pam-5.21.0-1  kwayland-integration-5.21.0-1
              kwayland-server-5.21.0-1  lib32-libelf-0.183-3  lib32-openssl-1:1.1.1.j-1
              libappletdecoration-0.8.1-3  libelf-0.183-3  libkscreen-5.21.0-1  libksysguard-5.21.0-1
              libupnp-1.14.1-1  milou-5.21.0-1  plasma-browser-integration-5.21.0-1  plasma-desktop-5.21.0-1
              plasma-integration-5.21.0-1  plasma-nm-5.21.0-1  plasma-pa-5.21.0-1  plasma-thunderbolt-5.21.0-1
              plasma-vault-5.21.0-1  plasma-workspace-5.21.0-1  plasma5-applets-window-buttons-0.8.1-3
              polkit-kde-agent-5.21.0-1  powerdevil-5.21.0-1  sddm-kcm-5.21.0-1  systemsettings-5.21.0-1
              xdg-desktop-portal-kde-5.21.0-1  xkeyboard-config-2.32-1

Total Download Size:     7.29 MiB
Total Installed Size:  186.38 MiB
Net Upgrade Size:       13.70 MiB

No, maybe KDE user :slight_smile:

Yeah, I'm using dr460nized, so might be only kde
hope so

1 Like

Interesting, how does the breakage look like? :eyes:

1 Like

After update and restart when I entered the password, the system freeze

1 Like

If any kde user experience the same... let me know

I'm on kde, and I am experiencing the same bug, after login trough sddm plasma hang up on the loading screen, but the system is still functional and you can access a tty.

1 Like

I am not seeing this on Vanilla Arch so maybe it is theme / and /or driver related. I use AMD only.

1 Like

My AMD i3wm work fine after update via ssh, kernel 5.10.16-zen1.

I have the same issue on dragonised kde

I faced this since yesterday evening as well.. Blamed it on another thing though. Will investigate later. Timeshift until the solution has been solved :+1:

3 Likes

If you have got new plasma version, first do the usual clean-up for plasma.
Plasma clean cache

Clean plasma after update or before update...?
Would try

After update, outside of plasma session (logged out).

1 Like

I have the same issue. Just installed the dragonized kde version and started the process of installing gimp and it also did the kde 5.21 update as well. After rebooting and logging in, the system is prompting for The password to kde wallet that I haven’t setup yet.

I was able to use timeshift to get back to the base install but can’t install new software without it trying to update kde as well.

I am using KDE Barebones and had absolutely no issues after today's Plasma 5.21 update. Plasma looks and feels better than ever. So I'm a bit confused. Happy but confused. :crazy_face:

P.S. I don't have full-blown plasma, Barebones with hand-picked components added.

2 Likes

Did you restart the system after update...?

Yes, once. Because the menu froze up. Understandable as it got an overhaul. I simply did sudo reboot from yakuake and everything is working like a charm.

1 Like

Nvm. Thanks for reporting! :slight_smile:

Does nothing sadly. I captured a log of startx, nothing really happens but what caught my eye is this one:

(==) Using system config directory "/usr/share/X11/xorg.conf.d"
kdeinit5: preparing to launch '/usr/lib/kf5/klauncher'
kdeinit5: Launched KLauncher, pid = 21823, result = 0
kdeinit5: Communication error with launcher. Exiting!
org.kde.plasma.session: process job  "kcminit_startup" finished with exit code  0
/usr/bin/kwin_x11: symbol lookup error: /usr/lib/libkwin.so.5: undefined symbol: _ZN14KWaylandServer13SeatInterface9touchDownERK7QPointF
(II) AIGLX: Suspending AIGLX clients for VT switch
(II) AIGLX: Suspending AIGLX clients for VT switch
(II) AIGLX: Suspending AIGLX clients for VT switch
xinit: connection to X server lost
2 Likes

Really :rofl: .
Don't you find this cheating?...

This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.

X.Org X Server 1.20.99.1
X Protocol Version 11, Revision 0

Maybe not related, but worth checking?

2 Likes