Switch to Wayland?

Hey, so this is probably a stupid question I could work out with some experimenting on my laptop but I'm currently out and scared I'll break something. I don't have an Nvidia card so I think I would like to use Wayland because of the benefits as I'm fine with a bit of instability if any associated with it. Could someone suggest the best method to install this and set to default? I'm used to, when logging in, seeing the option to choose x11 or wayland so was surprised it wasn't an option. Thanks!

I used this thread to get started. I run wayland and x11 on garuda kde, with an Nvidia RTX2060. Wayland is 95% of the way there. There are a few caveats that come up from time to time. They are so small that I usually don't notice until I log into x11. You can switch from the sddm between the two very easily.

1 Like

Hey so thanks for this. I already had that package installed it seems and set the configuration as stated. I don't see how to switch to Wayland though after rebooting. I don't see an option on the login screen or anything. How did you do it?

Okay so I fixed that but now the latte dock won't load...

https://katb.in/fofeposuzep

sure you are in wayland?

seems in the logs, latte is trying to load libxcb.

what does env | grep XDG_SESSION_TYPE say ?

Hey, so running that command outputs wayland. I followed the below YouTube video to theme my desktop which involved some applet's and themes for latte-dock. Some googling shows that the lattehdock may be fine but that an applet isn't working on Wayland which is crashing it. I don't know from the crash log what applet that would be but the below video shows what was themed and installed with links so maybe that would help diagnose which applet if any is causing this crash? Thanks

by the way, you can also launch latte-dock -dr from the terminal, that will show more info.

can you try backing up and then removing your lattedock configuration?
its the ~/.config/lattedock* files.

and then start lattedock. If it runs fine, then for sure it is some applet.

Ran that command as stated and it kept running forever even after trying to cancel it or pipe it into a text file so not sure how to show the output of that. I did backup the latte config though and it now loads just fine. The below is my latte config file btw. It has many applets and I really have no clue which one is causing the problem or how to test it without deleting them one at a time.

https://katb.in/saqugekajuq

I fixed it! It's not often I work it out lol but I'm happy haha. Did a bunch more googling and someone mentioned that they tried removing the virtual desktop button applet. It added a nice button where you can select 1 or 2 for the virtual desktop. Now it's removed I have no issues! Just need to remember the virtual desktop shortcut now haha

Ctrl + F1
Ctrl + F2

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.