Sddm in wayland

Hi,

So for all that want to run an "all wayland kde", with sddm using wayland instead of xorg, do this:

  • install package sddm-wayland-git from chaotic-aur
  • in for example /etc/sddm.conf.d/dr460nized.conf, add:
[General]
DisplayServer=wayland
GreeterEnvironment=QT_WAYLAND_SHELL_INTEGRATION=layer-shell

and

[Wayland]
CompositorCommand=kwin_wayland --no-lockscreen --inputmethod maliit-keyboard --width 2560 --height 1440

adjust width and height to your monitor.

but beware, maybe, here be dragons

8 Likes

I have been reading about wayland. All I can say is wow!.... But my first question is for those who have tried Garuda KDE with wayland. What are those Dragons?

there are some... lucky none here that attacks me :slight_smile:

some things work properly , the same or better than x11. others, not really.

best way is to try it yourself and see if any of the issues affects you. but kde wayland ( and wayland in general ) have been improving a lot.

EDIT: I didn't mentioned any dragons because of the top of my head I can't remember anything that is broken on wayland for me

Do you have nvidia drivers installed? That is what I think is holding me back from trying.

EDIT: I did it. Is there anyway to make sure I am using wayland. All seems to be working really well, so far!

Thanks

Seems as though x11 is still running not wayland

echo $XDG_SESSION_TYPE
x11

env | grep -i wayland

echo $DESKTOP_SESSION
plasma

you mean sddm or plasma ? are you selecting the plasma wayland session?

also I have amdgpu drivers. dunno about nvidia, but I have been reading that they are becoming more compatible with wayland?

At the login screen, there is nothing for me to select. Just my Login in name and which keyboard I want to use.

I followed your instructions in the first post to a tee. I appreciate your help, honestly.

you don't have a "plasma x11" and a "plasma wayland" to select on sddm?

maybe you only have plasma x11 installed.

can you check if you have the package: plasma-wayland-session ?

1 Like

That was the package I was missing. Thanks


╰─λ echo $DESKTOP_SESSION
plasmawayland

╰─λ env | grep -i wayland
DESKTOP_SESSION=plasmawayland
WAYLAND_DISPLAY=wayland-0
XDG_SESSION_TYPE=wayland
QT_WAYLAND_FORCE_DPI=96

Dragons: Wine+Wayland+Nvidia - Needs some work. Only tried one game (Farm Simulator 2019). Will not launch. Switched back to X11 and all is good.

EDIT: I found this


╰─λ sudo pacman -Ss wayland | grep wine
chaotic-aur/wine-wl-git wine.6.0.rc1.r5986.g8119f965602-1
A compatibility layer for running Windows programs (wayland version from gitlab.collabora.com/alf/wine/ wa
yland-staging-wip branch)

[✔️] ╰─λ  sudo pacman -S wine-wl-git
resolving dependencies...
looking for conflicting packages...
:: wine-wl-git and wine-staging are in conflict (wine). Remove wine-staging? [y/N] Y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing wine-staging breaks dependency 'wine>=4.0rc1' required by dxvk-mingw-git

but not sure how to proceed.

I would stick to normal wine for now ( although wl wine port seems pretty good ).

but can't you run wine on xwayland? .... check if you have the xorg-xwayland package ( you must have, 99% sure ... but just in case )

That package is installed

sudo pacman -Ss xorg-xwayland
extra/xorg-xwayland 21.1.2-1 (xorg) [installed]
run X clients under wayland
chaotic-aur/xorg-xwayland-git 21.1.2.r251.g735dbde48-1
Run X clients under Wayland (git version)

Wine starts but there are errors and then the game crashes before it starts.

does other wine apps work ? winecfg works ?

also can you try running it with env GDK_BACKEND=x11 wine ..... ? it should go to xwayland, but I am just trying things.

I have an amdgpu card, I don't have any issue with wayland on my wine apps ( apps, not games :slight_smile: )

I updated my system. Today FS2019 works! Also Stellaris works! I did not have to use env variables!

I am just in Awe of Garuda! Never have a had a system that updates driviers and software in one command without having to download from multiple sites.

nice :slight_smile: congrats !

Btw .... i don't know FS2019 , but does Stellaris works good on linux ?

FS2019 -> Farming Simulator 2019

Stellaris works awsome! There is no lag with maximum graphics settings. I do have an rtx 2060. Results may vary.

yeah, i got that FS2019 was the farming simulator ... I mean that I don't know the game.

But I do know stellaris... I like those types of games, kinda like galactic civ.

( i always dual boot to play windows games ... I should give it a try sometimes ( although, i rarelly play games :frowning: )

I ran windows for Gaming. Until I discovered Garuda. There are a few that I would still like to try and have yet to get them running in wine. However, there are so many that do run. I dropped windows. I still have a lot to learn about wine and winetricks. I haven't even started with proton or lutris yet. Seems as though we like the same gaming types.

Days Gone
City Skylines
Civ IV
Surviving Mars

All working on wayland

2 Likes

thanks !

I haven't played those games, but I know them. yeah, they are kinda my type of games. Days gone seems interesting, specially for the story.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.