How to enable wayland?

Here is my garuda-inxi output:

 ╰─λ garuda-inxi 
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_ADDRESS = "ms_MY.UTF-8",
        LC_NAME = "ms_MY.UTF-8",
        LC_MONETARY = "ms_MY.UTF-8",
        LC_PAPER = "ms_MY.UTF-8",
        LC_IDENTIFICATION = "ms_MY.UTF-8",
        LC_TELEPHONE = "ms_MY.UTF-8",
        LC_MEASUREMENT = "ms_MY.UTF-8",
        LC_TIME = "ms_MY.UTF-8",
        LC_NUMERIC = "ms_MY.UTF-8",
        LANG = "en_MY.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
System:
  Kernel: 5.16.15-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=05323000-3012-4479-b22d-114f8d81f621 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1
    resume=UUID=41bb886d-947b-4425-b7cf-b1746994b7f6 loglevel=3
  Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 wm: kwin_x11 vt: 1
    dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Notebook product: W740SU v: N/A
    serial: <superuser required> Chassis: type: 9 serial: <superuser required>
  Mobo: Notebook model: W740SU serial: <superuser required>
    BIOS: American Megatrends v: 4.6.5 date: 09/11/2014
CPU:
  Info: model: Intel Core i7-4770HQ bits: 64 type: MT MCP arch: Haswell
    family: 6 model-id: 0x46 (70) stepping: 1 microcode: 0x1C
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 2195 high: 2203 min/max: 800/3400 scaling:
    driver: intel_cpufreq governor: performance cores: 1: 2195 2: 2195 3: 2195
    4: 2195 5: 2192 6: 2196 7: 2203 8: 2195 bogomips: 35118
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Crystal Well Integrated Graphics vendor: CLEVO/KAPOK
    driver: i915 v: kernel ports: active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2
    bus-ID: 00:02.0 chip-ID: 8086:0d26 class-ID: 0300
  Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
    loaded: intel unloaded: modesetting alternate: fbdev,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP1 model: ChiMei InnoLux 0x14b6 built: 2015
    res: 1920x1080 hz: 60 dpi: 157 gamma: 1.2 size: 310x170mm (12.2x6.69")
    diag: 353mm (13.9") ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel Iris Pro Graphics P5200 (HSW GT3)
    v: 4.6 Mesa 22.0.0 compat-v: 3.1 direct render: Yes
Audio:
  Device-1: Intel Crystal Well HD Audio vendor: CLEVO/KAPOK
    driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:0d0c
    class-ID: 0403
  Device-2: Intel 8 Series/C220 Series High Definition Audio
    vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:8c20 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.15-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.49 running: yes
Network:
  Device-1: Intel Ethernet I217-V vendor: CLEVO/KAPOK driver: e1000e
    v: kernel port: f080 bus-ID: 00:19.0 chip-ID: 8086:153b class-ID: 0200
  IF: enp0s25 state: down mac: <filter>
  Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter
    driver: rtl8723be v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: e000 bus-ID: 03:00.0 chip-ID: 10ec:b723 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
Bluetooth:
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 3-4:3 chip-ID: 0bda:b002 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 111.79 GiB used: 33.63 GiB (30.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SMS200S3120G
    size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: BBF0 scheme: MBR
Partition:
  ID-1: / raw-size: 94.68 GiB size: 94.68 GiB (100.00%)
    used: 33.63 GiB (35.5%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-2: /home raw-size: 94.68 GiB size: 94.68 GiB (100.00%)
    used: 33.63 GiB (35.5%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-3: /var/log raw-size: 94.68 GiB size: 94.68 GiB (100.00%)
    used: 33.63 GiB (35.5%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-4: /var/tmp raw-size: 94.68 GiB size: 94.68 GiB (100.00%)
    used: 33.63 GiB (35.5%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.55 GiB used: 2.8 MiB (0.0%)
    priority: 100 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 17.1 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda2 maj-min: 8:2
Sensors:
  System Temperatures: cpu: 53.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 295 Uptime: 1h 6m wakeups: 1 Memory: 15.55 GiB
  used: 4.35 GiB (28.0%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1398 lib: 365 Shell: fish
  v: 3.4.1 running-in: yakuake inxi: 3.3.14
Garuda (2.5.6-2):
  System install date:     2021-06-21
  Last full system update: 2022-04-01 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       <superuser required>
  Snapshots:               Timeshift
  Failed units:            

Ok, I want to get a clear instructions on how to enable wayland on my Garuda installation. It is Garuda with KDE and fully updated. I also tried suggestions from this link --> https://forum.garudalinux.org/t/garuda-kde-plasma-wayland-support/17963

But no wayland session.

Thanks for any reply.

Just reboot, kernel is 15.17.1

Then install plasma-wayland-session and change to plasma wayland from the log in screen.

Edit: I just noticed the link you posted, which included basically the same (I think plasma-wayland-session brings in as dependencies the others). If that didn't work, give a look at this thread:

Just consider that now sddm-wayland-git is called sddm-git

3 Likes

Thank you for your reply. I was browsing through "Add/Remove Software" app for sddm-git and also other wayland related packages when I noticed that plasma-wayland-session was not installed. I installed it and restarted and viola! I have the option for Wayland session on my login screen. Thanks for the pointer and I hope this 'discovery' will benefit someone.

As a side note, may we should have "Wayland Install" as part of Garuda assistant which will install all necessary packages.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.