Sweet Home 3D - program doesn't start anymore

Sweet Home 3D (SW3D) has been causing me problems with Garuda for a long time now. I can't say that the problems lie with Garuda alone, probably not, but the program runs at least reasonably well under Windoof.

Problems:

  1. At the moment the program cannot be started under Garuda Linux, that is to say, a small program start window appears, but then the program tab disappears from the bar and the dock and only the start window remains permanently burned into the screen and can not be closed. Only a restart or logout then deletes the SW3D start screen.

This problem started with an garuda update about 2 days ago but after deinstallation and reinstallation of SW3D as well as the installation of Java it worked again. After another update today, the same game, only now nothing starts, even after deinstallation and reinstallation.

  1. The second and older problem with SW3D is that the program window (SW3D) freezes after some time of use and can not be closed. Sometimes other program besides SW3D are still accesseble but sometimes all of the system is frozen and even the keyboard and only a hot reset over the power button and a restart than lets the PC work again.

As I said, I don't necessarily assume that the problem is Garuda himself, but maybe someone has a suggestion on how to get SW3D to run reasonably stable and safely on Garuda.

my sys-infos are:

System:    Kernel: 5.14.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen 
           root=UUID=40141552-e6a3-48ef-ade6-40c1a5425fd6 rw [email protected] quiet splash 
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 
           loglevel=3 
           Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
           Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: Dell product: Precision M6700 v: 01 serial: <filter> Chassis: 
           type: 9 serial: <filter> 
           Mobo: Dell model: 096J9P v: A00 serial: <filter> UEFI: Dell v: A20 date: 11/30/2018 
Battery:   ID-1: BAT0 charge: 62.2 Wh (100.0%) condition: 62.2/98.2 Wh (63.3%) volts: 12.6 
           min: 11.1 model: Samsung SDI DELL 1C75X2B type: Li-ion serial: <filter> status: Full 
CPU:       Info: Quad Core model: Intel Core i7-3720QM bits: 64 type: MT MCP arch: Ivy Bridge 
           family: 6 model-id: 3A (58) stepping: 9 microcode: 21 cache: L2: 6 MiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 41467 
           Speed: 3445 MHz min/max: 1200/3600 MHz Core speeds (MHz): 1: 3445 2: 3411 3: 3391 
           4: 3396 5: 3523 6: 3446 7: 3442 8: 3401 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: 
           conditional, RSB filling 
           Type: srbds status: Vulnerable: No microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Dell driver: i915 v: kernel 
           bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300 
           Device-2: NVIDIA GK104GLM [Quadro K3000M] vendor: Dell driver: nouveau v: kernel 
           bus-ID: 01:00.0 chip-ID: 10de:11be class-ID: 0300 
           Device-3: Microdia Dell Integrated HD Webcam type: USB driver: uvcvideo bus-ID: 1-1.5:4 
           chip-ID: 0c45:643f class-ID: 0e02 
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel,nouveau 
           unloaded: modesetting alternate: fbdev,nv,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
           s-diag: 582mm (22.9") 
           Monitor-1: LVDS1 res: 1920x1080 hz: 60 dpi: 128 size: 380x210mm (15.0x8.3") 
           diag: 434mm (17.1") 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) v: 4.2 Mesa 21.2.3 
           compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Dell 
           driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20 class-ID: 0403 
           Device-2: NVIDIA GK104 HDMI Audio vendor: Dell driver: snd_hda_intel v: kernel 
           bus-ID: 01:00.1 chip-ID: 10de:0e0a class-ID: 0403 
           Sound Server-1: ALSA v: k5.14.12-zen1-1-zen running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: no 
           Sound Server-4: PipeWire v: 0.3.38 running: yes 
Network:   Device-1: Intel 82579LM Gigabit Network vendor: Dell driver: e1000e v: kernel 
           port: f080 bus-ID: 00:19.0 chip-ID: 8086:1502 class-ID: 0200 
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi v: kernel port: e000 
           bus-ID: 03:00.0 chip-ID: 8086:422b class-ID: 0280 
           IF: wlp3s0 state: down mac: <filter> 
Drives:    Local Storage: total: 2.55 TiB used: 582.06 GiB (22.3%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 model: SATA SSD size: 953.87 GiB block-size: 
           physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: BA.3 
           scheme: GPT 
           ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: P3-1TB size: 953.87 GiB block-size: 
           physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 117D 
           scheme: GPT 
           ID-3: /dev/sdc maj-min: 8:32 vendor: Micron model: MT-256 size: 238.47 GiB block-size: 
           physical: 512 B logical: 512 B speed: 3.0 Gb/s type: SSD serial: <filter> rev: 117D 
           scheme: GPT 
           ID-4: /dev/sdd maj-min: 8:48 vendor: SanDisk model: Ultra II 500GB size: 465.76 GiB 
           block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s type: SSD serial: <filter> 
           rev: 10WD scheme: MBR 
Partition: ID-1: / raw-size: 953.61 GiB size: 953.61 GiB (100.00%) used: 313.36 GiB (32.9%) 
           fs: btrfs dev: /dev/sda2 maj-min: 8:2 
           ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%) used: 562 KiB (0.2%) fs: vfat 
           dev: /dev/sda1 maj-min: 8:1 
           ID-3: /home raw-size: 953.61 GiB size: 953.61 GiB (100.00%) used: 313.36 GiB (32.9%) 
           fs: btrfs dev: /dev/sda2 maj-min: 8:2 
           ID-4: /var/log raw-size: 953.61 GiB size: 953.61 GiB (100.00%) used: 313.36 GiB (32.9%) 
           fs: btrfs dev: /dev/sda2 maj-min: 8:2 
           ID-5: /var/tmp raw-size: 953.61 GiB size: 953.61 GiB (100.00%) used: 313.36 GiB (32.9%) 
           fs: btrfs dev: /dev/sda2 maj-min: 8:2 
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) 
           ID-1: swap-1 type: zram size: 31.26 GiB used: 1.5 MiB (0.0%) priority: 100 
           dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 62.0 C mobo: 49.0 C sodimm: SODIMM C gpu: nouveau 
           temp: 38.0 C 
           Fan Speeds (RPM): cpu: 2595 
Info:      Processes: 281 Uptime: 8m wakeups: 2 Memory: 31.26 GiB used: 3.97 GiB (12.7%) 
           Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 
           pacman: 1538 lib: 359 Client: Unknown Client: garuda-assistant inxi: 3.3.06 

What was updated?
Use snapshot that work and wait for fix :smiley:

1 Like

and some Diagnostic data with error message:

-- Journal begins at Mon 2021-10-11 15:30:01 KST, ends at Fri 2021-10-15 22:08:55 KST. --
Okt 15 21:33:42 eric-precisionm6700 systemd-modules-load[306]: Failed to find module 'vboxpci'
Okt 15 21:33:42 eric-precisionm6700 systemd-udevd[351]: vboxdrv: /usr/lib/udev/rules.d/60-vboxdrv.rules:1 Only network interfaces can be renamed, ignoring NAME="vboxdrv".
Okt 15 21:33:42 eric-precisionm6700 systemd-udevd[346]: vboxdrvu: /usr/lib/udev/rules.d/60-vboxdrv.rules:2 Only network interfaces can be renamed, ignoring NAME="vboxdrvu".
Okt 15 21:33:42 eric-precisionm6700 systemd-udevd[354]: vboxdrv: /usr/lib/udev/rules.d/60-vboxdrv.rules:1 Only network interfaces can be renamed, ignoring NAME="vboxdrv".
Okt 15 21:33:42 eric-precisionm6700 systemd-udevd[367]: vboxdrvu: /usr/lib/udev/rules.d/60-vboxdrv.rules:2 Only network interfaces can be renamed, ignoring NAME="vboxdrvu".
Okt 15 21:33:42 eric-precisionm6700 systemd-udevd[339]: vboxnetctl: /usr/lib/udev/rules.d/60-vboxdrv.rules:3 Only network interfaces can be renamed, ignoring NAME="vboxnetctl".
Okt 15 21:33:42 eric-precisionm6700 systemd-udevd[354]: host6: /usr/lib/udev/rules.d/50-sata.rules:2 Failed to write ATTR{/sys/devices/pci0000:00/0000:00:14.0/usb3/3-4/3-4.2/3-4.2:1.2/host6/scsi_host/host6/link_power_management_policy}, ignoring: No such file or directory
Okt 15 21:33:43 eric-precisionm6700 systemd-tmpfiles[556]: Failed to write file "/sys/module/pcie_aspm/parameters/policy": Operation not permitted
Okt 15 21:33:44 eric-precisionm6700 kernel: Bluetooth: hci0: command 0x0c23 tx timeout
Okt 15 21:33:44 eric-precisionm6700 kernel: Bluetooth: hci0: sending frame failed (-19)
Okt 15 21:33:46 eric-precisionm6700 kernel: Bluetooth: hci0: command 0x0c14 tx timeout
Okt 15 21:33:46 eric-precisionm6700 kernel: Bluetooth: hci0: sending frame failed (-19)
Okt 15 21:33:47 eric-precisionm6700 smbd[3083]: [2021/10/15 21:33:47.726990,  0] ../../source3/smbd/server.c:1738(main)
Okt 15 21:33:47 eric-precisionm6700 smbd[3083]:   smbd version 4.15.0 started.
Okt 15 21:33:47 eric-precisionm6700 smbd[3083]:   Copyright Andrew Tridgell and the Samba Team 1992-2021
Okt 15 21:33:48 eric-precisionm6700 kernel: Bluetooth: hci0: command 0x0c25 tx timeout
Okt 15 21:33:48 eric-precisionm6700 kernel: Bluetooth: hci0: sending frame failed (-19)
Okt 15 21:33:50 eric-precisionm6700 kernel: Bluetooth: hci0: command 0x0c38 tx timeout
Okt 15 21:33:50 eric-precisionm6700 kernel: Bluetooth: hci0: sending frame failed (-19)
Okt 15 21:33:51 eric-precisionm6700 udev-configure-printer[627]: no corresponding CUPS device found
Okt 15 21:33:52 eric-precisionm6700 kernel: Bluetooth: hci0: command 0x0c39 tx timeout
Okt 15 21:33:52 eric-precisionm6700 kernel: Bluetooth: hci0: sending frame failed (-19)
Okt 15 21:33:53 eric-precisionm6700 colord-sane[3162]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Okt 15 21:34:38 eric-precisionm6700 systemd[6969]: Failed to start Profile-sync-daemon.
Okt 15 21:34:44 eric-precisionm6700 kernel: nouveau 0000:01:00.0: msvld: unable to load firmware data
Okt 15 21:34:44 eric-precisionm6700 kernel: nouveau 0000:01:00.0: msvld: init failed, -19
Okt 15 21:34:44 eric-precisionm6700 kernel: nouveau 0000:01:00.0: msvld: unable to load firmware data
Okt 15 21:34:44 eric-precisionm6700 kernel: nouveau 0000:01:00.0: msvld: init failed, -19
Okt 15 21:34:45 eric-precisionm6700 kernel: nouveau 0000:01:00.0: msvld: unable to load firmware data
Okt 15 21:34:45 eric-precisionm6700 kernel: nouveau 0000:01:00.0: msvld: init failed, -19

what was updated? good question!
just run the command 'upd' and let the system or better said Garuda decide. and normally I take a short overlook over the updates but hell, I can't remember them all :grinning: at least I remember it was a Kernel update, as usual and a libreoffice update in it too.

You should rummage into your pacman.log, with something like
cat /var/log/pacman.log | grep 2021-10-15 | grep upgraded
changing the date of course, or using installed, etc...

1 Like

snapshot OK
.
.
.
oh shit (sorry)
.
its because since I've deinstalled and reinstalled many times snapshot isn't an option anymore because it gives me only options from my last 10 attempts of today

[2021-10-15T21:02:59+0900] [ALPM] upgraded aom (3.1.3-1 -> 3.1.3-2)
[2021-10-15T21:02:59+0900] [ALPM] upgraded bison (3.8.1-1 -> 3.8.2-1)
[2021-10-15T21:02:59+0900] [ALPM] upgraded systemd-libs (249.4-2 -> 249.5-1)
[2021-10-15T21:02:59+0900] [ALPM] upgraded bluez (5.61-1 -> 5.62-1)
[2021-10-15T21:02:59+0900] [ALPM] upgraded libnghttp2 (1.45.0-1 -> 1.45.1-1)
[2021-10-15T21:03:00+0900] [ALPM] upgraded systemd (249.4-2 -> 249.5-1)
[2021-10-15T21:03:00+0900] [ALPM] upgraded bluez-cups (5.61-1 -> 5.62-1)
[2021-10-15T21:03:00+0900] [ALPM] upgraded bluez-hid2hci (5.61-1 -> 5.62-1)
[2021-10-15T21:03:00+0900] [ALPM] upgraded bluez-libs (5.61-1 -> 5.62-1)
[2021-10-15T21:03:00+0900] [ALPM] upgraded bluez-plugins (5.61-1 -> 5.62-1)
[2021-10-15T21:03:00+0900] [ALPM] upgraded bluez-utils (5.61-1 -> 5.62-1)
[2021-10-15T21:03:00+0900] [ALPM] upgraded game-devices-udev (0.15-1 -> 0.16-1)
[2021-10-15T21:03:00+0900] [ALPM] upgraded garuda-welcome (1.0.11-1 -> 1.0.12-1)
[2021-10-15T21:03:00+0900] [ALPM] upgraded git (2.33.0-1 -> 2.33.1-1)
[2021-10-15T21:03:00+0900] [ALPM] upgraded gmic (2.9.9-1 -> 2.9.9-2)
[2021-10-15T21:03:01+0900] [ALPM] upgraded jre-openjdk-headless (16.0.2.u7-1 -> 17.u35-1)
[2021-10-15T21:03:01+0900] [ALPM] upgraded jre-openjdk (16.0.2.u7-1 -> 17.u35-1)
[2021-10-15T21:03:01+0900] [ALPM] upgraded jdk-openjdk (16.0.2.u7-1 -> 17.u35-1)
[2021-10-15T21:03:01+0900] [ALPM] upgraded qt5-svg (5.15.2+kde+r7-1 -> 5.15.2+kde+r13-1)
[2021-10-15T21:03:01+0900] [ALPM] upgraded qt5-declarative (5.15.2+kde+r32-1 -> 5.15.2+kde+r33-1)
[2021-10-15T21:03:01+0900] [ALPM] upgraded krita-plugin-gmic (2.9.9-1 -> 2.9.9-2)
[2021-10-15T21:03:02+0900] [ALPM] upgraded libfprint (1.94.0-1 -> 1.94.1-1)
[2021-10-15T21:03:02+0900] [ALPM] upgraded libpamac-aur (11.1.0-1 -> 11.1.0-2)
[2021-10-15T21:03:02+0900] [ALPM] upgraded libqalculate (3.20.1-1 -> 3.21.0-1)
[2021-10-15T21:03:05+0900] [ALPM] upgraded libreoffice-fresh (7.2.1-3 -> 7.2.2-1)
[2021-10-15T21:03:05+0900] [ALPM] upgraded libreoffice-fresh-de (7.2.1-1 -> 7.2.2-1)
[2021-10-15T21:03:06+0900] [ALPM] upgraded linux-lts (5.10.72-1 -> 5.10.73-1)
[2021-10-15T21:03:11+0900] [ALPM] upgraded linux-lts-headers (5.10.72-1 -> 5.10.73-1)
[2021-10-15T21:03:11+0900] [ALPM] upgraded linux-wifi-hotspot (4.2.0-1 -> 4.2.1-1)
[2021-10-15T21:03:13+0900] [ALPM] upgraded linux-zen (5.14.11.zen1-1 -> 5.14.12.zen1-1)
[2021-10-15T21:03:17+0900] [ALPM] upgraded linux-zen-headers (5.14.11.zen1-1 -> 5.14.12.zen1-1)
[2021-10-15T21:03:17+0900] [ALPM] upgraded neard (0.16-2 -> 0.17-1)
[2021-10-15T21:03:17+0900] [ALPM] upgraded openjdk-src (16.0.2.u7-1 -> 17.u35-1)
[2021-10-15T21:03:17+0900] [ALPM] upgraded pamac-aur (10.2.0-2 -> 10.2.1-2)
[2021-10-15T21:03:17+0900] [ALPM] upgraded python-reportlab (3.6.1-1 -> 3.6.2-1)
[2021-10-15T21:03:18+0900] [ALPM] upgraded skypeforlinux-stable-bin (8.75.0.140-1 -> 8.77.0.97-1)
[2021-10-15T21:03:18+0900] [ALPM] upgraded strawberry (0.9.3-3 -> 1.0.0-1)
[2021-10-15T21:03:18+0900] [ALPM] upgraded systemd-sysvcompat (249.4-2 -> 249.5-1)
[2021-10-15T21:03:18+0900] [ALPM] upgraded yay (10.3.1-2 -> 11.0.1-1)
[2021-10-15T21:29:13+0900] [ALPM] upgraded mlt (7.0.1-1 -> 7.0.1-2)

This could be a candidate for problems since that should be a Java application?

3 Likes

Start app from terminal.

1 Like

thought the same but have no idea how to fix it

ok I think we're coming closer since this is the terminal reply:

OpenJDK 64-Bit Server VM warning: Ignoring option --illegal-access=permit; support was removed in 17.0
Java 3D: implicit antialiasing enabled
Exception in thread "J3D-Renderer-1" java.lang.IllegalAccessError: class javax.media.j3d.X11NativeConfigTempla
te3D (in unnamed module @0x57829d67) cannot access class sun.awt.X11GraphicsConfig (in module java.desktop) be
cause module java.desktop does not export sun.awt to unnamed module @0x57829d67
at javax.media.j3d.X11NativeConfigTemplate3D.isGraphicsConfigSupported(X11NativeConfigTemplate3D.java:
180)
at javax.media.j3d.NativePipeline.isGraphicsConfigSupported(NativePipeline.java:3341)
at javax.media.j3d.Renderer.doWork(Renderer.java:533)
at javax.media.j3d.J3dThread.run(J3dThread.java:275)

Have you tried the suggestions of the upstream site?
http://sweethome3d.com/faq.jsp
E.g.

  • Try to run the script SweetHome3D-Java3D-1_5_2 which is available in the Linux installer and runs with an older version of Java 3D.
  • If this solution doesn't work, you may still want to use Sweet Home 3D without 3D features, by reading the answer to the next question.
1 Like

I edit one post above, now you post terminal output again in not nice form, please, edit your post.

1 Like

OK will try next time

Finally a running program again at least the downloaded one. Hopefully the install version get fixed soon too.

A big thank you for your prompt and good help.

Sorry, I didn't get you.
You mean you fixed it by reinstalling?

no not reinstalling. Its just that the downloaded versions of SW3D from the SW3D homepage with the embedded Java is working. So it is not fixed but atm I can work with it

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.