Suspend/sleep not working


rmmod: ERROR: Module intel_lpss_pci is not currently loaded


You’re right, by the way: I should maybe start and think that this old potato of a PC (though it’s a desktop, not a laptop) gave what it could give, just retire it and buy something newer.
But then again, in Windows and even more so in Linux: it usually just works, and it is more than enough for any daily productivity of mine! The only problems are fans constantly spinning (I suspect a problem when it was built, since they never ever stopped) and heavy games, obviously, but there’s Geforce Now for that if the game is supported (even though it sucks that, on Linux, Geforce Now is limited to 60 fps via browser while the Windows and Mac app sport 120 fps in 4K…).

And another thing: I’m above moved that you guys are trying so hard to solve a minuscule problem of a noob user of a free and open source distribution. For free. Just to be helpful.
This is the kind of community I want to be a part of, in IT as in other aspects of life.
Thanks again! :pray:

1 Like

You are very welcome. :+1:

Just for a lark try this:

AutoSuspend & AutoWake

Suspend & Wake up system after a specific time in seconds (15 secs).

sudo rtcwake -m mem -s 15

It can also be used to wake the computer at say 7am or 5pm when you get home from work.


Tried it: it sleeps.
And, when it tries to wake up, you would never imagine what happens: fans spinning, keyboard lighting up, black screen of the eternal standby. :sweat_smile: :expressionless:

If only I could understand why it suspends and wakes without problems in the live usb!

I thought it worth trying, as I use it when testing a service that hangs when resuming.


Try the linux-hardened kernel.


When installing a new kernel do remember the kernel headers as well they are needed for compiling modules against your kernel.


Thank you!
Installed hardened and headers via the Garuda settings tool, restarted with it and… it does not go to suspend. :speak_no_evil:
(black screen for a minute or so, with fans still spinning and keyboard still lighted up)

Test out the linux-clear kernel from the chaotic aur, as it is optimized for Intel hardware.

You may also want to test the linux-clear LTS kernel versions from the AUR.

1 Like

I’ll do: installing from Octopi or pacman, both kernel and headers? Or can I use the Garuda Settings utility as I did for the hardened?
Another thing: if they don’t work and I want to remove them what’s the safe way to do it?

Just remove them… Pacman hooks will handle the rest, eg.

To install them

sudo pacman -S linux-clear linux-clear-headers

and then select it from grub advanced menu while booting.

and to remove them

sudo pacman -Rns linux-clear linux-clear-headers

The hooks will run the necessary commands to update grub, modules and initramfs and everything else.

1 Like

Tnx again @NaN and @tbg.
Installed the clear kernel, but unfortunately it doesn’t even manage to boot up: it gets stuck on the “loading linux-clear / loading iniatial initramfs” screen. :expressionless:

Try switching it to disabled.

This thread is so long now, it’s a little hard to follow! Are we trying to get suspend working, or are we still trying to enable hibernation so the PC can be fully shut down with a saved session?


We are trying to get suspend to work.


Ok, so, good news is: setting “Suspend to RAM” in BIOS as Disabled and clicking on Suspend in Garuda have my keyboard lights go off and the monitor go black and standby. And trying to wake the system up, well, actually wakes it up!
Bad news is: I hear the fans still spinning, so I guess it’s not really going into suspend. :upside_down_face:

Oh, and in the meantime I updated the system and I think I now got the latest linux-zen-6.6.2.zen1-1 kernel.

1 Like

It sounds like your mobo has an inbuilt power management system that is not compatible with Linux. That is actually pretty common; my home PC has a similar situation. No problem to keep it disabled.

The fans should continue to run if needed while in suspend, depending on how warm the machine is. Let it sit for a while and see if they turn off as the temps come down.


They just keep spinning forever. :roll_eyes:

cut the rope
to fan :wink:
New thermal paste, clean the desktop, SSD?
No time to scroll again :wink:


Well that’s great progress.Start searching the internet for similar topics such as:

Fans keep spinning while in suspend Arch Linux

Hopefully you will find a solution as you’re getting close. It only took nearly 100 posts. :rofl:


But if it is indeed not compatible with Linux, why does it suspend perfectly fine when booting from Garuda live USB (or, for that matters, with Linux Mint live USB)? :thinking:

Anyways, I want to thank you all again for your kind help. :pray:
I’m sorry if I’ve exahusted you all in a very, very long thread.
I’ll try and explore on my own now, without further bothering anyone.
But we’ll see if we can manage to reach the “100 posts in a single thread” achievement. :wink:

1 Like

OK, I’ll bite.

Happy 100th !!!

:partying_face: :tada: :fireworks:

Thank you! But wasn’t that only the 99th? :grin:
NOW it’s time to celebrate! :partying_face: :partying_face: :partying_face:

1 Like