Sudo password wrong , even though i am sure its the right password

I am using dragniozed gaming edtion
and after few days of using sudo , sudo decide the password i enter all these past days is suddenly wrong password !!

[sudo] password for abdulhadikh:   
Sorry, try again.
[sudo] password for abdulhadikh:      
Sorry, try again.
[sudo] password for abdulhadikh:   
sudo: 3 incorrect password attempts

i tried to roll back to old snap and that didnt help me !
I would like to get help to fix it ASAP

1 Like

1 Like

It's the User password, not root.

@abdulhadikh write your password in the terminal, so you can confirm your keyboard layout or CapsLock etc is not the problem.

You could try using your root account directly, using


There is a bug related Keyboard Settings in Garuda KDE Dr460nized. The Keyboard Layout occasionally reverts back to English (UK), in which @ (SHIFT+2) key is replaced by ". Maybe because of this the password that is entered is wrong, check System Settings > Keyboard Settings and make sure that the keyboard layout is the one you had set.

Two days ago I experienced the same issue and found out that my /etc/sudoers reverted back to a default state where no user is allowed to use the sudo command. Could that be the result of a system update?
I used "su" to log into my root account and then visudo to modify the sudoers file accordingly.

1 Like

Did you at some point restore a timeshift backup? Afaik /etc/ is included there. So if you revert back to where the /etc/sudoers didnt have your user in there, thats the result :thinking:

1 Like

I don't recall changing my sudoers or restoring any timeshift backup. Sounds weird I must admit. Looking at my snapshots shows that the file has been changed on Jan 11.

Hopefully, we are not mixing two different issues here.

I was pretty sure that the thread creator does not read what the terminal reports to him.

So I gave him the root link.
As @petsam correctly said it was about the user and not root.

To avoid this proplem most people set the same password as root, like in the installation process of calamares.

Now I'm not quite sure if root has a password at all if you leave out the hook because I've never done that :slight_smile:

Translated with (free version) so without warranty :-D.

1 Like

IIUC (translating the translator :laughing:), I hope the setting during installation that gives an option to have the same password for user1000 and user1(=root), creates a password for root, not leaves it with blank password.

Whatever the case, OP will have to answer and act, as our hands cannot pass through screens :rofl:.

In any case, my approach altering sudo config is with snippets, not editing sudoers.


Same issue here. Only it's a fresh install and the root pass doesn't work for sudo. It does in most places but not in the terminal... If I su, then password works, but back to user, I get 3 strikes...
Another issues I have is running update under su, I got files that were not accessible... How?
skypeforlinux.desktop could not be removed under su...?

Also... I did the inital setup and all the apps I chose did not get installed... Actually, none of them. I tried twice and the second time only selected a few... Fyi... Legion 5...

1 Like

Welcome to the forum!
Its nice that you had a search before posting but since this a 6 month old thread it is better to create a new thread with your report + proper system information as described here:


Please don't necrobump, especially for issues where the causes may be different.