Stuck on “Reached Target Graphical Interface” in Live Environment

AMD Ryzen 5 5600X 3.70 GHz
B450 Tomahawk
16GB RAM @ 3200
NVIDIA GeForce RTX 4070 Ti

I tried to get the output from the ‘garuda-inxi’ command, but I couldn’t figure out how to output it to a file on the Live USB I was using. If someone can give me some guidance there, I will happily provide it.

Relatively new to Garuda Linux, managed to get it installed fine with the GNOME variant on my laptop, but having some trouble getting any variant installed on my desktop. I am trying to mostly install the following ISOs as a dual-boot setup with Windows 11:

garuda-dr460nized-linux-zen-230501.iso (prefer this one)
garuda-gnome-linux-zen-230501.iso

I’ve setup a partition on a drive separate from the one with the Windows install that I plan to install Garuda to.

Whether I do normal or grub2 mode, open source or proprietor drivers, with both the GNOME or KDE isos, I keep getting stuck at “Reached Target Graphical Interface” and cannot proceed past that point. Initially I tried making the drive with Rufus, now with Ventroy, made sure SecureBoot is off and BIOS is in CFS mode, no option for Fast Boot to be found.

In the linked thread below I saw a user having a similar issue had to resort to a LTS build of the dr460nized ISO, but the link is dead now, so I was curious if someone knew where I might be able to pull a new version of that to try?

To provide your inxi from the live iso:

I believe you would have to wait for a dev to build it again for you.

1 Like

Awesome, thank you for the link to that post with the command needed to upload the output to termbin; I will run that this evening after work, and post the URL to this thread as soon as I can.

Okay, here is the output from my garuda-inxi command:

https://termbin.com/j85y

System:
  Kernel: 6.2.13-zen-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=garuda
    root=miso:LABEL=GARUDA_DR460NIZED_RAPTOR quiet systemd.show_status=1 ibt=off driver=free
    nouveau.modeset=1 i915.modeset=1 radeon.modeset=1
  Console: tty 2 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Micro-Star model: B450 TOMAHAWK (MS-7C02) v: 1.0
    serial: <superuser required> BIOS: American Megatrends LLC. v: 1.H5 date: 04/22/2021
CPU:
  Info: model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3+ gen: 4 level: v3 note: check
    built: 2022 process: TSMC n6 (7nm) family: 0x19 (25) model-id: 0x21 (33) stepping: 0
    microcode: 0xA201009
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache: L1: 384 KiB
    desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 32 MiB desc: 1x32 MiB
  Speed (MHz): avg: 2566 high: 3700 min/max: 2200/4650 boost: enabled scaling:
    driver: acpi-cpufreq governor: schedutil cores: 1: 3599 2: 2200 3: 3700 4: 2200 5: 2200 6: 2200
    7: 2200 8: 2200 9: 2200 10: 3700 11: 2200 12: 2200 bogomips: 88805
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
Graphics:
  Device-1: NVIDIA AD104 [GeForce RTX 4070 Ti] vendor: Gigabyte driver: N/A alternate: nouveau
    non-free: 530.xx+ status: current (as of 2023-03) arch: Lovelace code: AD1xx
    process: TSMC n4 (5nm) built: 2022-23+ pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 26:00.0 chip-ID: 10de:2782 class-ID: 0300
  Display: server: X.org v: 1.21.1.8 with: Xwayland v: 23.1.1 driver: N/A tty: 102x38
  API: OpenGL Message: GL data unavailable in console. Try -G --display
Audio:
  Device-1: NVIDIA vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 1-2:2 pcie:
    chip-ID: 0b0e:1041 class-ID: 0300 gen: 3 serial: <filter> speed: 8 GT/s lanes: 16 link-max:
    gen: 4 speed: 16 GT/s bus-ID: 26:00.1 chip-ID: 10de:22bc class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 28:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: GN Netcom Jabra PRO 9460 type: USB driver: jabra,snd-usb-audio,usbhid
  API: ALSA v: k6.2.13-zen-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.70 status: off with: 1: pipewire-pulse status: off 2: wireplumber
    status: off 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 22:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 2.79 TiB used: 0 KiB (0.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT1000P5SSD8 size: 931.51 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: P4CR311 temp: 41.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 QVO 2TB size: 1.82 TiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 2B6Q scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Samsung model: Flash Drive FIT size: 59.77 GiB
    block-size: physical: 512 B logical: 512 B type: SSD serial: <filter> rev: 1100 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  Message: No partition data found.
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.54 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 29.1 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 195 Uptime: 6m wakeups: 0 Memory: 15.54 GiB used: 890.1 MiB (5.6%) Init: systemd
  v: 253 default: graphical tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1200
  libs: 327 tools: octopi,paru Shell: Bash v: 5.1.16 running-in: tty 2 inxi: 3.3.26
Garuda (2.6.16-1):
  System install date:     2023-06-28
  Last full system update: 2023-06-28 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       <superuser required>
  Failed units:            

“New” GPU ?
Need other kernel, lts?

Not exactly new, have been using it for a few months now with W11 successfully, but trying to give a few distros of Linux a try now for the first time since I got it. I'd like to try a lts build if I can, but open to any suggestions at this point.

I try to upload the KDE dr460nized lts version to the Cloud.

IDK how long it needs and work, just a try.

1 Like
2 Likes

Thank you for the update and the provided LTS build, I appreciate the help. I downloaded this and gave it a shot, and there is progress, but now it is stalling at "Finished Live Media Keyring Setup" in both normal and grub2 mode, with open source and proprietary Nvidia drivers.

I pulled a new garuda-inxi log:

https://termbin.com/nz9m

System:
  Kernel: 6.1.35-1-lts arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=garuda
    root=miso:LABEL=GARUDA_DR460NIZED_RAPTOR quiet systemd.show_status=1 ibt=off driver=free
    nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 rdinit=/vtoy/vtoy
  Console: tty 2 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Micro-Star model: B450 TOMAHAWK (MS-7C02) v: 1.0
    serial: <superuser required> BIOS: American Megatrends LLC. v: 1.H5 date: 04/22/2021
CPU:
  Info: model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3+ gen: 4 level: v3 note: check
    built: 2022 process: TSMC n6 (7nm) family: 0x19 (25) model-id: 0x21 (33) stepping: 0
    microcode: 0xA201009
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache: L1: 384 KiB
    desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 32 MiB desc: 1x32 MiB
  Speed (MHz): avg: 2200 min/max: 2200/4650 boost: enabled scaling: driver: acpi-cpufreq
    governor: schedutil cores: 1: 2200 2: 2200 3: 2200 4: 2200 5: 2200 6: 2200 7: 2200 8: 2200
    9: 2200 10: 2200 11: 2200 12: 2200 bogomips: 88842
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
Graphics:
  Device-1: NVIDIA AD104 [GeForce RTX 4070 Ti] vendor: Gigabyte driver: N/A alternate: nouveau
    non-free: 530.xx+ status: current (as of 2023-05) arch: Lovelace code: AD1xx
    process: TSMC n4 (5nm) built: 2022-23+ pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 26:00.0 chip-ID: 10de:2782 class-ID: 0300
  Display: server: X.org v: 1.21.1.8 with: Xwayland v: 23.1.2 driver: N/A tty: 102x38
  API: OpenGL Message: GL data unavailable in console. Try -G --display
Audio:
  Device-1: NVIDIA vendor: Gigabyte driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s
    lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 26:00.1 chip-ID: 10de:22bc class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 28:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: GN Netcom Jabra PRO 9460 driver: jabra,snd-usb-audio,usbhid type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-2:2 chip-ID: 0b0e:1041 class-ID: 0300
    serial: <filter>
  API: ALSA v: k6.1.35-1-lts status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.71 status: off with: 1: pipewire-pulse status: off 2: wireplumber
    status: off 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 22:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 2.79 TiB used: 0 KiB (0.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT1000P5SSD8 size: 931.51 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: P4CR311 temp: 44.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 QVO 2TB size: 1.82 TiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 2B6Q
    scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Samsung model: Flash Drive FIT size: 59.77 GiB
    block-size: physical: 512 B logical: 512 B type: USB rev: 3.0 spd: 5 Gb/s lanes: 1
    mode: 3.2 gen-1x1 tech: SSD serial: <filter> fw-rev: 1100 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  Message: No partition data found.
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.54 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 39.6 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 229 Uptime: 3m wakeups: 0 Memory: available: 15.54 GiB used: 1.12 GiB (7.2%)
  Init: systemd v: 253 default: graphical tool: systemctl Compilers: gcc: 13.1.1 Packages:
  pm: pacman pkgs: 1194 libs: 323 tools: octopi,paru Shell: Bash v: 5.1.16 running-in: tty 2
  inxi: 3.3.27
Garuda (2.6.16-1):
  System install date:     2023-06-29
  Last full system update: 2023-06-29 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       <superuser required>
  Failed units:            

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.