Stuck on Black Screen after system update, cannot bring up tty, no keyboard shortcuts work. (Problems Occurrs with Gnome edition and Dragonized edition)

My problem is a bit strange, I will provide with any log files and stuff if its possible, just ask me for what you need.
I am on a Razer Blade Stealth 13 (Early 2020)
1650 Ti Max-Q
(its a 4k screen btw, if that has anything to do with this)

The issues occurred as follows:

I first installed Garuda Dragonized version, which I downloaded on the 20th of April, updated the system, works fine, nothing wrong with the system. Loved it!

I decided to switch back to Fedora to check something the next day,
on the 22nd of April, I reinstalled Garuda Dragonized using the same ISO, did a full system update on the Garuda assistance menu. Restarted the system, and it boots in to a black screen.
The keyboard shortcuts I tried in the blackscreen were,
-arrow keys
(i saw something similar being posted and was asked to use a chroot ? to get to a console but, I'm not sure how to do that).

Interestingly, the same ISO works just fine on my desktop (the system I am trying to make it work on is my razer blade laptop).

Then again, I re-downloaded a few flavours of garuda again on the 24th of April,
Dragonized - BlackArch

all 4 works fine on my Desktop machine.
But, I have the exact same issue on my laptop with them EXCEPT Dragonized - BlackArch.
For some reason, the BlackArch edition I could fully update and it boots and work fine.

If it helps, I noticed I get some weird errors related to CPU when I am running another distro like Fedora on my laptop, from versions 32 until 34(beta). But no problem on my desktop.

I have also tried several settings in my UEFI/BIOS settings,
Tried different Storage settings, AHCI, RAID, etc
Tried on VT-D enabled and disabled both.
Tried Secure boot both enable and disabled.

I am not sure exactly which information would come useful, Just let me know what else I could provide. BIOS/UEFI settings screenshots, logs etc.

(I am not that tech savvy and new to Linux, so kindly do explain a bit if you ask me to try something, like the exact commands and stuff, I would really appreciate that)

Thanks to anyone who comes out to give a hand with my issue. Sorry to take your time, any help is much appreciated. Thank you :grin: :+1:
(P.S, this is my first post on any online forum)

This is the only little help I can offer, but maybe a starting point:

In addition to tat maybe:


Thank you, The first one about chroot seems really helpful, I am gonna try that in few hours and post on how it goes,

Regarding the second one about graphics driver, This could be it too actually, is there a difference between which version of the graphics driver is grabbed during update, depending on which flavor or spin of Garuda I am running.
This is because, the BlachArch edition works just fine after updating, its just the normal Dragonized edition and Gnome which breaks after update for me (I have only tested 3, as mentioned on the original post), with the black screen problem that I had posted.
I wonder if someone could investigate that and see if there is a version difference for the grabbed graphics driver between Garuda flavours.

Thanks for the help filo. Ill be trying chroot. Appreciated

1 Like

This is far beyond my reach :slight_smile: and we'll need the experts here...
Maybe a difference is in the Display Manager (e.g. GDM, LightDM, SDDM) but I have no clue as regards the graphic driver, this should be the same...

By-the-way, you don't necessarily need to chroot from a live ISO to start troubleshooting, if you just add 3 at grub (select your line, and press button E and add 3 at the end of the line starting with linux), you will boot to TTY.
In that context, you could also try something else (e.g. remove "splash") before or after trying with the '3' (not in the same test).


Thanks a lot for the kind help filo!

So, I was able to make it to TTY! Keep in mind, I actually redownloaded the ISO file just in case, and did a fresh install, was able to recreate the exact same problem. When I was updating, I got a few warnings regarding nvidia drivers dependency etc (sorry if that is-not that helpful), But I can put a dump of the entire update process from the terminal here, its pretty lengthy, how would I go about pasting the the stuff from shell ?

Secondly, after making it into TTY thanks to your advice, I went ahead and followed the short guide already in the forum regarding the same issue and when in TTY. (the guide you posted in your original answer, which also happened to be what came up when I searched for the issue first)
There were 2 methods, while trying the first method, I was not able to get a mirror list because the connection seems to time out for every mirror.
Then I checked if I was actually connected to the internet since I am on a laptop with just WiFi, used the command ;iwconfig;
It showed that I was indeed connected to my WiFi connection. It's a pretty stable connection.

Fortunately, the second method worked for me, I was able to boot in upon feeding it the command ;startx; (when startx is run, it spits a few lines before booting in, I can grab that as well if needed)

There was no issues with the UI, everything seemed fine, I was so surprised to see it was Gnome 40!! Loved it !

a few things I noticed were that my shell when opened reports some weird conflict error about starship ? I was able to fix it after updating starship and copying that .toml file, according to the guide in the form

My only concern now Is that, I'd have to first get into TTY the hard way, every time I boot into Garuda, login, and run startx().

I have done all updates in TTY and in the System, there was no update, but do note that I was not able to get a mirror list in TTY, all mirrors timed out, but running ;sudo pacman -Syyu; reported there was nothing to update, True I did update the system right after installation

Is there a way to fix this permemantly ? I am obviously gonna keep trying on my own, So far I tried adding startx to the .bashrc file, (not sure if that is stupid).
Asking, just in case there is already a ready-made fix for this issue.

P.S I am making my answers as detailed as possible, Do let me know if these types of replies are not preferred and a more summarized reply is better in these forums, again, This is my first post in an online forum of any sort

also, yes, this led me to think it indeed is a problem with the Display Manager like you mentioned, which seems an issue some others encountered as well.

Once again, Thank you and I appreciate it a lot!


Glad you made some progress, but even more now we'll need someone more experienced...
If startx works, it should be a problem with the display manager.
A few days ago there were problems with one of them, sddm, but everything was fixed and should be working after the update.
Did you try removing splash from the grub string?
Maybe it is something related to the graphics drivers.
I hope someone will jump in with the next advices :blush:


Perhaps try installing the git version of whichever display manager you are using to see if the issue is present on the developmental version of the display manager.

Very nicely done working your way through your long list of issues.

Welcome to Garuda.


Thanks for the responses. Truly a wonderful community, I feel really welcomed to this new and probably my first (internet) community.

What worked until this point was using chroot to get to TTY using CTRL + ALT + F4
and then login to my account, used the command
to boot in, there were no issues whatsoever from then on, besides small problems which I have described in the original post such as, starship issue on alacritty (which was easily fixed :slight_smile: ).

What I have now done to weirdly Fix it

I'll Give an update on what I have done according to what I was directed by flio & tbg and other posts I found in the forum.

First of all, I feel like I did things in the wrong order, but
my first attempt was to change my display manager version to a developmental version as tbg adviced. I assumed that this means the -git version of my display manager (to be honest, I don't really know what a display manager really is except some basic understanding from searching it up).

I also assumed that my display manager could be either GDM, LightDM or SDDM as mentioned on the forum.

  • I reinstalled Garuda Gnome flavor from scratch again.
  • upon installation, followed by a reboot, I was welcomed with the Garuda Assistant prompt,
  • Before doing anything here I decided to first switch my DM
    • I figured that typing
      systemctl status display-manager.service
      showed me which Display Manager I was using, which was reported as GDM
      I then closed the terminal as the status process was running for this service ? and I was about to change the service so..
  • Then I opened up the software application (pamac ?) and searched for gdm

The Software app reported a few packages when searched for gdm, I could-not find any version ending with a -git or something like that. There is 3 available, gdm, gdm-prime & gdm-plymouth
Since my Razer Blade laptop has Nvidia Optimus, I went ahead and got the gdm-prime which is for optimus laptops apparently?

Another reason, I chose the GUI software app is because, it reported to me saying, it's gonna remove the existing gdm and replace it with gdm-prime, then I installed it along with all of its dependencies, which auto removed the existing gdm I believe.

Then, I checked for updates, there was no updates apparently.. so I just rebooted the system.

Unfortunately, the same problem still persisted.. so, switching to gdm-prime really did-not do anything for me here. I also tried the same thing with gdm-plymouth again after a second fresh installation of Garuda, and the results were same,
Note that, gdm-plymouth was on version 40.0 apprently ? the others were on 3.XX.X (check and change to real version later)
But on reboot, all 3, gdm, gdm-plymouth and gdm-prime, all looks like the new Gnome 40 desktop, even though the version reported is 3.XX.X.

Here is what I did next, Which Worked (kindah?), Which I should Have Done First
I then went on to what filo recommended me first, about removing 'splash' from the grub string.
this is easily achieved by

hitting the 'E' key on Grub load screen

and then searching and removing 'splash' from the string, and using

hitting the CTRL + X key-Combination to continue to boot

This, then with no issues, booted me into my Desktop.

However, the only flaw was that this change is not permanent, similar to using startx to in the tty text terminal when stuck in the blank black screen on boot.

I figured that this grub file must be located somewhere, and went ahead to try and edit the actual file which is read.
I found a few locations where a "grub configuration file" was located in my system.

which Pointed me to the location of the template which is used to generate this file using
grub-mkconfig, the template file was located in
file named as grub

I opened up both files, removed 'splash' from the string, saved it. Rebooted system, Problem still persists. And I checked with hitting 'E' on a second reboot to check if the change was applied, it was-not.

I then went ahead, and removed all instances of 'splash' in the main, auto-generated grub.conf file. (I could-not figure out how to make it auto generated using that grub-mkconfig mentioned in the file, as a comment.

Which then, Worked!

when booting in, it does generate some weird [OK] texts for like half a second though, but it does indeed work. Thanks to what filo suggested, I removed 'splash' from grub.

I obviously have a lot of concerns though, First of all, to be completely honest, I have no idea what I am doing, whatsoever, I am afraid this might break my system or something.. As I do intend to use Garuda as my main system, which will store many of my important files etc.

I know this "solution" which worked for me, really is-not a good way to do this, Please do let me know the proper was to go about this and point out my mistakes during this process, I did my best to look up what I can with the time I have.

P.S, I read the post about formatting, posts, I gave it a try, Hope I formatted correctly.
Once again, Thanks for all who are helping me, Much appreciated, Like I said, I am not a tech-savvy person and new to linux, so do explain a bit to your best in reponses. Thanks again :grin:


Wow! Very well done!
The only thing I'd say is that playing around with the grub config files only to make the parameter persistent was a bit dangerous (but you did it fine in the end), while there is a nice tool to do that from the Garuda Assistant.
As regards possibile side effects of removing splash, I don't know...
If I were you, I'd keep an eye to the next updates of gdm. I'd always make a try to reintroduce splash in that case. Maybe this is something that will be fixed.
Not sure though which GDM version is best for you.
Let's are, there are also many gnome users here (I'm in KDE).


You have no reason to worry, in fact you just removed an option we enabled to have Plymouth working. Removing splash means you will likely see some system messages, by removing "quiet" as well you could see the entire boot log instead (which, to be honest, is pretty cool and makes my non tech people go omg, fast scrolling text, he must be a hacker :crazy_face: )
Also, nice to see someone actually trying stuff & documenting it. That gives hope :smiley:


Very nicely done, except you should have run sudo update-grub after editing /etc/default/grub.

I'm very impressed by your level of motivation to learn new things.

Bonus points to you for effort. :+1:


Thanks a lot everyone!

The problem is now solved ,

  1. Did a Fresh install of Garuda Gnome Edition (it worked even without a fresh install though)

  2. Did a full system update upon first boot to the system, THEN before restarting, I made a change to the grub file located in


the change made to the grub file was removing 'splash' from the string in the grub file

After that, the change was applied by running the following command in the terminal

sudo update-grub

After that, I rebooted the system. And everything works fine!

Only thing I noticed after the fix was seeing a flash of some "boot log" messages when booting, for a second though.

The same thing can be achieved in the Garuda Assistant GUI, under the Boot Options, there was a CheckBox I could untick, to remove 'splash' from the string in grub file. Thanks a lot for pointing that out, @filo

And I will keep checking if the Booting problem is fixed by adding back 'splash' to the string in the grub file, on every major update, especially to gdm, in case the problem is fixed :grin:

Another thing..
I was able to achieve the same thing even without a fresh install when I unable to boot and stuck on the black screen. Here is what I did :

In my case, I was stuck in the black screen, without being able to use any keyboard shortcuts, I used the guide provided in the forum for using chroot to get to a tty for text based terminal, othwise using CTRL + ALT + F2, and then log in and use the command


to boot in to desktop.
This however is-not a permanently solution in my case, but it works!
Furthermore, this gave me a 'not authenticated' error on the login screen somtimes, locking me out.

Upon booting into the desktop using startx, I was able to perform all the steps mentioned above to get everything working fine consistently.

I am still not sure, what the exact root cause of this, but there are certain important things I noted down.

  • The root problem is still not known, I am unsure if this is related to my Nvidia drivers, Display Manager ? etc.
  • Fixing the problem with booting with grub works best for my case on Garuda Gnome Flavor, I read on the forum that for some people, switching to the Git-Version of the Display Manager or Updating the Display Manager fixed it. (note that I am on a Razer Blade Stealth 2020)

Lastly, thank you so much, for the fast responses by the forum members, to fix this problem quickly. I can get my work done the next day now.
Thanks, again for directing me into solve the problem. Really appreciate it. :grin: :+1:

Garuda Fly! Fly Like an Eagle!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.