Stuck in snapshot after frozen upd

Ran upd this morning, laptop froze, nothing responded, Ctrlc, alt-f4, mouse, keyboard frozen

Held power off 10 sec to reboot.

Grub - only option was to load snapshot, Tried many with different kernels.

All black screen

CtrlAltf1 Which I think is tty1
stops at same place

CtrlAltf2 tty2
can log in.

Not sure how to restore snapshot from terminal

Found related thread

sudo btrfs subvolume list

output very long last line is

 ID 2692 gen 1988206 top level 263 path @/.snapshots/2034/snapshots

none of the lines have a " restore_backup_@_ " in it

Posting from different laptop, can’t share output of commands

findmnt /
/ /dev/nvme0n1p1[/@/.snapshots/2034/snapshot] btrfs rw.notime.compress=zstd:3,ssd,discard=async.space_cache=v2.subvolid=1692.subvol=/@/.snapshots/2034/snapshot

I assume the solution may be simliar to below but not sure what I should change for line 2 and 4

sudo mkdir -p /mnt/btrfs
sudo mount /dev/sda2 /mnt/btrfs -o subvolid=5
sudo rmdir /mnt/btrfs/@/.snapshots
sudo mv /mnt/btrfs/restore_backup_@_202148186/.snapshots /mnt/btrfs/@/.snapshots
sudo umount /mnt/btrfs

Any help would be very appreciated. Id rather not reinstall.

1 Like

Please post garuda-inxi from chroot or live ISO.


Sorry when I boot into live usb wifi is unavailable. Never seen this before. Any suggestion?

tethering via smartphone?

Which DE are we talking about?


This is from live-usb but not my ssd,

  Kernel: 6.2.13-zen-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=garuda
    root=miso:LABEL=GARUDA_CINNAMON_RAPTOR quiet systemd.show_status=1 ibt=off
    systemd.unified_cgroup_hierarchy=1 driver=nonfree nouveau.modeset=0 i915.modeset=1
  Desktop: Cinnamon v: 5.6.8 tk: GTK v: 3.24.37 wm: muffin vt: 7 dm: LightDM v: 1.32.0
    Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: EVOO Products product: EG-LP4 v: Standard serial: <superuser required>
  Mobo: EVOO Products model: GK5CP5X v: Standard serial: <superuser required>
    UEFI-[Legacy]: American Megatrends v: N.1.05 date: 10/10/2019
  ID-1: BAT0 charge: 31.9 Wh (100.0%) condition: 31.9/46.7 Wh (68.3%) volts: 12.8 min: 11.4
    model: standard type: Li-ion serial: <filter> status: full
  Info: model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Coffee Lake gen: core 9 level: v3
    note: check built: 2018 process: Intel 14nm family: 6 model-id: 0x9E (158) stepping: 0xA (10)
    microcode: 0xF0
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache: L1: 384 KiB
    desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 1325 high: 2600 min/max: 800/4500 scaling: driver: intel_pstate
    governor: powersave cores: 1: 900 2: 900 3: 901 4: 900 5: 900 6: 2600 7: 900 8: 900 9: 900
    10: 2600 11: 900 12: 2600 bogomips: 62399
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Tongfang Hongkong driver: i915
    v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1 empty: none
    bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: Tongfang Hongkong
    driver: nvidia v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
    status: current (as of 2023-03) arch: Turing code: TUxxx process: TSMC 12nm FF built: 2018-22
    pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1f91 class-ID: 0300
  Device-3: Chicony HD Webcam type: USB driver: uvcvideo bus-ID: 1-13:5 chip-ID: 04f2:b642
    class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.8 driver: X: loaded: modesetting,nvidia unloaded: nouveau
    alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: LG Display 0x05e8 built: 2018 res: 1920x1080 hz: 144 dpi: 142
    gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel Cannon Lake PCH cAVS vendor: Tongfang Hongkong driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA vendor: Tongfang Hongkong driver: snd_hda_intel v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403
  API: ALSA v: k6.2.13-zen-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:a370 class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Tongfang Hongkong
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 04:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0 state: down mac: <filter>
  Local Storage: total: 7.96 TiB used: 0 KiB (0.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-m
in: 259:0 vendor: Western Digital model: WDS500G2X0C-00L350
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
    serial: <filter> rev: 101110WD temp: 44.9 C scheme: MBR
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 QVO 8TB size: 7.28 TiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 2B6Q scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: SanDisk model: USB 3.2Gen1 size: 232.88 GiB
    block-size: physical: 512 B logical: 512 B type: N/A serial: <filter> rev: 1.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No partition data found.
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.47 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
  System Temperatures: cpu: 49.0 C pch: 55.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 311 Uptime: 4m wakeups: 1 Memory: 15.47 GiB used: 3.62 GiB (23.4%) Init: systemd
  v: 253 default: graphical tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1274
  libs: 339 tools: paru Client: shell wrapper v: 5.1.16-release inxi: 3.3.26
Garuda (2.6.16-1):
  System install date:     2024-03-18
  Last full system update: 2024-03-18 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       <superuser required>
  Failed units:            

Did you try chroot and update the system?
I mve it to Cinnamon


I am sorry not sure what that means

when I booted to tty i could not do update because db.lck. couldn’t delete it because read only file system

Im watching a video about chroot right now.

is this something I run from the live cd? or do I reboot into the tty screen?

live ISO , garuda welcome, chroot button.


in live iso, garuda welcome clicked chroot.

In terminal

grub-probe: error: cannot find a GRUB drive for /dev/sdb2.  Check your
grub-probe: error: cannot find a GRUB drive for /dev/sdb2.  Check your
==> Mounting (Debian_GNU/Linux_11_(bullseye)) [/dev/nvme0n1p1]
 --> mount: [/mnt]
root@garuda-cinnamon:/# garuda-inxi
bash: garuda-inxi: command not found

I read the post not sure what I need to do. Sorry I am so new, hope you can keep helping me.

I am in the middle of backing up my home directory after that I will reboot and try the steps again. It will be a while TY

Ty for your help. I didn’t realize i could restore snapper files with the live-iso.

So grateful for the wonderful tools and helpful team at Garuda.



Booted into live-is (usb)
Garuda-Welcome window (should open default)
Clicked "Chroot" (not sure if needed)
Clicked toolbar menu button typed "btrfs" [Enter] (Btrfs Assistant
Clicked snapper top tab
Clicked Browse/Restore
Clicked Last known good snapshot
Clicked Restore (top right)
Gave name (optional)
Told to reboot, rebooted 
Start up took much longer than normal
Cinnamon desktop loaded, ran upd from terminal
System updated with issue
rebooted to confirm issue was resolved

Btw, to prevent such situations in future, just make sure that you have enough RAM and Disk space while updating the system, and CPU is not very busy.

Sometimes, the system might freeze while updating due to any of above 3 things, and hence corrupt the files. Anyways, you always has snapper to save you :smiley:


Thanks. I can’t recall if I was doing anything else other then sharing torrents of linux iso and doing some transcoding in jelly fin. Pretty standard stuff for me. My laptop has never frozen up before so it was very strange. I do know I have some pacnew files I need to resolve. Hope it doesn’t happen again. Thanks aga to SGS for the help.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.