SSH Problem - Terminal type alacritty is not defined

This is new to me, everything been working fine and then all the sudden when I use ssh, this happens.

emacs: Terminal type alacritty is not defined.
If that is not the actual type of terminal you have,
use the Bourne shell command `TERM=... export TERM' (C-shell:
`setenv TERM ...') to specify the correct type.  It may be necessary
to do `unset TERMINFO' (C-shell: `unsetenv TERMINFO') as well.

Should $TERM be xterm-256color since default /home/X/.config/alacritty/alacritty.yml states

env:
  # TERM variable
  #
  # This value is used to set the `$TERM` environment variable for
  # each instance of Alacritty. If it is not present, alacritty will
  # check the local terminfo database and use `alacritty` if it is
  # available, otherwise `xterm-256color` is used.
  TERM: xterm-256color
1 Like

I have not seen that one before either :thinking:
Actually this is set already in fish config (assuming you use it)

## Set environment
set TERM "xterm-256color"             
set EDITOR "micro"

While looking at ~/.profile I noticed another TERM is set (TERM=alacritty) so thats quite redundant. Gotta change this! Also:

Probably the ssh session doesnt support session type alacritty and errors out.

2 Likes

Are you sure it has nothing to do with your ssh settings/configuration?

Yes I use fish.
And YES THE .profile FILE!!!!

export EDITOR=/usr/bin/micro
export BROWSER=firefox
# export TERM=alacritty
export MAIL=thunderbird
export GTK2_RC_FILES="$HOME/.gtkrc-2.0"

Simply commenting it out fixed the problem for me.

Big Thanks.

1 Like