Some apps like pamac doesn't follow the dark theme and appear completely white

Hi everyone

I keep trying to apply dark theme to all GUI apps but some of them just can’t follow the theme no matter what i do or what other changes i made, so i am kinda lost with this one, does anybody have any clue about what suddenly pamac turned white and some apps doesn’t apply the dark theme?

  Kernel: 6.6.1-1-clear arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-clear
    root=UUID=becffce5-d826-4b85-9694-9f527a8a6835 rw rootflags=subvol=@
    quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
  Type: Desktop System: Dell product: Precision Tower 5810 v: N/A
    serial: <filter> Chassis: type: 7 serial: <filter>
  Mobo: Dell model: 0HHV7N v: A00 serial: <filter> UEFI: Dell v: A34
    date: 10/19/2020
  Info: model: Intel Xeon E5-1650 v3 socket: LGA2011-3 bits: 64 type: MT MCP
    arch: Haswell level: v3 note: check built: 2013-15 process: Intel 22nm
    family: 6 model-id: 0x3F (63) stepping: 2 microcode: 0x49
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 15 MiB desc: 1x15 MiB
  Speed (MHz): avg: 3546 high: 3800 min/max: 1200/3800 base/boost: 3500/4000
    scaling: driver: intel_cpufreq governor: performance volts: 1.8 V
    ext-clock: 100 MHz cores: 1: 3800 2: 2987 3: 3800 4: 1571 5: 3800 6: 3800
    7: 3800 8: 3800 9: 3800 10: 3800 11: 3800 12: 3800 bogomips: 83812
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: NVIDIA GM204GL [Quadro M5000] driver: nouveau v: kernel
    alternate: nvidiafb non-free: 545.xx+ status: current (as of 2023-10;
    EOL~2026-12-xx) arch: Maxwell code: GMxxx process: TSMC 28nm
    built: 2014-2019 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
    speed: 8 GT/s ports: active: DP-1,DVI-I-1 empty: DP-2,DP-3,DP-4
    bus-ID: 03:00.0 chip-ID: 10de:13f0 class-ID: 0300 temp: 41.0 C
  Display: x11 server: X.Org v: 21.1.9 compositor: xfwm v: 4.18.0 driver: X:
    loaded: nouveau unloaded: modesetting alternate: fbdev,nv,vesa dri: nouveau
    gpu: nouveau display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.00x11.22")
    s-diag: 1055mm (41.54")
  Monitor-1: DP-1 pos: primary,left model: Samsung S27B350 serial: <filter>
    built: 2012 res: 1920x1080 hz: 60 dpi: 82 gamma: 1.2
    size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  Monitor-2: DVI-I-1 pos: right model: BenQ GW2750H serial: <filter>
    built: 2012 res: 1920x1080 hz: 60 dpi: 82 gamma: 1.2
    size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
    max: 1920x1080 min: 640x480
  API: Vulkan v: 1.3.269 layers: 5 device: 0 type: cpu name: llvmpipe (LLVM
    16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM 16.0.6)
    device-ID: 10005:0000 surfaces: xcb,xlib
  API: OpenGL Message: Unable to show GL data. glxinfo is missing.
  Device-1: Intel C610/X99 series HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8d20 class-ID: 0403
  Device-2: NVIDIA GM204 High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
    speed: 8 GT/s bus-ID: 03:00.1 chip-ID: 10de:0fbb class-ID: 0403
  API: ALSA v: k6.6.1-1-clear status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.85 status: n/a (root, process) with:
    1: pipewire-pulse status: active 2: wireplumber status: active
    3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Ethernet I217-LM vendor: Dell driver: e1000e v: kernel
    port: f020 bus-ID: 00:19.0 chip-ID: 8086:153a class-ID: 0200
  IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Hardware-1: Intel C600/X79 series SATA RAID Controller driver: ahci v: 3.0
    port: f000 bus-ID: 00:1f.2 chip-ID: 8086:2826 rev: N/A class-ID: 0104
  Local Storage: total: 4.09 TiB used: 836.92 GiB (20.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT500MX500SSD1
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 043 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD4004FZWX-00GBGB0 size: 3.64 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
    fw-rev: 0A81 scheme: GPT
  ID-1: / raw-size: 465.36 GiB size: 465.36 GiB (100.00%)
    used: 35.21 GiB (7.6%) fs: btrfs block-size: 4096 B dev: /dev/sda1
    maj-min: 8:1
  ID-2: /boot/efi raw-size: 406 MiB size: 405.2 MiB (99.80%)
    used: 576 KiB (0.1%) fs: vfat block-size: 512 B dev: /dev/sda2 maj-min: 8:2
  ID-3: /home raw-size: 3.63 TiB size: 3.63 TiB (100.00%)
    used: 801.71 GiB (21.6%) fs: btrfs block-size: 4096 B dev: /dev/sdb1
    maj-min: 8:17
  ID-4: /var/log raw-size: 465.36 GiB size: 465.36 GiB (100.00%)
    used: 35.21 GiB (7.6%) fs: btrfs block-size: 4096 B dev: /dev/sda1
    maj-min: 8:1
  ID-5: /var/tmp raw-size: 465.36 GiB size: 465.36 GiB (100.00%)
    used: 35.21 GiB (7.6%) fs: btrfs block-size: 4096 B dev: /dev/sda1
    maj-min: 8:1
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 62.72 GiB used: 2.2 MiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc max-streams: 12 dev: /dev/zram0
  System Temperatures: cpu: 50.0 C mobo: N/A sodimm: SODIMM C gpu: nouveau
    temp: 41.0 C
  Fan Speeds (rpm): cpu: 1075 gpu: nouveau fan: 1175
  Processes: 551 Uptime: 2h 45m wakeups: 0 Memory: total: 64 GiB
  available: 62.72 GiB used: 9.7 GiB (15.5%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: pacman pkgs: 1663 libs: 449 tools: pamac,paru
  Shell: garuda-inxi (sudo) default: Bash v: 5.2.15 running-in: xfce4-terminal
  inxi: 3.3.31
Garuda (2.6.19-2):
  System install date:     2022-12-29
  Last full system update: 2023-11-21 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager mkinitcpio
  Windows dual boot:       No/Undetected
  Failed units:

please reboot the system , and put the code between </>

and the topic below have the solution :

1 Like

Unfortunately, this does not work with pamac.
Long story.

Just use octopi or pacseek. :slight_smile:


I’d suggest replacing Pamac with Bauh, cause it will grab the system theme once you sit it in settings and it will handle Aur, Flatpak, Snap, Web, Appimage.

1 Like

The issue is actually that some apps do not follow the system colors.

Pamac, which should only be used for searching, is just a side issue.

We strongly recommend using only the terminal for installation and updating the system with garuda-update (update, upd, [paru]). :slight_smile:

1 Like

1 Like

I saw only in GNOME the dark version, it does not work on other DE.

Actually it depends on the version. I have seen Pamac follow the system themeing without issue plenty of times in Plasma. One just has to grab the right version. I know cause I’ve done fresh installs of OS’s and Pamac wasn’t behaving as far as keeping it’s size and appearance so I tried the various ones and eventually ran into one that finally picked up the system theme. My issues with Pamac are the themeing issue, the fact that it can and will change size after it’s updated, and the fact that it does not always show all the issues. I like Bauh for the reasons I mentioned and the fact that it maintains its same size even after being updated, not to mention it catch all updates that are out there.

As for updating the system yes use Bauh to see which updates are out there, decide if you want to update now based on the list of updates, if you do launch konsole and update from their.

pamac-gtk3 :slight_smile:

I don’t know BAUH, so I don’t know if it gives feedback for orphaned packages, pacnew, pacsave, messages and notes from the apps like in the terminal and if it catches errors like the garuda-update. :slight_smile:

Welcome to the Garuda community @xuser948. :wave:

I have edited your OP (Opening Post) to format your garuda-inxi output properly so that users on portable devices don’t have to scroll down a half a mile to the finish. Please click the pencil icon at the bottom of your OP to view how to format a code block properly in the future.



Just like Pamac it just tells you what updates are out there. Like Pamac I would never actually use it to update. The main reason I never used Pamac to update is cause it can run across issues updating or simply trying to install something where doing the same update or installing the same app from one’s terminal usually doesn’t have the install issues.


I’m curious about it, why suddenly some apps doesn’t follow the system colors? what’s going on with the updates? it really cannot be fixed from the app itself like pamac?

Wow this actually worked, i didn’t notice it was that simple thank you so much!

That’s actually an interesting suggestion and will test it, it seems more useful than octopi, thank you.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.