[Solved] SMPlayer fails to show video

I've been having an issue with SMPlayer since a while. Contacted the devs and even they couldn't identify the problem. Asking here if someone has an idea.

SMPlayer (with MPV) had been working well before. Until about when the Plasma updates came out, then it stopped working some time ago. It will play the audio only and fail to display the video.

With the option "Run MPV in its own window", it works fine. The flatpack version of SMPlayer also works (but doesn't show in start menu). Only the pacman version stopped showing the video. (removing the extra MPV arguments doesn't solve it)

Why is it failing?

Here's the MPV log

/usr/bin/mpv --no-quiet --terminal --no-msg-color --input-ipc-server=/tmp/smplayer-mpv-f73e7 --msg-level=ffmpeg/demuxer=error --video-rotate=no --no-fs --hwdec=no --sub-auto=fuzzy --vo=gpu, --no-input-default-bindings --input-vo-keyboard=no --no-input-cursor --cursor-autohide=no --no-keepaspect --wid=134217745 --monitorpixelaspect=1 --osd-level=2 --osd-scale=1 --osd-bar-align-y=0.6 --sub-ass --embeddedfonts --sub-ass-line-spacing=0 --sub-scale=1 --sub-font=Arial --sub-color=#ffffffff --sub-shadow-color=#ff000000 --sub-border-color=#ff000000 --sub-border-size=0.75 --sub-shadow-offset=2.5 --sub-font-size=50 --sub-bold=no --sub-italic=no --sub-margin-y=8 --sub-margin-x=20 --sub-codepage=ISO-8859-1 --vid=1 --sub-pos=100 --volume=110 --cache=auto --start=200 --screenshot-template=cap_%F_%p_%02n --screenshot-format=jpg --screenshot-directory=/home/hanuman/Pictures/smplayer_screenshots --audio-pitch-correction=yes --volume-max=110 --hr-seek-framedrop=no --profile=gpu-hq --gpu-api=vulkan --hwdec=auto-copy --vulkan-async-compute=yes --vulkan-async-transfer=yes --vulkan-queue-count=1 --autofit=85%x85% --dither=error-diffusion --deband=yes --deband-iterations=2 --deband-threshold=20 --deband-range=16 --scale=ewa_hanning --scale-radius=3.2383154841662362 --cscale=ewa_lanczossoft --dscale=mitchell --scale-antiring=0 --cscale-antiring=0 --correct-downscaling=yes --linear-downscaling=no --sigmoid-upscaling=yes --blend-subtitles=no --hdr-compute-peak=yes --tone-mapping=mobius --glsl-shaders-clr --fbo-format=rgba16f --glsl-shader=~/.config/mpv/shaders/FSRCNN_x2_r2_32-0-2.glsl --term-playing-msg=MPV_VERSION=${=mpv-version:}
INFO_VIDEO_WIDTH=${=width}
INFO_VIDEO_HEIGHT=${=height}
INFO_VIDEO_ASPECT=${=video-params/aspect}
INFO_VIDEO_FPS=${=container-fps:${=fps}}
INFO_VIDEO_FORMAT=${=video-format}
INFO_VIDEO_CODEC=${=video-codec}
INFO_DEMUX_ROTATION=${=track-list/0/demux-rotation}
INFO_AUDIO_FORMAT=${=audio-codec-name}
INFO_AUDIO_CODEC=${=audio-codec}
INFO_AUDIO_RATE=${=audio-params/samplerate}
INFO_AUDIO_NCH=${=audio-params/channel-count}
INFO_LENGTH=${=duration:${=length}}
INFO_DEMUXER=${=current-demuxer:${=demuxer}}
INFO_SEEKABLE=${=seekable}
INFO_TITLES=${=disc-titles}
INFO_CHAPTERS=${=chapters}
INFO_TRACKS_COUNT=${=track-list/count}
METADATA_TITLE=${metadata/by-key/title:}
METADATA_ARTIST=${metadata/by-key/artist:}
METADATA_ALBUM=${metadata/by-key/album:}
METADATA_GENRE=${metadata/by-key/genre:}
METADATA_DATE=${metadata/by-key/date:}
METADATA_TRACK=${metadata/by-key/track:}
METADATA_COPYRIGHT=${metadata/by-key/copyright:}
INFO_MEDIA_TITLE=${=media-title:}
INFO_STREAM_PATH=${stream-path}
 --audio-client-name=SMPlayer --term-status-msg=STATUS: ${=time-pos} / ${=duration:${=length:0}} P: ${=pause} B: ${=paused-for-cache} I: ${=core-idle} VB: ${=video-bitrate:0} AB: ${=audio-bitrate:0} /run/media/hanuman/Storage/NaturalGrounding/AOA/Miniskirt.mp4

  autoload: Prepending Miniskirt (Eye Contact Practice).mp4 
  autoload: Prepending Like a Cat (Show Champion).mp4 
  autoload: Prepending Like a Cat.mp4 
  autoload: Prepending Like a Cat (Dance Practice).mp4 
  autoload: Prepending I'm Jelly BABY.mkv 
  autoload: Prepending Heart Attack.webm 
  autoload: Prepending Good Luck.mkv 
  autoload: Prepending Get Out.mp4 
  autoload: Prepending Excuse Me.mkv 
  autoload: Prepending Elvis.mp4 
  autoload: Prepending Confused (Show Champion 20131023).mp4 
  autoload: Prepending Confused.mp4 
  autoload: Prepending 흔듀렀 ν˜œμ • 직캠 (140607).mkv 
  autoload: Adding Miniskirt (Music Core 20140118).mp4 
  autoload: Adding Miniskirt (Show Champion 20140212).mp4 
  autoload: Adding MOYA.mp4 
  autoload: Adding MOYA (Show Champion 20130731).mp4 
  autoload: Adding Short Hair (Eye Contact Practice).mp4 
  autoload: Adding Short Hair.mp4 
  autoload: Adding Short Hair (Show Champion).mp4 
  autoload: Adding γ€Œζ„›γ‚’γ‘γ‚‡γ†γ γ„.mkv 
   cplayer:  (+) Video --vid=1 (*) (h264 1920x1080 59.999fps)
   cplayer:  (+) Audio --aid=1 (*) (aac 2ch 44100Hz)
MESA-INTEL: warning: Performance support disabled, consider sysctl dev.i915.perf_stream_paranoid=0
        vd: Using hardware decoding (nvdec-copy).
  ao/pulse: The --audio-stream-silence option is set. This will break certain player behavior.
   cplayer: AO: [pulse] 44100Hz stereo 2ch float
   cplayer: VO: [gpu] 1920x1080 nv12
  term-msg: MPV_VERSION=mpv 0.34.0-165-g712ef65e2a
  term-msg: INFO_VIDEO_WIDTH=1920
  term-msg: INFO_VIDEO_HEIGHT=1080
  term-msg: INFO_VIDEO_ASPECT=1.777778
  term-msg: INFO_VIDEO_FPS=59.998840
  term-msg: INFO_VIDEO_FORMAT=h264
  term-msg: INFO_VIDEO_CODEC=h264 (H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10)
  term-msg: INFO_DEMUX_ROTATION=
  term-msg: INFO_AUDIO_FORMAT=aac
  term-msg: INFO_AUDIO_CODEC=aac (AAC (Advanced Audio Coding))
  term-msg: INFO_AUDIO_RATE=44100
  term-msg: INFO_AUDIO_NCH=2
  term-msg: INFO_LENGTH=221.288000
  term-msg: INFO_DEMUXER=lavf
  term-msg: INFO_SEEKABLE=yes
  term-msg: INFO_TITLES=
  term-msg: INFO_CHAPTERS=0
  term-msg: INFO_TRACKS_COUNT=2
  term-msg: METADATA_TITLE=
  term-msg: METADATA_ARTIST=
  term-msg: METADATA_ALBUM=
  term-msg: METADATA_GENRE=
  term-msg: METADATA_DATE=
  term-msg: METADATA_TRACK=
  term-msg: METADATA_COPYRIGHT=
  term-msg: INFO_MEDIA_TITLE=Miniskirt.mp4
  term-msg: INFO_STREAM_PATH=/run/media/hanuman/Storage/NaturalGrounding/AOA/Miniskirt.mp4
  term-msg: 

Here's the SMPlayer log

My Inxi

maybe corrupt files ...I checked all my videos and they are working fine with SMplayer....but I use mpv and VLC as standard go to . I downloaded your player just to check.

Try smplayer-svn.

1 Like

Stand-alone MPV and VLC work perfectly. Video files are not corrupt; and reinstalling SMPlayer didn't help.

smplayer-svn from AUR doesn't work either. Resetting config files ~/.config/smplayer/ doesn't help either.

I'm assuming this is your post because of the similar inxi No longer plays video after recent update Β· Issue #402 Β· smplayer-dev/smplayer Β· GitHub

If you did indeed try the Flatpak and that works, I am starting to think some dependency packages are corrupted in some way. Maybe try reinstalling all packages with the Garuda Assistant.
If that still doesn't work, you could try comparing packages against the latest ISO for your flavor of Garuda and installing them with this command but it might be risky:

curl https://iso.builds.garudalinux.org/iso/garuda/dr460nized/xxxxxx/garuda-dr460nized-linux-zen-xxxxxx.pkgs.txt | grep -Eo '^[^ ]+' | paru -Syu --needed -

Replace URL with current package list for the flavor of Garuda you have (package lists are found on the Download Garuda page). Be aware you most likely will have to settle some package conflicts for the command to work.

2 Likes

Yes that's my thread.

Re-installing all packages opens up a whole other can of worms, showing this for every package.

error: sdbus-cpp: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/sdbus-cpp-1.1.0-2-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).

Which brings to this thread.

I used this to clear the keyring and start fresh

sudo rm -fr /etc/pacman.d/gnupg
sudo pacman-key --init
sudo pacman-key --populate archlinux chaotic
sudo pacman -Syy archlinux-keyring chaotic-keyring
sudo pacman -Syu

I still get the problem.

sudo pacman-key --refresh-keys --keyserver hkps://keyserver.ubuntu.com

This command loops endlessly.

gpg: error retrieving '[email protected]' via WKD: No data
gpg: error reading key: No data
gpg: refreshing 1 key from hkps://keyserver.ubuntu.com
gpg: key D53A0445B47A0DAB: "Connor Behan <[email protected]>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
gpg: error retrieving '[email protected]' via WKD: No data
gpg: error reading key: No data
gpg: refreshing 1 key from hkps://keyserver.ubuntu.com
gpg: key 40F557B731496106: "Andrzej Giniewicz (giniu) <[email protected]>" 1 signature cleaned
gpg: Total number processed: 1
gpg:     signatures cleaned: 1
gpg: marginals needed: 3  completes needed: 1  trust model: pgp
gpg: depth: 0  valid:   1  signed:  13  trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1  valid:  13  signed:  94  trust: 0-, 0q, 0n, 13m, 0f, 0u
gpg: depth: 2  valid:  88  signed:  32  trust: 88-, 0q, 0n, 0m, 0f, 0u
gpg: next trustdb check due at 2022-05-06
gpg: error retrieving '[email protected]' via WKD: No data
gpg: error reading key: No data
gpg: refreshing 1 key from hkps://keyserver.ubuntu.com
gpg: key 73B8ED52F1D357C1: "Lukas Jirkovsky <[email protected]>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
gpg: error retrieving '[email protected]' via WKD: No data
gpg: error reading key: No data
gpg: error retrieving '[email protected]' via WKD: No data
gpg: error reading key: No data

What does garuda-update give you?

Have you tried:

sudo pacman -S chaotic-keyring
sudo pacman -Syyu
5 Likes

This can also be down to the package in the repo being broken (or not matching the metadata in the database)... @dr460nf1r3 ?

2 Likes

garuda-update works no problem.

sudo pacman -S chaotic-keyring

warning: chaotic-keyring-20220220-1 is up to date -- reinstalling
sudo pacman -Syyu

works but there are these 2 warnings

warning: libcpufeatures-git: local (0.7.0+.r269.d20220308.8a494eb-1) is newer than chaotic-aur (0.7.0+8.r277.d
20220315.188d0d3-1)
warning: lxc-git: local (4.0.0.r2198.g30ebf0964-1) is newer than chaotic-aur (lxc.4.0.0.2205-1)
resolving dependencies...

The package has been rebuilt in case :eyes:

3 Likes

I still get this

:: Synchronizing package databases...
core is up to date
extra                                1717.0 KiB   588 KiB/s 00:03 [------------------------------------] 100%
community                               6.6 MiB  2.44 MiB/s 00:03 [------------------------------------] 100%
multilib is up to date
chaotic-aur                          1642.1 KiB  1330 KiB/s 00:01 [------------------------------------] 100%
:: Starting full system upgrade...
warning: libcpufeatures-git: local (0.7.0+.r269.d20220308.8a494eb-1) is newer than chaotic-aur (0.7.0+8.r277.d20220315.188d0d3-1)
warning: lxc-git: local (4.0.0.r2198.g30ebf0964-1) is newer than chaotic-aur (lxc.4.0.0.2205-1)
resolving dependencies...
looking for conflicting packages...

btw in the past I tried the cachyos kernel which gave tons of warnings, but I reverted the changes. Perhaps something wasn't reverted correctly?

It does look like the SMPlayer problem could be due to mixed-up packages after all.

Huh... r269 is newer than r277? r2198 is newer than 2205?

The two warnings are just telling you that the [ -git ] versions are newer ( as @DragonFire mentioned "The package has been rebuilt " ) than the stock chaotic-aur packages. If you want those errors to go away (IE: You may not need the -git versions and you can use the stock chaotic-aur packages) just install the chaotic-aur packages. Of course you may want to keep those -git versions and in that case you will continue to get those warnings but it should not hurt anything at all. It is just an FYI so to speak. Only you know if you need to keep the -git verions.

For instance when I was using and testing [ btrfs-assitant-git ] I got those warnings as well. Now I have installed the btrfs-assistant [ non-git ] since Btrfs Assistant 1.1 has been released... and no more errors. It is to be expected in those cases. pacman has a high IQ. :wink:

All the luck,
-Cannabis

2 Likes

OK so if those warnings are fine. What could be causing the keyring errors when (only when) reinstalling all packages?

It is simply telling you that you already have the latest chaotic-keyring package installed... and... that it will reinstall it anyway because you told pacman to do so. It will do that with any package that is already installed and the version is the exact same in the repo. Try that with any package and if the same version is on your system that is in the repo you will get the same warning. This is the expected behaviour in that case. If you think you really need to reinstall it, go ahead and hit Y.

same thing here... this is a non-issue

╭─[email protected] in ~/.config/fusuma took 3ms
╰─λ sudo pacman -S chaotic-keyring
[sudo] password for cannabis:
warning: chaotic-keyring-20220220-1 is up to date -- reinstalling

Nothing wrong here.

Enjoy,
-Cannabis

2 Likes

Ahhh, well, your keyring error I was not addressing in my reply.
I was addressing your errors here which are normal:

warning: libcpufeatures-git: local (0.7.0+.r269.d20220308.8a494eb-1) is newer than chaotic-aur (0.7.0+8.r277.d20220315.188d0d3-1)
warning: lxc-git: local (4.0.0.r2198.g30ebf0964-1) is newer than chaotic-aur (lxc.4.0.0.2205-1)

To be thourough, I looked back at your error when you run...

sudo pacman-key --refresh-keys --keyserver hkps://keyserver.ubuntu.com

Is this the error you are concerned about that you posted here: ???

error: sdbus-cpp: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid

NOTE: when you run the `pacman-key --refresh-keys' command as you posted above it is very normal to get many errors and the command takes a while... it will finish. Don't kill it. I just refreshed my keys here and I did not get the sdbus-cpp specific error. Run refresh keys again and let it run. It should finish.

AFAICT the errors like I post here are normal when the key is unchanged. It means it is the same on your local machine and the server and there is no need to update your local key for that user. It looks like it refreshes it anyway. Note the line here at the bottom:

gpg:              unchanged: 1

EXAMPLE HERE:

gpg: error retrieving '[email protected]' via WKD: No data
gpg: error reading key: No data
gpg: refreshing 1 key from hkps://keyserver.ubuntu.com
gpg: key 3056513887B78AEB: "Pedro Henrique Lara Campos <[email protected]>" not changed
gpg: Total number processed: 1
**gpg:              unchanged: 1**

Are you still getting the sdbus-cpp error?

Enjoy
-Cannabis

Last but not least.
What results in the terminal

garuda-update

?

1 Like

How long is this command supposed to take? More than 15 minutes?

garuda-update

--> Refreshing mirrorlists using reflector, please be patient..
[2022-03-31 11:49:04] WARNING: failed to rate http(s) download (https://mirror.telepoint.bg/archlinux/community/os/x86_64/community.db): Download timed out after 5 second(s).
[2022-03-31 11:49:10] WARNING: failed to rate http(s) download (https://archlinux.mailtunnel.eu/community/os/x86_64/community.db): Download timed out after 5 second(s).
################################################################################
################# Arch Linux mirrorlist generated by Reflector #################
################################################################################

# With:       reflector --latest 5 --age 2 --fastest 5 --protocol https --sort rate --save /etc/pacman.d/mirrorlist
# When:       2022-03-31 16:49:13 UTC
# From:       https://archlinux.org/mirrors/status/json/
# Retrieved:  2022-03-31 16:48:48 UTC
# Last Check: 2022-03-31 16:42:20 UTC

Server = https://mirror.theo546.fr/archlinux/$repo/os/$arch
Server = https://phinau.de/arch/$repo/os/$arch
Server = https://archlinux.thaller.ws/$repo/os/$arch
Server = https://mirror.telepoint.bg/archlinux/$repo/os/$arch
Server = https://archlinux.mailtunnel.eu/$repo/os/$arch

:: Synchronizing package databases...
core                                  155.1 KiB   131 KiB/s 00:01 [------------------------------------] 100%
extra                                1715.0 KiB   486 KiB/s 00:04 [------------------------------------] 100%
community                               6.6 MiB  1006 KiB/s 00:07 [------------------------------------] 100%
multilib                              168.9 KiB   123 KiB/s 00:01 [------------------------------------] 100%
chaotic-aur                          1645.1 KiB  1826 KiB/s 00:01 [------------------------------------] 100%
spawn pacman -Su
:: Starting full system upgrade...
warning: libcpufeatures-git: local (0.7.0+.r269.d20220308.8a494eb-1) is newer than chaotic-aur (0.7.0+8.r277.d20220315.188d0d3-1)
warning: lxc-git: local (4.0.0.r2198.g30ebf0964-1) is newer than chaotic-aur (lxc.4.0.0.2207-1)
resolving dependencies...
looking for conflicting packages...

Packages (5) dxvk-mingw-git-1.10.1.r8.g95a34139-1  garuda-dr460nized-1.6.3-1
latte-dock-git-0.10.6.r186.g538dba0a-1  pdftk-3.3.2-2  uresourced-0.5.2-1

Total Download Size:   10.50 MiB
Total Installed Size:  29.68 MiB
Net Upgrade Size:      -0.01 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
uresourced-0.5.2-1-x86_64              36.0 KiB  68.3 KiB/s 00:01 [------------------------------------] 100%
garuda-dr460nized-1.6.3-1-any        1029.9 KiB  1384 KiB/s 00:01 [------------------------------------] 100%
latte-dock-git-0.10.6.r186.g538d...  1449.9 KiB  1586 KiB/s 00:01 [------------------------------------] 100%
dxvk-mingw-git-1.10.1.r8.g95a341...     7.1 MiB  3.95 MiB/s 00:02 [------------------------------------] 100%
pdftk-3.3.2-2-any                     948.3 KiB   404 KiB/s 00:02 [------------------------------------] 100%
Total (5/5)                            10.5 MiB  4.15 MiB/s 00:03 [------------------------------------] 100%
(5/5) checking keys in keyring                                     [------------------------------------] 100%
(5/5) checking package integrity                                   [------------------------------------] 100%
(5/5) loading package files                                        [------------------------------------] 100%
(5/5) checking for file conflicts                                  [------------------------------------] 100%
(5/5) checking available disk space                                [------------------------------------] 100%
:: Running pre-transaction hooks...
(1/1) Performing snapper pre snapshots for the following configurations...
==> root: 546
:: Processing package changes...
(1/5) upgrading dxvk-mingw-git                                     [------------------------------------] 100%
(2/5) upgrading garuda-dr460nized                                  [------------------------------------] 100%
(3/5) upgrading latte-dock-git                                     [------------------------------------] 100%
(4/5) upgrading pdftk                                              [------------------------------------] 100%
(5/5) upgrading uresourced                                         [------------------------------------] 100%
Restart service:

systemctl daemon-reload
systemctl restart uresourced

Restart the user systemd instance; i.e., [email protected] or reboot

:: Running post-transaction hooks...
( 1/10) Reloading system manager configuration...
( 2/10) Arming ConditionNeedsUpdate...
( 3/10) Reloading system bus configuration...
( 4/10) Foreign/AUR package notification
ckb-next-git 1:0.4.4.r170.g36a7a4ea-1
clang+llvm-binaries 11.1.0-1
megasync 4.6.3.0-1
mpv-git 0.34.0_165_g712ef65e2a-1
vapoursynth-editor-git R19.mod.5.beta2.0.gb71e2c8-1
vapoursynth-lib-vsfilterscript-git r119.fc6f2fc-1
vapoursynth-plugin-bm3d-git 9.0.gfe1a433-1
vapoursynth-plugin-bm3dcuda-git 2.6.1.gf9504cd-1
vapoursynth-plugin-fmtconv-git 28.11.g70414b2-1
vapoursynth-plugin-knlmeanscl-git 1.1.1.r571.c4af339-2
vapoursynth-plugin-mvsfunc-git 10.r64.b9218ff-1
vapoursynth-plugin-mvtools-git 23.0.g6d805e2-1
vapoursynth-plugin-mvtools_sf-git 10_pe.7.g38dadba-1
vapoursynth-plugin-neo_f3kdb-git 7.0.ga72cf3d-1
vapoursynth-plugin-neo_tmedian-git 2.0.g9b6a893-1
vapoursynth-plugin-nnedi3_resample-git 20.5ef5bf4-1
vapoursynth-plugin-nnedi3_weights_bin r1-1
vapoursynth-plugin-nnedi3cl-git 8.0.geb2a810-1
vapoursynth-plugin-removegrain-git R1.4.gea3d156-1
vapoursynth-plugin-rgsf-git 5.0.g657d1e7-1
vapoursynth-plugin-vsakarin-git 0.92.8.gde866cb-1
( 5/10) Updating icon theme caches...
( 6/10) Orphaned package notification...
boost 1.78.0-1
breezy 3.2.1-2
celt 0.11.3-4
clang+llvm-binaries 11.1.0-1
cmake 3.22.3-1
electron13 13.6.9-2
elfutils 0.186-5
gtkspell3 3.0.10-2
libcdio-paranoia 10.2+2.0.1-2
libcroco 0.6.13-2
libofa 0.9.3-9
memavaild 0.6-1
meson 0.62.0-1
mujs 1.2.0-2
nasm 2.15.05-1
nm-connection-editor 1.26.0-1
nohang 0.2.0-1
opencv 4.5.5-3
opentimelineio 0.14.1-2
prelockd 0.9-1
python-docutils 1:0.16-2
python-pytest-runner 5.3.2-1
recordmydesktop 0.4.0-2
schedtool 1.3.0-7
spice-protocol 0.14.4-1
uresourced 0.5.2-1
vapoursynth-lib-vsfilterscript-git r119.fc6f2fc-1
zita-alsa-pcmi 0.4.0-1
zita-resampler 1.8.0-1
( 7/10) Checking for .pacnew and .pacsave files...
.pac* files found:
/etc/nsswitch.conf.pacnew
/usr/lib/firedragon/distribution/policies.json.pacnew
/etc/locale.gen.pacnew
/etc/default/grub.pacnew
/etc/default/grub-btrfs/config.pacnew
/etc/pamac.conf.pacnew
/etc/libvirt/libvirtd.conf.pacnew
/etc/pacman.d/mirrorlist.pacnew
/etc/paru.conf.pacnew
Please check and merge
( 8/10) Updating the desktop file MIME type cache...
( 9/10) Performing snapper post snapshots for the following configurations...
==> root: 547
(10/10) Syncing all file systems...

Parsing man pages and writing completions to /home/hanuman/.local/share/fish/generated_completions/
9122 / 9122 : zramctl.8.gz

Checking for plugin updates
Nothing to install / update

System updated! 🐧

Update is fine.
Remove orphans with

cleanup

check if smplayer work.

Todo

 Checking for .pacnew and .pacsave files...
.pac* files found:
/etc/nsswitch.conf.pacnew
/usr/lib/firedragon/distribution/policies.json.pacnew
/etc/locale.gen.pacnew
/etc/default/grub.pacnew
/etc/default/grub-btrfs/config.pacnew
/etc/pamac.conf.pacnew
/etc/libvirt/libvirtd.conf.pacnew
/etc/pacman.d/mirrorlist.pacnew
/etc/paru.conf.pacnew
1 Like

did cleanup

I don't understand your todo quote

SMPlayer now fails with error code 127

/usr/bin/mpv --no-quiet --terminal --no-msg-color --input-ipc-server=/tmp/smplayer-mpv-250dc6 --msg-level=ffmpeg/demuxer=error --video-rotate=no --no-fs --hwdec=no --sub-auto=fuzzy --vo=gpu, --no-input-default-bindings --input-vo-keyboard=no --no-input-cursor --cursor-autohide=no --no-keepaspect --wid=106954769 --monitorpixelaspect=1 --osd-level=2 --osd-scale=1 --osd-bar-align-y=0.6 --sub-ass --embeddedfonts --sub-ass-line-spacing=0 --sub-scale=1 --sub-font=Arial --sub-color=#ffffffff --sub-shadow-color=#ff000000 --sub-border-color=#ff000000 --sub-border-size=0.75 --sub-shadow-offset=2.5 --sub-font-size=50 --sub-bold=no --sub-italic=no --sub-margin-y=8 --sub-margin-x=20 --sub-codepage=ISO-8859-1 --sub-pos=100 --volume=110 --cache=auto --start=239 --screenshot-template=cap_%F_%p_%02n --screenshot-format=jpg --screenshot-directory=/home/hanuman/Pictures/smplayer_screenshots --audio-pitch-correction=yes --volume-max=110 --hr-seek-framedrop=no --profile=gpu-hq --gpu-api=vulkan --hwdec=auto-copy --vulkan-async-compute=yes --vulkan-async-transfer=yes --vulkan-queue-count=1 --autofit=85%x85% --dither=error-diffusion --deband=yes --deband-iterations=2 --deband-threshold=20 --deband-range=16 --scale=ewa_hanning --scale-radius=3.2383154841662362 --cscale=ewa_lanczossoft --dscale=mitchell --scale-antiring=0 --cscale-antiring=0 --correct-downscaling=yes --linear-downscaling=no --sigmoid-upscaling=yes --blend-subtitles=no --hdr-compute-peak=yes --tone-mapping=mobius --glsl-shaders-clr --fbo-format=rgba16f --glsl-shader=~/.config/mpv/shaders/FSRCNN_x2_r2_32-0-2.glsl --term-playing-msg=MPV_VERSION=${=mpv-version:}
INFO_VIDEO_WIDTH=${=width}
INFO_VIDEO_HEIGHT=${=height}
INFO_VIDEO_ASPECT=${=video-params/aspect}
INFO_VIDEO_FPS=${=container-fps:${=fps}}
INFO_VIDEO_FORMAT=${=video-format}
INFO_VIDEO_CODEC=${=video-codec}
INFO_DEMUX_ROTATION=${=track-list/0/demux-rotation}
INFO_AUDIO_FORMAT=${=audio-codec-name}
INFO_AUDIO_CODEC=${=audio-codec}
INFO_AUDIO_RATE=${=audio-params/samplerate}
INFO_AUDIO_NCH=${=audio-params/channel-count}
INFO_LENGTH=${=duration:${=length}}
INFO_DEMUXER=${=current-demuxer:${=demuxer}}
INFO_SEEKABLE=${=seekable}
INFO_TITLES=${=disc-titles}
INFO_CHAPTERS=${=chapters}
INFO_TRACKS_COUNT=${=track-list/count}
METADATA_TITLE=${metadata/by-key/title:}
METADATA_ARTIST=${metadata/by-key/artist:}
METADATA_ALBUM=${metadata/by-key/album:}
METADATA_GENRE=${metadata/by-key/genre:}
METADATA_DATE=${metadata/by-key/date:}
METADATA_TRACK=${metadata/by-key/track:}
METADATA_COPYRIGHT=${metadata/by-key/copyright:}
INFO_MEDIA_TITLE=${=media-title:}
INFO_STREAM_PATH=${stream-path}
 --audio-client-name=SMPlayer --term-status-msg=STATUS: ${=time-pos} / ${=duration:${=length:0}} P: ${=pause} B: ${=paused-for-cache} I: ${=core-idle} VB: ${=video-bitrate:0} AB: ${=audio-bitrate:0} /run/media/hanuman/Storage/NaturalGrounding/AOA/Like a Cat.mp4

/usr/bin/mpv: error while loading shared libraries: /usr/lib/libmujs.so: cannot open shared object file: No such file or directory

Replaced mpv-git with mpv, mujs error is gone, but still no video during playback.

For reinstalling all packages; I still don't think think it's normal that it's giving me an invalid signature prompt for every package.

https://wiki.archlinux.org/title/Pacman/Pacnew_and_Pacsave

On every update you must read the output, it may contain important information, also next to pacnew and pacsafe.

search for libmujs.so
error while loading shared libraries: /usr/lib/libmujs.so: cannot open shared object file: No such file or directory
.