[solved] I get black screen after using my GPU

So let's get into the topic, I get black screen in random time (very random) but i notice i get it whenever my GPU get used for sometime by playing roblox (yes finally you can play it on linux, thanks wine) or by just watching netflix after ~10m my screen goes black and i still can hear the sound of movie but after some seconds my keyboard num light stuck (so that means my whole OS stuck) and yeah i restart again so i want to know why it happens is it problem with my gpu? or is it driver problem or how do i know if its drivers problem


it was my GPU all along

Read

please
and post terminal in- and output from

inxi -Fza

as text!

Even if you personally think it is unnecessary.

2021-07-30_00-19

4 Likes

You'd think Linus could just ask Anthony… :grin:

4 Likes

but i don't think its a bug as its more my own system problem? also yes i did search online some said do dmesg and some said its distro problem but i wanted to tackle it down to see if its drivers problem or well my GPU problem (thanks for the guide btw)

inxi -Fza gave me:

System:    Kernel: 5.13.6-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/vmlinuz-linux-zen root=UUID=fd995316-5f71-477f-8241-237a35bd8605 rw 
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
           systemd.unified_cgroup_hierarchy=1 resume=UUID=5707f6fe-a244-4a47-847f-19b5b8ea19e6 loglevel=3 
           Desktop: GNOME 40.3 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 Distro: Garuda Linux 
           base: Arch Linux 
Machine:   Type: Desktop Mobo: Gigabyte model: B450M GAMING v: x.x serial: <filter> 
           UEFI-[Legacy]: American Megatrends v: F51 date: 07/29/2020 
CPU:       Info: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 family: 17 (23) 
           model-id: 71 (113) stepping: 0 microcode: 8701021 cache: L2: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86237 
           Speed: 3695 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 1: 3695 2: 3591 
           3: 3590 4: 3591 5: 3587 6: 3593 7: 3571 8: 3594 9: 3590 10: 3457 11: 3840 12: 3592 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full AMD retpoline, IBPB: conditional, STIBP: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
           vendor: Hightech Information System driver: amdgpu v: kernel bus-ID: 09:00.0 chip-ID: 1002:67df 
           class-ID: 0300 
           Display: x11 server: X.Org 1.20.13 compositor: gnome-shell driver: loaded: amdgpu,ati 
           unloaded: modesetting alternate: fbdev,vesa display-ID: :1 screens: 1 
           Screen-1: 0 s-res: 1280x1024 s-dpi: 96 s-size: 339x271mm (13.3x10.7") s-diag: 434mm (17.1") 
           Monitor-1: HDMI-A-0 res: 1280x1024 dpi: 127 size: 256x192mm (10.1x7.6") diag: 320mm (12.6") 
           OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.41.0 5.13.6-zen1-1-zen LLVM 12.0.1) 
           v: 4.6 Mesa 21.1.5 direct render: Yes 
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] 
           vendor: Hightech Information System driver: snd_hda_intel v: kernel bus-ID: 09:00.1 
           chip-ID: 1002:aaf0 class-ID: 0403 
           Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel 
           bus-ID: 0b:00.4 chip-ID: 1022:1487 class-ID: 0403 
           Sound Server-1: ALSA v: k5.13.6-zen1-1-zen running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: no 
           Sound Server-4: PipeWire v: 0.3.32 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169 
           v: kernel port: f000 bus-ID: 08:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: enp8s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 2.27 TiB used: 52.28 GiB (2.2%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD5000AAKX-00ERMA0 size: 465.76 GiB 
           block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: N/A serial: <filter> rev: 1H15 
           scheme: GPT 
           ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WD20EZRZ-22Z5HB0 size: 1.82 TiB 
           block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 
           serial: <filter> rev: 0A80 scheme: GPT 
Partition: ID-1: / raw-size: 186.26 GiB size: 186.26 GiB (100.00%) used: 11.72 GiB (6.3%) fs: btrfs 
           dev: /dev/sda3 maj-min: 8:3 
           ID-2: /boot raw-size: 1024 MiB size: 1024 MiB (100.00%) used: 125.8 MiB (12.3%) fs: btrfs 
           dev: /dev/sda1 maj-min: 8:1 
           ID-3: /home raw-size: 1.82 TiB size: 1.82 TiB (100.00%) used: 40.43 GiB (2.2%) fs: btrfs 
           dev: /dev/sdb1 maj-min: 8:17 
           ID-4: /var/log raw-size: 186.26 GiB size: 186.26 GiB (100.00%) used: 11.72 GiB (6.3%) fs: btrfs 
           dev: /dev/sda3 maj-min: 8:3 
           ID-5: /var/tmp raw-size: 186.26 GiB size: 186.26 GiB (100.00%) used: 11.72 GiB (6.3%) fs: btrfs 
           dev: /dev/sda3 maj-min: 8:3 
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) 
           ID-1: swap-1 type: zram size: 15.57 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0 
           ID-2: swap-2 type: partition size: 3.72 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda4 
           maj-min: 8:4 
Sensors:   System Temperatures: cpu: 70.1 C mobo: 16.8 C gpu: amdgpu temp: 50.0 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 677 
Info:      Processes: 385 Uptime: 4m wakeups: 0 Memory: 15.57 GiB used: 2.14 GiB (13.7%) Init: systemd 
           v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1461 lib: 430 
           Shell: Zsh v: 5.8 running-in: gnome-terminal inxi: 3.3.06 

update: i tried the mentioned way in the wiki and i did "arch linux" screen goes black after a while and man i hate when i get hit by a rare problem! but someone got same problem with gnome and xorg (same as my setup) so i think this is the case?

Anthony is supporting the support team (https://invidious.snopyta.org/watch?v=zk97ywS-fGc at 24:15)

1 Like

So, did "someone" find a fix and what was it?

(Personally, I always blame GNOME, that [email protected]#$%^) :wink:

2 Likes

they changed the distro if u know what i mean :wink:

or maybe i need to ditch gnome or make it work with wayland


UPDATE: hmm, i followed instructions to change my distro from gnome to KDE and sadly i still have same problem so i think its not related to gnome

There should be some error messages in journal and Xorg.
Can you get them and post, or do you need help?

PS: No logs == no issue :man_shrugging:

3 Likes

I told myself hey @esmailelbob wait and try again and my suspect was right. it was my GPU all along, the wires itself were dead so yeah it was not garuda's problem nor gnome's fault

3 Likes

image

2 Likes

computer_there'syourproblem

3 Likes

pretty much

1 Like

i saw your post from edited option :stuck_out_tongue: :joy:

and yes i tried (but yeah it was wiring problem)

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.