Several Issues I've had after fresh install XFCE

Hello. Coming to Garuda after hearing excellent things (Manjaro user) from SwitchedToLinux.

I used the installer to install Brave and Chromium browsers, the other ones I’ve installed work but these two will not load.
I’ve tried running them from the terminal and does not load it says

× chromium
[96417:96449:0420/] Failed to call method: org.freedesktop.DBus.Properties.Get: object_path= /org/freedesktop/portal/desktop: org.freedesktop.DBus.Error.InvalidArgs: No such interface “org.freedesktop.portal.FileChooser”
[96417:96449:0420/] Failed to read portal version property

I am not a hacker by any means but I’m interested in learning some of the Black Arch programs and was delighted this system offered to install a slew of these programs. I see Black Arch in the menu but I only see the programs that should be listed in this submenu under the Menu Editor and it appears none of them are actually installed, if I click to not show it from the Menu Editor and then for it to be shown and save it I get a location but the file there is not a program, for example they say:

[Desktop Entry]

Welcome :slight_smile:

What’s the problem with not posting garuda-inxi?
It contains additional, useful information about the status of your system.

:warning: Missing information requested in the template may result in not receiving assistance

Make sure you have done the following before you post:

Issue still unresolved? Then:

  • ONE issue per topic.

  • Describe your issue in detail. The more we know, the better we can help
  • Show us the results of your searches, and what you’ve tried
  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)

  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

Without garuda-inxi this request will be moved to 412 Precondition Failed


Hello and welcome to the forum! :smiley:

You should only install software using the Arch Linux package manager (pacman).

# pacman -S chromium

# pacman -S brave



Can’t respond. I’ll just go back to manjaro. Thanks for the help.

I’ll just go back to manjaro. Thanks for the help.

You’re asking for help here because software that has nothing to do with Garuda doesn’t work, but you’re sure garuda-inxi won’t help us. Well then, as already mentioned in the template and again by me, it now goes to 412 Precondition Failed


sudo pacman -S chromium
Abhängigkeiten werden aufgelöst …
Nach in Konflikt stehenden Paketen wird gesucht …

Paket (1)       Neue Version     Netto-Veränderung  Größe des Downloads

extra/chromium  124.0.6367.60-1         317,31 MiB            98,47 MiB

Gesamtgröße des Downloads:              98,47 MiB
Gesamtgröße der installierten Pakete:  317,31 MiB

:: Installation fortsetzen? [J/n] 
:: Pakete werden empfangen …
 chromium-124.0.6...    98,5 MiB  21,9 MiB/s 00:04 [----------------------] 100%
(1/1) Schlüssel im Schlüsselbund werden geprüft    [----------------------] 100%
(1/1) Paket-Integrität wird überprüft              [----------------------] 100%
(1/1) Paket-Dateien werden geladen                 [----------------------] 100%
(1/1) Auf Dateikonflikte wird geprüft              [----------------------] 100%
(1/1) Verfügbarer Festplattenspeicher wird erm...  [----------------------] 100%
:: Pre-transaction-Hooks werden gestartet …
(1/2) Rejecting pacman transaction if running in snapshot...
(2/2) Performing snapper pre snapshots for the following configurations...
==> root: 73
:: Paketänderungen werden verarbeitet …
(1/1) Installiert wird chromium                    [----------------------] 100%
Optionale Abhängigkeiten für chromium
    pipewire: WebRTC desktop sharing under Wayland [Installiert]
    kdialog: support for native dialogs in Plasma [Installiert]
    qt5-base: enable Qt5 with --enable-features=AllowQt [Installiert]
    gtk4: for --gtk-version=4 (GTK4 IME might work better on Wayland)
    org.freedesktop.secrets: password storage backend on GNOME / Xfce
    kwallet: support for storing passwords in KWallet on Plasma [Installiert]
:: Post-transaction-Hooks werden gestartet …
(1/8) Arming ConditionNeedsUpdate...
(2/8) Foreign/AUR package notification
=> No foreign/AUR packages found.
(3/8) Orphaned package notification...
lib32-libunwind 1.8.1-1
(4/8) Checking for .pacnew and .pacsave files...
(5/8) Updating icon theme caches...
(6/8) Updating the desktop file MIME type cache...
(7/8) Performing snapper post snapshots for the following configurations...
==> root: 74
(8/8) Syncing all file systems...

It’s just a command; you type it into your terminal like this:


It has useful troubleshooting info like hardware specs, etc. At the moment, we don’t even know what desktop environment you installed. It is typically helpful to have some basic information to refer to.

You can edit your first post to add the inxi output in.

I’m not sure I follow what you are saying but check and see if it is this issue:


Really not? Then why can I read that you can’t reply?
I had enabled your opening post for garuda-inxi to edit, but apparently the function doesn’t even exist on your OS.

Again, chromium works.

I guess learning a bit of Linux while you’re gone wouldn’t be out of order. :slight_smile:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.