Setup Xrdp on Garuda Linux KDE Plasma Dr460nized

This is the procedure I have followed to successfully setup Xrdp on Garuda KDE Dr460nized. It has not been easy, so I guess it is a good thing to share it in case it may help other Garuders (maybe even users of other Arch Linux derivatives).

The first problem I ran into was that the aur/xrdp package, once running, reported the following journal error: xrdp_wm_log_msg: error loading specified in xrdp.ini, please add a valid entry like or similar.

So I uninstalled it and, instead, I installed aur/xrdp-bin-git. You can do this easily with the yay command. Before this, however, if you already have tigervnc installed, you probably will have to uninstall it , so the tigervnc-server dependence that comes with aur/xrdp-bin-git may get installed instead.

Installing aur/xrdp-bin-git (and the related tigervnc-server) takes a while, because they are compiled from source.

Once installed, I executed the following commands:

sudo systemctl enable xrdp
sudo systemctl start xrdp

(The second one probably was not necessary, but better safe than sorry).

Afterwards, I edited the file ~/.xinitrc to replace the line exec startplasma-x11 with /usr/lib/plasma-dbus-run-session-if-needed startplasma-x11

Next, I went to System Settings > Startup and Shutdown > Autostart, edited the entry Latte, went to the Application tab and wrote this as the Command field: /usr/bin/latte-dock --replace --layout Dr460nized (The latte dock is very sensitive. Read its help and documentation before you decide to do this, so you understand what you are doing and so you know how to backup its configuration before anything).

Finally, I added a rule to allow the RDP protocol (port 3389) through my firewall (GUFW/UFW).

At this point, I rebooted and I could already connect through RDP (port 3389) to my computer, using a Xvnc session (not Xorg).

Troubleshooting tips:

  1. See if the xrdp daemon/service is running:
systemctl status xrdp
  1. View the live daemon/service messages:
journalctl -fu xrdp

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.