Screen says "Grub" nothing else on boot

Btrfs. Trying to just restore grub. Can chroot into drive from live USB, but cannot reinstall grub to it?

If I do grub-install with the EFI directions if says /boot/efi doesn’t look like an EFI partition.

If I do grub-install /dev/sda it says this GPT partition label contains no BIOS Boot Partition; embedding won’t be possible. btrfs doesn’t support blocklists

gdisk tells me “Found valid GPT with protective MBR; using GPT.” “Main partition table begins at sector 2 & ends at sector 33”

Can’t seem to use Garuda Boot Repair either as it won’t mount anything.

Hi @slfaber, welcome to the community. :slightly_smiling_face:

Please log in to the forum from the live environment and add some information to the thread.

lsblk -f
sudo parted -l
1 Like
╰─λ lsblk -f
NAME FSTYPE FSVER LABEL               UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
squash 4.0                                                                  0   100% /run/miso/sfs/livefs
squash 4.0                                                                  0   100% /run/miso/sfs/mhwdfs
squash 4.0                                                                  0   100% /run/miso/sfs/desktopfs
squash 4.0                                                                  0   100% /run/miso/sfs/rootfs
│    ext4   1.0   Arch                889e6a45-bf3a-461f-8758-f4bc20b54cc9
│    ext4   1.0   Arch Var            91fcb24f-48c1-48ad-bc2f-2c498b1e2319
│    ufs    2                         628fe874a5fc5686
│    ext4   1.0                       76685434-0bd2-4f46-82b5-a979ec10d248
│    ext4   1.0   Arch Home2          091ff22c-7340-4401-9dec-1616cedff2b0
│    ext4   1.0   Deepin Home         7442cd3a-267f-4552-9bb3-9354f80e79d4
│    ext4   1.0   ArcoLinux           76783d7e-d5fb-4963-83eb-33a8747a6267
│    swap   1                         b2352427-106b-43a7-8e4d-474c766b77f9
│    ext4   1.0   Arch Home           8228e866-652d-4ad7-9e32-8e0ba8e16569
│    ext4   1.0                       9f6f1b4e-f738-4e0a-91b1-ed5fce914589
btrfs        Garuda              521e88e8-327a-4022-8b8d-c8fd12b7d2e4    2.6G    90% /mnt/@/boot/efi
sdb  iso966 Jolie GARUDA_DR460NIZED_TALON
2022-04-28-03-48-30-00                     0   100% /run/miso/bootmnt
│    iso966 Jolie GARUDA_DR460NIZED_TALON
│                                     2022-04-28-03-48-30-00
vfat   FAT12 MISO_EFI            BC49-2C48
╰─λ sudo parted -l
Model: ATA WDC WD3200BEKT-6 (scsi)
Disk /dev/sda: 320GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name  Flags
1      1049kB  21.5GB  21.5GB  ext4
2      21.5GB  42.4GB  21.0GB  ext4
3      42.4GB  60.7GB  18.3GB
4      61.3GB  82.2GB  21.0GB  ext4
5      82.3GB  101GB   18.8GB  ext4
6      101GB   139GB   38.3GB  ext4
7      139GB   155GB   15.7GB  ext4
8      155GB   159GB   4194MB  linux-swap(v1)        swap
9      159GB   223GB   64.0GB  ext4
10      223GB   287GB   63.3GB  ext4
11      287GB   320GB   33.5GB  btrfs                 boot, esp

Model:  USB DISK 2.0 (scsi)
Disk /dev/sdb: 8007MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End     Size    Type     File system  Flags
2      2435MB  2439MB  4194kB  primary               esp

Model: Unknown (unknown)
Disk /dev/zram0: 3903MB
Sector size (logical/physical): 4096B/4096B
Partition Table: loop
Disk Flags:

Number  Start  End     Size    File system     Flags
1      0.00B  3903MB  3903MB  linux-swap(v1)

sh-5.2# efibootmgr
EFI variables are not supported on this system.

sh-5.2# garuda-inxi
12Kernel 5.17.4-zen1-1-zen 12arch x86_64 12bits 64 12compiler gcc 12v 11.2.0 12clocksource tsc
12available hpet,acpi_pm 12parameters BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
misobasedir=garuda misolabel=GARUDA_DR460NIZED_TALON quiet systemd.show_status=1
driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=1
12Console N/A 12wm kwin_x11 12Distro Garuda Linux 12base Arch Linux
12Type Laptop 12System Hewlett-Packard 12product HP Pavilion dv4 Notebook PC
12v 0496200000241210100630000 12serial <filter> 12Chassis 12type 10 12serial N/A
12Mobo Hewlett-Packard 12model 140A 12v 50.17 12serial <filter> 12BIOS Insyde 12v F.0B 12date 02/24/2010
12ID-1 BAT0 12charge 0% 12condition 47.5/47.5 Wh (100.0%) 12volts 4.7 12min 10.8
12model Hewlett-Packard Primary 12type Li-ion 12serial N/A 12status N/A
12Info 12model Intel Core i3 M 330 12bits 64 12type MT MCP 12arch Westmere 12gen core 1 12level v2
12built 2010-11 12process Intel 32nm 12family 6 12model-id 0x25 (37) 12stepping 2 12microcode 0x11
12Topology 12cpus 1x 12cores 2 12tpc 2 12threads 4 12smt enabled 12cache 12L1 128 KiB
12desc d-2x32 KiB; i-2x32 KiB 12L2 512 KiB 12desc 2x256 KiB 12L3 3 MiB 12desc 1x3 MiB
12Speed (MHz) 12avg 933 12min/max 933/2133 12base/boost 2133/2133 12scaling 12driver acpi-cpufreq
12governor schedutil 12volts 0.0 V 12ext-clock 1066 MHz 12cores 121 933 122 933 123 933 124 933 12bogomips 17024
12Flags ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
12Vulnerabilities <filter>
12Device-1 Intel Core Processor Integrated Graphics 12vendor Hewlett-Packard 12driver i915 12v kernel
12arch Gen-5.75 12process Intel 45nm 12built 2010 12ports 12active LVDS-1,VGA-1 12empty DP-1,HDMI-A-1
12bus-ID 00:02.0 12chip-ID 8086:0046 12class-ID 0300
12Device-2 Silicon Motion - Taiwan (formerly Feiya ) HP Webcam 12driver uvcvideo 12type USB 12rev 2.0
12speed 480 Mb/s 12lanes 1 12mode 2.0 12bus-ID 2-1.5:4 12chip-ID 090c:137b 12class-ID 0e02 12serial <filter>
12Display 12server 12v 12with Xwayland 12v 23.2.2 12compositor kwin_x11 12driver 12gpu i915
12display-ID :0
12Monitor-1 LVDS-1 12model AU Optronics 0x4444 12built 2006 12res 1280x800 12dpi 107 12gamma 1.2
12size 304x190mm (11.97x7.48") 12diag 358mm (14.1") 12ratio 16:10 12modes 1280x800
12Monitor-2 VGA-1 12model Samsung S24B240 12serial <filter> 12built 2012 12res 1920x1080 12dpi 94 12gamma 1.2
12size 521x293mm (20.51x11.54") 12diag 598mm (23.5") 12ratio 16:9 12modes 12max 1920x1080 12min 720x400
12API EGL 12v 1.5 12hw 12drv intel crocus 12platforms 12device 0 12drv crocus 12device 1 12drv swrast 12gbm
12drv crocus 12surfaceless 12drv crocus 12inactive wayland,x11
12API OpenGL 12v 4.5 12compat-v 2.1 12vendor mesa 12v 23.2.1-arch1.2 12note incomplete (EGL sourced)
12renderer Mesa Intel HD Graphics (ILK), llvmpipe (LLVM 16.0.6 128 bits)
12API Vulkan 12Message No Vulkan data available.
12Device-1 Intel 5 Series/3400 Series High Definition Audio 12vendor Hewlett-Packard 5
12driver snd_hda_intel 12v kernel 12bus-ID 00:1b.0 12chip-ID 8086:3b56 12class-ID 0403
12API ALSA 12v k5.17.4-zen1-1-zen 12status kernel-api 12tools N/A
12Server-1 PipeWire 12v 1.0.0 12status n/a (root, process) 12with 121 pipewire-pulse 12status active
122 wireplumber 12status off 123 pipewire-alsa 12type plugin 124 pw-jack 12type plugin
12tools pactl,pw-cat,pw-cli,wpctl
12Device-1 Broadcom BCM43225 802.11b/g/n 12vendor Hewlett-Packard 12driver bcma-pci-bridge 12v N/A 12pcie
12gen 1 12speed 2.5 GT/s 12lanes 1 12bus-ID 02:00.0 12chip-ID 14e4:4357 12class-ID 0280
12Device-2 Realtek RTL810xE PCI Express Fast Ethernet 12vendor Hewlett-Packard 12driver r8169
12v kernel 12pcie 12gen 1 12speed 2.5 GT/s 12lanes 1 12port 3000 12bus-ID 03:00.0 12chip-ID 10ec:8136
12class-ID 0200
12IF enp3s0f0 12state down 12mac <filter>
12IF-ID-1 wlp2s0b1 12state up 12mac <filter>
12Local Storage 12total 305.55 GiB 12used 28.15 GiB (9.2%)
12ID-1 /dev/sda 12maj-min 8:0 12vendor Western Digital 12model WD3200BEKT-60V5T1 12family Scorpio Black
12size 298.09 GiB 12block-size 12physical 512 B 12logical 512 B 12sata 2.5 12speed 3.0 Gb/s 12tech HDD 12rpm 7200
12serial <filter> 12fw-rev 1A12 12temp 46 C
12SMART yes 12state enabled 12health PASSED 12on 214d 19h 12cycles 4431 12Old-Age 12g-sense error rate 231
12write error rate 100 12threshold 100
12ID-2 /dev/sdb 12maj-min 8:16 12model USB DISK 2.0 12size 7.46 GiB 12block-size 12physical 512 B
12logical 512 B 12type USB 12rev 2.0 12spd 480 Mb/s 12lanes 1 12mode 2.0 12tech N/A 12serial <filter> 12fw-rev PMAP
12SMART Message Unknown USB bridge. Flash drive/Unsupported enclosure?
12ID-1 / 12raw-size 31.17 GiB 12size 31.17 GiB (100.00%) 12used 28.15 GiB (90.3%) 12fs btrfs
12block-size 4096 B 12dev /dev/sda11 12maj-min 8:11
12ID-2 /boot/efi 12raw-size 31.17 GiB 12size 31.17 GiB (100.00%) 12used 28.15 GiB (90.3%) 12fs btrfs
12block-size 4096 B 12dev /dev/sda11 12maj-min 8:11
12Kernel 12swappiness 133 (default 60) 12cache-pressure 100 (default) 12zswap no
12ID-1 swap-1 12type zram 12size 3.63 GiB 12used 424.5 MiB (11.4%) 12priority 100 12comp zstd
12avail lzo,lzo-rle,lz4,lz4hc,842 12max-streams 4 12dev /dev/zram0
12System Temperatures 12cpu 71.0 C 12mobo N/A
12Fan Speeds (rpm) N/A
12Processes 202 12Uptime 54m 12wakeups 0 12Memory 12total 4 GiB 12available 3.64 GiB 12used 2.19 GiB (60.4%)
12igpu 32 MiB 12Init systemd 12v 254 12default graphical 12tool systemctl 12Compilers 12gcc 13.2.1 12Packages
12pm pacman 12pkgs 1485 12libs 402 12tools octopi,paru 12Client 12inxi 3.3.31
Garuda (2.6.19-2):
System install date:     2023-11-27
Last full system update: 2023-12-07
Is partially upgraded:   No
Relevant software:       snapper NetworkManager connman mkinitcpio

You do not have an EFI partition so these mount options are not correct. You should unmount them, then try again following the instructions for reinstalling Grub on a legacy/BIOS installation: How to chroot Garuda Linux

sudo mkdir -p /mnt/broken
sudo mount /dev/sda11 /mnt/broken
sudo garuda-chroot /mnt/broken/@
grub-install /dev/sda
1 Like

Maybe these incorrect flags are causing an issue. Try removing them before the grub installation.

sudo parted /dev/sda11
set 1 esp off
set 1 boot off

Paste the output of print into the thread so we can double-check it looks good. Then quit to exit out of parted, and try the Grub installation again.


That was exactly it. I had to turn off my boot flag & just have my bios flag on using KDEDiskManager.

Thank you so much.

[What I deleted above, so people who have the same problem can understand the post]

I’ve tried that before, but tried it exactly as you typed it just in case:
warning: Discarding improperly nested partitionhostdisk//dev/sda,gpt3,bsd.
warning: this GPT partition label contains no BIOS Boot Partition; embedding won’t be possible
error: filesystem ‘btrfs’ doesn’t support blocklists. I believe the warnings are from my FreeBSD partition, so not relevant.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.