Screen black

After last big update 04.05.23
Get black screen
Rollback to last good snap

  Kernel: 6.2.13-zen-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=4d80aa2f-c64e-472e-99b7-435bba92b795 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=c7eb26e0-2169-433a-a786-a4cd4934d503 loglevel=3 ibt=off
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: Z170-A v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 3802
    date: 03/15/2018
  Info: model: Intel Core i5-6500 bits: 64 type: MCP arch: Skylake-S
    gen: core 6 level: v3 note: check built: 2015 process: Intel 14nm family: 6
    model-id: 0x5E (94) stepping: 3 microcode: 0xF0
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 3300 high: 3600 min/max: 800/3600 scaling:
    driver: intel_pstate governor: performance cores: 1: 3200 2: 3200 3: 3600
    4: 3200 bogomips: 25599
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel HD Graphics 530 vendor: ASUSTeK driver: i915 v: kernel
    arch: Gen-9 process: Intel 14n built: 2015-16 ports: active: none
    empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2, HDMI-A-3 bus-ID: 00:02.0
    chip-ID: 8086:1912 class-ID: 0380
  Device-2: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: Gigabyte driver: amdgpu v: kernel arch: GCN-4 code: Arctic Islands
    process: GF 14nm built: 2016-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    ports: active: DP-6 empty: DP-3, DP-4, DP-5, DP-7, DVI-D-1, HDMI-A-4
    bus-ID: 01:00.0 chip-ID: 1002:67df class-ID: 0300 temp: 48.0 C
  Display: x11 server: X.Org v: 21.1.8 compositor: xfwm v: 4.18.0 driver: X:
    loaded: amdgpu,modesetting alternate: fbdev,intel,vesa dri: radeonsi,iris
    gpu: amdgpu display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x317mm (20.00x12.48")
    s-diag: 599mm (23.57")
  Monitor-1: DP-6 mapped: DisplayPort-5 model: Dell U2415 serial: <filter>
    built: 2014 res: 1920x1200 hz: 60 dpi: 94 gamma: 1.2
    size: 518x324mm (20.39x12.76") diag: 611mm (24.1") ratio: 16:10 modes:
    max: 1920x1200 min: 720x400
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel alternate: snd_soc_avs bus-ID: 00:1f.3
    chip-ID: 8086:a170 class-ID: 0403
  Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: Gigabyte driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s
    lanes: 16 bus-ID: 01:00.1 chip-ID: 1002:aaf0 class-ID: 0403
  API: ALSA v: k6.2.13-zen-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-5:2 chip-ID: 0bda:2550 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
  Local Storage: total: 3.71 TiB used: 607.99 GiB (16.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO Plus 500GB size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXM7 temp: 50.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD1003FZEX-00K3CA0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
    rev: 1A01 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 870 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1B6Q scheme: GPT
  ID-4: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WD20EFRX-68EUZN0 size: 1.82 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
    rev: 0A82 scheme: GPT
  ID-5: /dev/sdd maj-min: 8:48 vendor: Hitachi model: HDS728080PLA380
    size: 76.69 GiB block-size: physical: 512 B logical: 512 B speed: 1.5 Gb/s
    type: N/A serial: <filter> rev: A6EA scheme: MBR
  ID-1: / raw-size: 448.42 GiB size: 448.42 GiB (100.00%)
    used: 33.19 GiB (7.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 5.5 MiB (1.8%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 448.42 GiB size: 448.42 GiB (100.00%)
    used: 33.19 GiB (7.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 448.42 GiB size: 448.42 GiB (100.00%)
    used: 33.19 GiB (7.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 448.42 GiB size: 448.42 GiB (100.00%)
    used: 33.19 GiB (7.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.49 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 17.05 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  System Temperatures: cpu: 34.0 C mobo: N/A gpu: amdgpu temp: 48.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 709
  Processes: 259 Uptime: 11m wakeups: 0 Memory: 15.49 GiB
  used: 2.29 GiB (14.8%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1508
  libs: 380 tools: cylon,pamac,paru,yay Shell: fish v: 3.6.1 default: Bash
  v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.26
Garuda (2.6.16-1):
  System install date:     2023-04-30
  Last full system update: 2023-05-03
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:

Please, use last working snapshot.

Please, no blockquote
Kernel: 5.18.15-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1

looks like

  Kernel: 5.18.15-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1

I had the same problem and had to chroot to fix the problem, they are rebuilding lots of packages to suit the new python update.
I would wait a day or so before you update again and see what happens then


thanks for trying to help.
I tried to look for solutions on the Internet, some people think that the problem is Python dependencies due to the new version,
tried to resolve them after update yay -S --rebuild --noconfirm $(yay -Qqo /usr/lib/python3.10/)
reinstalled amd drivers.
restarted - display manager
none of this helped
the system was updated every day.
all attempts are unsuccessful.
Every time a black screen ctrl alt f1 or f2 does not give any reaction.

looks like i have no choice
if what you did in the chroot helped you, I would be happy with the full instructions

If you have restored the snapshot try again update in terminal.



via Garuda Welcome app or via How to chroot Garuda Linux
Then garuda-update in terminal.


I tried to update the system from under the chroot live usb Garuda, nothing howled, the same black screen when loading a normal system.
The system is the same as in the example on nvme and the partition with BTRFS is also on nvme0n1p2
For some reason, the Garuda chroot application failed to update the system.

What could be the reason and what else is worth trying in your opinion?
*Returned to the last working snapshot


No pictures from terminal.

:pray: :pray: :pray:


sory if you prefer i delete it

You cannot delete anything in this forum. It is saved as history.
The forum search cannot search it and makes unnecessary work for helpers when they have to enter error messages by hand into their search engines.


took note
What about the black screen, any ideas
I don't understand where the problem is
I think maybe from under chroot, after the update, reinstall lightdm and rebuild python applications?
Am I the only one with this problem?


Did you try other kernel?
Zen is not default in Xfce.


will wait about week and try update.
Not think that the problem in zen kernel if just me get the case.
Maximum reinstall garuda.
If you will see the same case and how repair it I will be glad if you let me know

I'm trying, but my memory is not the best anymore :smiley:
So to be sure, you should observe your problem yourself.

1 Like

I see you have in your pacman conf two additional repos: archlinuxcn and blackarch.
This makes things a bit more complicated to troubleshoot, because we don't know and are not responsabile for what's there.
But if you hold on the updates for a while, chances are everything will be fixed.
By-the-way, I see you always use sudo pacman -Syu but garuda-update is our suggested script for updating.


Comment has been deleted

Thanks for the answer
I’ll definitely remove it and then I’ll try to rebuild Python packages in chroot
In fact, at the very beginning of the way to use Garuda, I already use it out of habit yay -Syuu garuda-update && update
Pacman - Syu i used in chroot becouse of yay not work there and think use updates as usual in arch

I can confirm I had this very similar issue on my trail of breadcrumbs to an optimistic glance of 'lower mouse latency' enlightenment through a fresh install of Xfce upon observation after initial upgrade.

In the end I installed KDE and there was no issues with updating. I have not enough knowledge to fix it so I ran away back to the Dragons lair. :dragon_face: