Samsung 4k smart TV wont refresh at 1440p_120hz using nvidia DKMS driver

Originally posted in Display problems - #6 by petsam

Creating a new post per mod instruction.

I will start by stating I am a long time OpenSuse user and am fairly unfamiliar with Arch and attempting to use Garuda as a gaming OS.
Things are working generally well, but an issue I am having is that my Samsung RU8000 65" tv connected via HDMI to my gtx 1070ti is only detected as supporting 1440p_60 instead of 1440p_120, 1440p at 120hz works great on Windows with this tv.
I also have a Valve Index VR kit and the HMD has no issues refreshing at 120hz.

Any help is appreciated, thanks in advance.

Output of

inxi -Faz
System:    Kernel: 5.14.9-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=92151bbd-378b-488c-9abf-917e49325c26  
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Console: tty pts/0 wm: kwin_x11 DM: SDDM Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Desktop System: ASUS product: N/A v: N/A serial: N/A  
Mobo: ASUSTeK model: TUF GAMING X570-PRO (WI-FI) v: Rev X.0x serial: <filter>  
UEFI: American Megatrends v: 4002 date: 06/15/2021  
CPU:       Info: 8-Core model: AMD Ryzen 7 5800X socket: AM4 bits: 64 type: MT MCP arch: Zen 3  
family: 19 (25) model-id: 21 (33) stepping: 0 microcode: A201016 cache: L1: 512 KiB L2: 4 MiB  
L3: 32 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 121604  
Speed: 3599 MHz min/max: 2200/3800 MHz base/boost: 3800/4850 boost: enabled volts: 1.1 V  
ext-clock: 100 MHz Core speeds (MHz): 1: 3599 2: 3658 3: 3617 4: 3599 5: 3593 6: 3767 7: 3618  
8: 3600 9: 3595 10: 3599 11: 3600 12: 3652 13: 3599 14: 3596 15: 3598 16: 3753  
Vulnerabilities: Type: itlb_multihit status: Not affected  
Type: l1tf status: Not affected  
Type: mds status: Not affected  
Type: meltdown status: Not affected  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2  
mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: always-on, RSB filling  
Type: srbds status: Not affected  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: NVIDIA GP104 [GeForce GTX 1070 Ti] vendor: Micro-Star MSI driver: nvidia v: 470.74  
alternate: nouveau,nvidia_drm bus-ID: 09:00.0 chip-ID: 10de:1b82 class-ID: 0300  
Display: server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: nvidia  
unloaded: modesetting alternate: fbdev,nouveau,nv,vesa display-ID: :0 screens: 1  
Screen-1: 0 s-res: 2560x1440 s-dpi: 68 s-size: 956x538mm (37.6x21.2") s-diag: 1097mm (43.2")  
Monitor-1: HDMI-0 res: 2560x1440 hz: 60 dpi: 35 size: 1872x1053mm (73.7x41.5")  
diag: 2148mm (84.6")  
OpenGL: renderer: NVIDIA GeForce GTX 1070 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 470.74  
direct render: Yes  
Audio:     Device-1: NVIDIA GP104 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel  
v: kernel bus-ID: 09:00.1 chip-ID: 10de:10f0 class-ID: 0403  
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel  
bus-ID: 0b:00.4 chip-ID: 1022:1487 class-ID: 0403  
Sound Server-1: ALSA v: k5.14.9-zen2-1-zen running: yes  
Sound Server-2: JACK v: 1.9.19 running: no  
Sound Server-3: PulseAudio v: 15.0 running: no  
Sound Server-4: PipeWire v: 0.3.38 running: yes  
Network:   Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 04:00.0 chip-ID: 8086:2723  
class-ID: 0280  
IF: wlp4s0 state: down mac: <filter>  
Device-2: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel port: N/A bus-ID: 05:00.0  
chip-ID: 8086:15f3 class-ID: 0200  
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>  
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-4:2 chip-ID: 8087:0029  
class-ID: e001  
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>  
Drives:    Local Storage: total: 1.68 TiB used: 273.81 GiB (15.9%)  
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Silicon Power model: SPCC M.2 PCIe SSD  
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD  
serial: <filter> rev: S0614B0 temp: 41.9 C scheme: MBR  
SMART: yes health: PASSED on: 352d 0h cycles: 591 read-units: 8,647,549 [4.42 TB]  
written-units: 4,818,379 [2.46 TB]  
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST3500630AS family: Barracuda 7200.10  
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s type: N/A  
serial: <filter> rev: D temp: 44 C scheme: GPT  
SMART: yes state: enabled health: PASSED on: 4y 323d 15h cycles: 6854 Pre-Fail:  
attribute: Spin_Retry_Count value: 100 worst: 100 threshold: 97  
ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WD6000HLHX-01JJPV0  
family: VelociRaptor size: 558.91 GiB block-size: physical: 512 B logical: 512 B sata: 2.6
speed: 6.0 Gb/s type: HDD rpm: 10000 serial: <filter> rev: 5G04 temp: 36 C scheme: MBR
SMART: yes state: enabled health: PASSED on: 5y 307d 8h cycles: 4715
ID-4: /dev/sdc maj-min: 8:32 vendor: Intel model: SSDSC2BP240G4
family: 730 and DC S35x0/3610/3700 Series SSDs size: 223.57 GiB block-size: physical: 512 B
logical: 512 B sata: 2.6 speed: 6.0 Gb/s type: SSD serial: <filter> rev: 0410 scheme: GPT
SMART: yes state: enabled health: PASSED on: 4y 355d 1h cycles: 3880 read: 38.3 TiB
written: 33.31 TiB
Partition: ID-1: / raw-size: 465.5 GiB size: 465.5 GiB (100.00%) used: 273.81 GiB (58.8%) fs: btrfs
block-size: 4096 B dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%) used: 563 KiB (0.2%) fs: vfat
block-size: 512 B dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 465.5 GiB size: 465.5 GiB (100.00%) used: 273.81 GiB (58.8%) fs: btrfs
block-size: 4096 B dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 465.5 GiB size: 465.5 GiB (100.00%) used: 273.81 GiB (58.8%) fs: btrfs
block-size: 4096 B dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 465.5 GiB size: 465.5 GiB (100.00%) used: 273.81 GiB (58.8%) fs: btrfs
block-size: 4096 B dev: /dev/sda2 maj-min: 8:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.26 GiB used: 256 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 40.2 C mobo: N/A gpu: nvidia temp: 57 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:      Processes: 351 Uptime: 33m wakeups: 0 Memory: 31.26 GiB used: 3.84 GiB (12.3%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1678 lib: 498
Shell: fish (sudo) v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

Please, use ~~~ before and after terminal output.

I set this up over a year ago on my Sony TV and it was quite the learning curve.

Firstly you must use an HDMI cable of at least 4K capability (preferably 8K just to be sure it's of sufficient display quality).

The other issue is, displaying 4K @ 120hz from your computer in Linux often requires enabling special settings in your TV. Often this does not come pre-configured from the factory to allow a 4K display @ 120hz on computers by default with Linux.

It took me a ton of searching to figure out which settings needed to be changed on my Sony 4K TV to enable 4K display over HDMI from my computer. I have no idea which settings a Samsung would require as most manufacturers use different terms and they are far from intuitive. There's no point in asking me about what your TV might require, as I do not remember the settings and I'm not currently using that TV.

The other issue I experienced (once I had the cabling and TV configured correctly) was that I could enable 1440p at 120hz, but it would not stick. Once I rebooted I had to reset the display back to 120hz from 60 every time after a reboot. No matter what I tried I could not get 120hz to stick. The only way I could get the 120hz display setting to permanently stick was to reinstall Garuda with everything set up 100% correctly during the install process.

It was a long and painful process to get things working properly as Linux doesn't seem to have implemented full support for this as yet. I also gather TV manufacturers don't seem to want this enabled at purchase as it may lessen the life of the screen.

Good luck to you.

2 Likes

Actually just trying to use [email protected], not 2160p_120, I dont think my TV even supports that.
Tried adding the rate via xrandr, got the following:

╰─λ xrandr -r 120
Rate 120.00 Hz not available for this size

For some reason this gave me an idea, I went into my TV settings, went into
-General
-External Device Manager
-Input Sinal Plus
I turned on input signal plus for HDMI4 which my pc is connected to and the issue is solved!

ps:
Wow the desktop looks amazing in 120fps.. lol

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.