Rtw88-dkms error

Hello, I started that topic:

System:
  Kernel: 5.17.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=417f187a-a42b-44a5-b6b3-c27517119ed0 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=8f7c97f0-2758-4001-95b0-57f15fb14228 loglevel=3
  Desktop: GNOME v: 42.1 tk: GTK v: 3.24.33 wm: gnome-shell dm: GDM v: 42.0
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: HUAWEI product: KLVL-WXX9 v: M1300
    serial: <superuser required>
  Mobo: HUAWEI model: KLVL-WXX9-PCB v: M1300 serial: <superuser required>
    UEFI: HUAWEI v: 1.06 date: 09/14/2020
Battery:
  ID-1: BAT0 charge: 50.0 Wh (99.6%) condition: 50.2/54.9 Wh (91.4%)
    volts: 8.4 min: 7.6 model: SUNWODA HB4593R1ECW-22S0 type: Li-ion
    serial: <filter> status: discharging cycles: 172
CPU:
  Info: model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 2 family: 0x17 (23) model-id: 0x60 (96) stepping: 1
    microcode: 0x8600104
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 8 MiB desc: 2x4 MiB
  Speed (MHz): avg: 1395 high: 1397 min/max: 1400/3000 boost: enabled
    scaling: driver: acpi-cpufreq governor: powersave cores: 1: 1397 2: 1397
    3: 1396 4: 1396 5: 1397 6: 1392 7: 1397 8: 1397 9: 1397 10: 1386 11: 1397
    12: 1395 bogomips: 71862
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Renoir driver: amdgpu v: kernel pcie: gen: 4 speed: 16 GT/s
    lanes: 16 ports: active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 04:00.0
    chip-ID: 1002:1636 class-ID: 0300
  Device-2: IMC Networks HD Camera type: USB driver: uvcvideo bus-ID: 3-4:3
    chip-ID: 13d3:5451 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
    compositor: gnome-shell driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2160x1440 s-dpi: 96 s-size: 571x381mm (22.48x15.00")
    s-diag: 686mm (27.03")
  Monitor-1: eDP-1 mapped: eDP model: BOE Display 0x0893 built: 2019
    res: 2160x1440 hz: 60 dpi: 185 gamma: 1.2 size: 296x197mm (11.65x7.76")
    diag: 356mm (14") ratio: 3:2 modes: max: 2160x1440 min: 640x480
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 04:00.1
    chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x,
    snd_sof_amd_renoir
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 04:00.5 chip-ID: 1022:15e2
    class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 04:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Sound Server-1: ALSA v: k5.17.5-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
    vendor: & Tele RSH driver: rtw_8822ce v: kernel modules: rtw88_8822ce pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 01:00.0
    chip-ID: 10ec:c822 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
Bluetooth:
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 3-3:2 chip-ID: 1358:c123 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 24 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 63.48 GiB (13.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: PC SN530 SDBPNPZ-512G-1027 size: 476.94 GiB block-size:
    physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
    serial: <filter> rev: 21117000 temp: 39.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
    used: 63.48 GiB (13.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
    used: 63.48 GiB (13.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
    used: 63.48 GiB (13.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
    used: 63.48 GiB (13.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 1.1 MiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: swap-2 type: zram size: 7.2 GiB used: 3.09 GiB (42.9%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 36.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 359 Uptime: 7d 59m wakeups: 27 Memory: 7.2 GiB
  used: 4.13 GiB (57.3%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 12.1.0 Packages: 1332 pacman: 1327 lib: 356 flatpak: 5 Shell: fish
  v: 3.4.1 default: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.15
Garuda (2.6.3-2):
  System install date:     2022-04-09
  Last full system update: 2022-05-15 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:            mnt-Seagate.mount mnt-Toshiba.mount 

now wifi is working but I see that errors during updates:

Error! The module/version combo: rtw88-r130.f7e18c5 is not located in the DKMS tree.
Błąd podczas konfiguracji rtw88-dkms-git
Błąd: rtw88-dkms-git: komenda nie wykonała się poprawnie
Konfigurowanie rtw88-dkms-git...
Creating symlink /var/lib/dkms/rtw88/r131.ce97958/source -> /usr/src/rtw88-r131.ce97958
Error! Your kernel headers for kernel 5.17.5-zen1-1-zen cannot be found at /usr/lib/modules/5.17.5-zen1-1-zen/build or /usr/lib/modules/5.17.5-zen1-1-zen/source.
Błąd podczas konfiguracji rtw88-dkms-git
Please install the linux-headers-5.17.5-zen1-1-zen package or use the --kernelsourcedir option to tell DKMS where it's located.
Error! Your kernel headers for kernel 5.17.5-zen1-1-zen cannot be found at /usr/lib/modules/5.17.5-zen1-1-zen/build or /usr/lib/modules/5.17.5-zen1-1-zen/source.
Błąd podczas konfiguracji rtw88-dkms-git
Please install the linux-headers-5.17.5-zen1-1-zen package or use the --kernelsourcedir option to tell DKMS where it's located.

Regards

You have probably just updated, but haven't rebooted:

Because kernel version should be 5.17.7
Maybe try rebooting and update again (never update again after kernel update without rebooting).

3 Likes

Hi, that errors shows during upgrading. I reboot laptop after it finish.
OK, I reebot second time and it looks OK.
I have kernel 5.17.7-zen1-1-zen
Regards.

2 Likes

hi , i have the same wifi card as you. i think the problem exists with the linux-zen kernel. i also faced the same issue of connections dropping. which resulted in me trying the rtw-88 dkms package from the aur. this resulted in random wifi speed drops especially after hibernation so i had a janky workaround where i would unload and load the kernel module again via a systemd service after hibernation so that the speed of my wifi would not be affected . I have managed to fix this problem and the random speed drop with the linux-xanmod-edge kernel (i removed the rtw-88 dmks package & my workaround systemd service). so give it a try if the current solution stops working for you.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.