RTL88x2BU Unstable WiFi Connection

I've been having problems with my WiFi suddenly dropping to 0bps. It happens when I reach my 7mbps internet speeds. My WiFi icon turns orange and says "limited internet." It refuses to continue working until I reconnect to my WiFi.

I've already looked through many websites and forums and tried disabling power saving mode, disabling mac address randomization, disabling Bluetooth, plugging in my WiFi module into different ports, reinstalling drivers but the problem persists. I even checked my signal (which is around 96%-98%) which I thought might be the problem but I found none.

Here's my system:
System:
Kernel: 5.16.16-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=2c3c6e84-3990-4512-8eb0-99c1da081f7c rw [email protected]
quiet splash amdgpu.ppfeaturemask=0xffffffff rd.udev.log_priority=3
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma v: 5.24.3 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: B350M PRO-VDH (MS-7A38) v: 2.0
serial: <superuser required> UEFI: American Megatrends v: A.JS
date: 11/02/2021
CPU:
Info: model: AMD Ryzen 3 2200G with Radeon Vega Graphics bits: 64 type: MCP
arch: Zen family: 0x17 (23) model-id: 0x11 (17) stepping: 0
microcode: 0x8101016
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 384 KiB
desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
desc: 1x4 MiB
Speed (MHz): avg: 3777 high: 3900 min/max: N/A cores: 1: 3900 2: 3899
3: 3900 4: 3410 bogomips: 31201
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Retpolines, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: XFX Pine driver: amdgpu v: kernel pcie: gen: 3 speed: 8 GT/s
lanes: 8 link-max: lanes: 16 ports: active: DP-1
empty: DP-2, DP-3, DVI-D-1, HDMI-A-1 bus-ID: 10:00.0 chip-ID: 1002:67df
class-ID: 0300
Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa gpu: amdgpu
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1280x800 s-dpi: 96 s-size: 338x211mm (13.31x8.31")
s-diag: 398mm (15.69")
Monitor-1: DP-1 mapped: DisplayPort-0 model: E15T4W serial: <filter>
built: 2007 res: 1280x800 hz: 60 dpi: 98 gamma: 1.37
size: 332x207mm (13.07x8.15") diag: 386mm (15.2") ratio: 16:10 modes:
max: 1280x800 min: 720x400
OpenGL: renderer: AMD Radeon RX 590 Series (POLARIS10 DRM 3.44.0
5.16.16-zen1-1-zen LLVM 13.0.1)
v: 4.6 Mesa 21.3.7 direct render: Yes
Audio:
Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
vendor: XFX Pine driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s
lanes: 8 link-max: lanes: 16 bus-ID: 10:00.1 chip-ID: 1002:aaf0
class-ID: 0403
Device-2: AMD Family 17h/19h HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 29:00.6 chip-ID: 1022:15e3 class-ID: 0403
Device-3: C-Media USB Audio Device type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-4:2 chip-ID: 0d8c:0012
class-ID: 0300
Sound Server-1: ALSA v: k5.16.16-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: e000 bus-ID: 25:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp37s0 state: down mac: <filter>
IF-ID-1: wlp41s0f4u1i2 state: up mac: <filter>
Bluetooth:
Device-1: Realtek 802.11ac NIC type: USB driver: btusb,rtl88x2bu
bus-ID: 5-1:2 chip-ID: 0bda:b82c class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 2.04 TiB used: 678.27 GiB (32.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD20EZRZ-00Z5HB0 size: 1.82 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 0A80 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SA400S37120G
size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 61K1 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
model: WD1200JS-00NCB1 size: 111.79 GiB block-size: physical: 512 B
logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: 2E02
scheme: MBR
Partition:
ID-1: / raw-size: 111.53 GiB size: 111.53 GiB (100.00%)
used: 77.29 GiB (69.3%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%)
used: 562 KiB (0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 111.53 GiB size: 111.53 GiB (100.00%)
used: 77.29 GiB (69.3%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-4: /var/log raw-size: 111.53 GiB size: 111.53 GiB (100.00%)
used: 77.29 GiB (69.3%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-5: /var/tmp raw-size: 111.53 GiB size: 111.53 GiB (100.00%)
used: 77.29 GiB (69.3%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 23.48 GiB used: 7.39 GiB (31.5%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 39.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 1865
Info:
Processes: 357 Uptime: 1d 23h 20m wakeups: 0 Memory: 23.48 GiB
used: 11.85 GiB (50.5%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1732 lib: 421 Shell: fish
v: 3.3.1 running-in: konsole inxi: 3.3.14
Garuda (2.5.6-2):
System install date:     2022-03-28
Last full system update: 2022-03-28
Is partially upgraded:   Yes
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Timeshift (maybe)
Failed units:

Is the AP dropping your adapter?

I've already checked various settings. It doesn't happen to my other devices. When the signal turns to "limited internet" it cannot access anything until I disconnect and reconnect in some way.

1 Like

Next easy thing to try would be some different kernels; linux-lts for 5.15 and update so you get 5.17 rather than 5.16 (assuming you haven't already done that).

1 Like

Have you looked under the 'known Issues' and solutions here and here?

I've updated linux-zen kernel to the latest (5.17). I've also installed and ran linux-lts for kernel 5.15 but both of them end up the same. Still no luck.

I've tried those solutions as well and I thought it was working for a while. It ended up failing once again under my max download and upload speeds by loading websites and watching a few videos.

Did you install a driver package for this (e.g. rtl8822bu-dkms or rtl88x2bu-dkms-git)?

I followed the solution to this forum.

I couldn't get the WiFi module to work and that solution worked out of the box. So I am using the dkms-git version.

Have you rebuilt the package recently? -git packages don't update themselves, you have to regularly rebuild to pick up any new commits (Chaotic-AUR will do periodic rebuilds).

1 Like

Yes, I have reinstalled it since yesterday and the day before trying to troubleshoot.

Reinstalling isn't the same as rebuilding.

What's the version number of the package you have installed?

1 Like

The version number is 5.13.1.r158.a543f24-1

1 Like

OK, that matches the latest commit.

I don't immediately see any reported issues that look related on the issue tracker, so I guess the next question is did this work correctly at any point, and what has changed since then?

Since I first set it up it has never worked correctly. I wasn't aware at the time that Garuda Linux had forums either. I found a post here but it wasn't for my drivers. I am not sure what is causing this.

1 Like

It's possible that your specific device doesn't like Linux, but there's also some information on the AUR package page about getting more log output:

(There's also a Garuda pastebin linked at the very top of the page)

1 Like

Try disabling IPv6.

Add the following kernel boot parameter to grub:

ipv6.disable=1

The following command will automatically add the above kernel boot parameter to /etc/default/grub:

sudo cp /etc/default/grub /etc/default/grub.bak && sudo sed '/^GRUB_CMDLINE_LINUX_DEFAULT=/s/"$/ ipv6.disable=1"/g' -i /etc/default/grub

After adding the boot parameter, run:

sudo update-grub 

Then reboot


Have you tried the adapter on different USB ports, USB2 vs USB3?



Have you rebooted your router?



Try locking your Wifi connection to your AP's SSID in network manager.

You can do this in Network Manager's "Wi-Fi" tab in your WiFi connection's properties settings.

There is a "BSSID" drop down field where you can select and lock your home Wi-Fi to a single BSSID.

After modifying Network Manager's configuration, reboot both your router and your computer.


Select a fixed wifi channel in your router settings.


Select a single band in your router settings, 2.4 or 5MHz not both.

Test your wifi on the 2.4 MHz band, and be sure you have separate BSSID's for the 2.4 and 5 MHz bands set in your router.


Test your connection with wifi encryption temporarily disabled. This is only a troubleshooting step. Never leave your wifi security disabled for an extended period of time.


Edit:


Enable Network Manager's debugging mode with the following command:

echo -e "[logging]\nlevel=DEBUG" | sudo tee /etc/NetworkManager/conf.d/00-defaults.conf

This will give you a far more in depth logging.

Open a Network Manager live log session.

The command below will output a live log detailing your network's current activities. Open a live Network Manager debugging log session via this command:

journalctl -fu NetworkManager 

Let the command run in the terminal, logging all current network activities.

Connect to your network and perform some large downloads to generate some useful log information.

Log at least 25-50 lines of output around times when your connection was dropped.

Copy the output from the terminal and post any important looking excerpts from the log (especially around failure events).

In another terminal tab/window you can also run:

journalctl -f _COMM=wpa_supplicant

You may want to test iwd in place of wpa_supplicant.


Try changing the channel bandwidth to 20MHz in your router.


Do you have a spare router, (or can you borrow one) to swap in temporarily? Please don't tell me it works fine with Windows.


Run the following command:

sudo systemctl stop NetworkManager; sudo modprobe -r 88x2bu; sleep 3; sudo modprobe 88x2bu rtw_power_mgnt=0 rtw_ips_mode=0 rtw_enusbss=0; sleep 3; sudo systemctl start NetworkManager

If your connectivity is improved using the above command, then make these driver options permanent with:

echo "options 88x2bu rtw_power_mgnt=0 rtw_ips_mode=0 rtw_enusbss=0" | sudo tee /etc/modprobe.d/88x2bu.conf

Reboot.


2 Likes

Hey there @OSS.

I've noticed you on the forum several times since my last post that contained numerous questions/suggestions for you.

If you have resolved your wifi issue please close out your thread properly by indicating how you managed to solve your issue. This helps others having similar issues to locate a solution more easily.

If your issue is not resolved, have you tested out some of the solutions put forward? Please indicate which suggestions you've tested so far (and the result). Also be sure to answer any questions put to you.

Life in general (and our forum) is a two way street. Please always acknowledge others efforts to assist you, and always respond to helpers queries. This is simply common courtesy, and is the expected behavior if you've come soliciting help on our forum.

Please don't leave your threads dangling, always ensure any help request you open is closed out properly. Your cooperation in this matter would be greatly appreciated.

3 Likes

Hi, I've tried most of your solutions. Unfortunately most of them didn't work (I haven't tested any of the commands yet). I had tried changing the beacon interval in my router but it didn't seem to work. Right now I need more testing, I've tried switching my bandwidth to 20mhz and changed to a less congested channel (there's a network hogging up a lot of channels). I've also changed my mode to 802.11ac only to see if that had any solution.

As of now it seems stable but I can't confirm it and it needs more testing. Sometimes it seems very stable for a while to later stop working.

1 Like

Well at least that's encouraging that you've had some improvement. Thanks for letting us know your progress. Keep us informed on how other fixes go.

2 Likes