[RTL8822BE] Wifi slow-not working

So i have a problem with the wifi on linux, wifi in general is pretty fast but on garuda linux its super slow or not working at all. Would appreciate help.
Specs:

System: Kernel: 5.11.11-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=95d310df-554c-4c78-b72f-64c2db496098
rw rootflags=subvol=@ quiet splash rd.udev. Log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.21.3 tk: QC 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine: Type: Laptop System: ASUSTeK product: VivoBook ASUSLaptop X512DA_X512DA v: 1.0 serial: <filter>
Mobo: ASUSTeK model: X512DA v: 1.0 serial: <filter> UEFI: American Megatrends v: X512DA.313
date: 08/24/2020
Battery: ID-1: BATO charge: 34.3 Wh (97.4%) condition: 35.2/37.1 Wh (94.9%) volts: 7.8 min: 7.8
model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Discharging cycles: 83
CPU: Info: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx bits: 64 type: MT MCP
arch: Zen/Zen+ note: check family: 17 (23) model-id: 18 (24) stepping: 1 microcode: 8108102
cache: L2: 2 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 sm bogomips: 33538
Speed: 1402 MHz min/max: 1400/2100 MHz boost: enabled core speeds (MHz): 1: 1402 2: 1913
3: 1821 4: 2044 5: 2395 6: 2392 7: 1197 8: 1264
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics: Device-1: AMD Picasso vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 03:00.0
chip-ID: 1002:15d8 class-ID: 0300
Device-2: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus-ID: 3-2.2:5
chip-ID: 13d3:56dd class-ID: DE02 serial: «filter>
Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: amdgpu,ati
unloaded: modesetting alternate: fbdev, vesa display-ID: : screens: 1
Screen-1: s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.40.0 5.11.11-zen1-1-zen LLVM 11.1.0)
V: 4.6 Mesa 21.0.1 direct render: Yes
Audio: Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel v: kernel
bus-ID: 03:00.1 chip-ID: 1002: 15de class-ID: 0403
Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor driver: snd_pci_acp3x v: kernel
alternate: snd_rn_pci_acp3x bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.11.11-zen1-1-zen running: yes
Sound Server-2: JACK V: 0.125.0 rurning: no
Sound Server-3: PulseAudio v: 14.2 running: yes
Sound Server-4: PipeWire v: 0.3.24 running: no
Network: Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: AzureWave driver: rtw_8822be
V: N/A modules: rtw88_8822be port: f000 bus-ID: 01:00.0 chip-ID: 10ec:b822 class-ID: 0280
IF: wlp1so state: up mac: ilter
Bluetooth: Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 3-2.1:4
chip-ID: 13d3:3526 class-ID: 2001 serlal: <filter>
Report: ID: hci0 state: up address: <fllter>
Drives: Local Storage: total: 476.94 GiB used: 17.34 GLB (3.6%)
SMART Message: Unable to run smartctl. Root privileges required
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: OM8PCP3512F-AB size: 476.94 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD
serial: <filter> rev: ECFK52.3 temp: 39.9 C scheme: GPT
Partition: ID-1: / raw-size: 100 GiB size: 100 GiB (100.00%) used: 17.32 GiB (17.3%) fs: btrfs
dev: /dev/nvmen1p4 maj-min: 259:4
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 25.8 MiB (10.1%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 100 GiB size: 100 GiB (100.00%) used: 17.32 GiB (17.3%) fs: btrfs
dev: /dev/nvme0n1p4 maj-min: 259:4
ID-4: /var/Log raw-size: 100 GiB size: 100 GiB (100.00%) used: 17.32 GiB (17.3%) fs: btrfs
dev: /dev/nvme0n1p4 maj-min: 259:4
ID-5: /var/tmp raw-size: 100 GiB size: 100 GiB (100.00%) used: 17.32 GiB (17.3%) fs: btrfs
dev: /dev/nvme0n1p4 maj-min: 259:4
Swap: Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: zram size: 743. 1 MiB used: @ KiB (0.0%) priority: 32767 dev: /dev/zramo
ID-2: swap-2 type: zram size: 743.1 MiB used: @ KiB (0.6%) priority: 32767 dev: /dev/zram1
ID-3: swap-3 type: zram size: 743.1 MiB used: @ KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-4: swap-4 type: zram size: 743.1 MiB used: @ KiB (0.0%) priority: 32767 dev: /dev/zram3
ID-5: swap-5 type: zram size: 743.1 MiB used: @ KiB (0.0%) priority: 32767 dev: /dev/zram4
ID-6: swap-6 type: zram size: 743. 1 MiB used: @ KLB (0.0%) priority: 32767 dev: /dev/zram5
ID-7: swap-7 type: zram size: 743.1 MiB used: @ KLB (0.0%) priority: 32767 dev: /dev/zramo
ID-8: swap-8 type: zram size: 743.1 MiB used: 0 kiB (0.0%) priority: 32767 dev: /dev/zram7
Sensors: System Temperatures: cpu: 51.0 C mobo: N/A gpu: amdgpu temp: 51.0 C
Fan Speeds (RPM): cpu: 2400
Info: Processes: 274 Uptime: 1m wakeups: 1 Memory: 5.81 GlB used: 1.54 GiB (26.6%) Init: systemd
v: 248 tool: systemctl Compilers: ecc: 10.2.0 clang: 11.1.0 Packages: pacman: 1626 lib: 504
Shell: fish v: 3.2.1 default: Zsh 5.8 running-in: konsole inxi: 3.3.0

I will use three ~ before and after post from now.

Search the forum for your wifi chip model and try suggestions given to others.
Read Garuda wiki on ways to find solutions and how to post new.

Hello,

First thing to do is to remove mac address randomization
Also, try searching for solutions. Here, I found a relevant one
https://bbs.archlinux.org/viewtopic.php?id=260589

And also try switching kernel.

1 Like

What do you mean "in general" ?

Which is it, and in what way?

Slow to do what?

Not working how?

1 Like

In general i mean that it works fast everythere except for garuda linux. By slow i mea i get 900B/s and if im lucky 1kb/s, but usually its just on 0B/s. This might be out of the topic but i just downloaded Manjaro Linux to see if it would work there, well it doesnt work on Manjaro either.

Im just confused right now, it works perfectly on windows.

And yet:

So not "everywhere except Garuda" then?

When doing what?

So am I, I have the exact same wifi chipset in my laptop and it works perfectly.

You could try what Naman suggested above, or try moving your laptop closer to your AP, or look at the AP settings, etc. etc.

1 Like

Its super slow even when im not running anything, as i said it works on windows but when i tried garuda, manjaro, didnt work on those, so it might be because of dual boot, otherwise i have no idea but its like 2days now how im trying to fix this...

You might try the suggestions already posted, then feed back about what you tried and what the effect was.

1 Like

Ive tried what Naman said, except for swithing kernel, idk how to do that, nothing worked btw

It is preferred you do not open multiple posts on the same topic on the forum.

I would have unlocked your thread, but I only just woke up. I'm pretty good at multi tasking, but not so much when I'm sleeping.

Generalizations are generally unhelpful. By which method did you disable MAC Address randomization.

The forum has lots of information on installing new kernels. You can install kernels through the Garuda GUI for managing your hardware. Also be sure to install the corresponding headers.

This can be done in the terminal as well.:

sudo pacman -Syu linux-next-git linux-next-git-headers

or:

sudo pacman -Syu linux-mainline linux-mainline-headers

Or:

sudo pacman -Syu linux linux-headers

Or:

sudo pacman -Syu linux-lts linux-lts-headers

You switch kernels at the advanced grub menu when you reboot. Multiple kernels can be installed at the same time with Garuda.

3 Likes

Sorry for making another thread just didnt know that you were sleeping, i think i changed it in some settings or something, cant remember whether it was a command or settings, im tired xd.

Oh and how do i pm an admin?

Install this driver (then reboot):

rtw88-dkms-git

You no longer need to PM a mod for the thread to be reoped now.

1 Like

The driver didnt change anything and i dont think i can install a kernel cause even with my phone usb sharing wifi i get like 5KiB/s, so it would take about 5hrs to install, after like 5minutes when the connection drops to 0Bit/s, it stops downloading...

I appreciate all the help you tried to gave me but i dont think its possible in anyway to fix this. Everysingle time i download any linux on any pc, something bad happens with it. Oh well, look how lucky i am.

Back to windows :frowning:

If USB Android tethering is also slow, then it is possible the problem lies elsewhere. Have you thought to reboot both your router and computer?

Kernels packages and the headers may be downloaded and installed offline.

1 Like

I rebooted my router 2 times and my computer? Well i rebooted it at least 10 times today soo i have no clue whats the problem, on windows it was faaaast, so it cant be that theres something wrong with the pc itself.

But i dont think ive seen a single thread that had the exact same problem. I really like linux, this distro especially but i dont think ill figure this out, man...

5KiB/s while doing what ?

The wifi adapter itself works fine (proven by my own laptop). Can you also replicate this issue using an Ethernet connection?

There are also options you could test for your wifi driver. However, I'm not going to waste my time troubleshooting an issue with a user who has already made it clear they will simply give up and waste my time.

Linux is clearly not for you if you have no desire to troubleshoot your own problems.

Give my regards to Bill.

1 Like

Thats not what i meant at all. I just dont want to waste your time and be annoying with this because its been 2 days, and i cant fix it yet, and yes i do want to but i dont know how and i dont know if its even doable.

Wait a minute, where did you check your internet speed? On which website?

Guys, I've got this. Had the exact same problems (I do every single time I install Garuda) and because your system is so damn similar to my own machine (Lenovo Ideapad 14ADA015) I'm going to tell you what I had to do.

I had to get my network adapter to stop falling asleep. And from looking at your own card model and how similar your system is to mine I think you've got the same problem.

If I'm right then this is what you can do -

First, you need to get ahold of yay:

#1. sudo pacman -S yay

Then you need to get the following:

#2. Get:

yay -S linux-firmware-git sparrow-wifi-git -y

#3. You're now going to apply the following changes to your settings:

Under the Garuda Welcome Launcher click on 'Advanced Network Settings' and make sure that your WiFi isn't set to sleep.

Then, look for your system settings and load that.

Under the Connection option check your Wifi settings and make sure your network isn't set to the 'metered' option. Make sure your system can re-connect if there's any interruption, etc.

Then, under 'Power Savings' you have to have it set to where your PC won't sleep and that your WiFi will always be on.

The settings for that tidbit on WiFi are at the bottom of the power savings settings for your laptop when it is on AC Power / plugged in / unplugged / at low levels (or something like that.

You'll have three tabs, and at the bottom of each you'll see options to change the option from 'leave unchanged' to 'always on'.

There should be (in the very same settings page) a section after that where you can define special behavior. You'll want to make sure your system is set to never go to sleep or to shut down. It is the second option.

I had to take notes on this and it took me several days to get my system working so try these and tell me if it works. Use the Sparrow Wifi tool (you can find it under your applications menu after downloading it) to check your signal.

Tell me if you need more help.

3 Likes