Garuda Linux, Wifi Problem

Edit: i uploaded the image

Hey yall, so I just installed Garuda Linux yesterday and i really like it but im having a problem with wifi.

Before you ask, yes i have seen the other threads, in fact ive tried everything in them, i dont think theres a thread about it that i havent tried.

Anyway, i made a dual boot, windows10 with garuda linux, my wifi is pretty fast and works good in general but on garuda linux its very slow (1kb/s~) or not working at all. Ive tried reinstalling the OS just in case but the same problem occured.

I have no clue whats left to do, ive been trying to fix this for about 4hours now and its frustrating. Can someone please help?


Theres something i suspect, could the open source drivers be the problem? On the installation i chose "Open source drivers"

Edit: which part dont you understand of what i said? I tried using the ethernet from my phone which didnt work either, you want me to just write down all of that text to my phone????

Edit: ive made a text from a photo to txt converter, checked the text. And no im not a troll, i know i can sometimes be annoying tho.


System: Kernel: 5.11.11-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=95d310df-554c-4c78-b72f-64c2db496098
rw rootflags=subvol=@ quiet splash rd.udev. Log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.21.3 tk: QC 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine: Type: Laptop System: ASUSTeK product: VivoBook ASUSLaptop X512DA_X512DA v: 1.0 serial:
Mobo: ASUSTeK model: X512DA v: 1.0 serial: UEFI: American Megatrends v: X512DA.313
date: 08/24/2020
Battery: ID-1: BATO charge: 34.3 Wh (97.4%) condition: 35.2/37.1 Wh (94.9%) volts: 7.8 min: 7.8
model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Discharging cycles: 83
CPU: Info: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx bits: 64 type: MT MCP
arch: Zen/Zen+ note: check family: 17 (23) model-id: 18 (24) stepping: 1 microcode: 8108102
cache: L2: 2 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 sm bogomips: 33538
Speed: 1402 MHz min/max: 1400/2100 MHz boost: enabled core speeds (MHz): 1: 1402 2: 1913
3: 1821 4: 2044 5: 2395 6: 2392 7: 1197 8: 1264
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics: Device-1: AMD Picasso vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 03:00.0
chip-ID: 1002:15d8 class-ID: 0300
Device-2: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus-ID: 3-2.2:5
chip-ID: 13d3:56dd class-ID: DE02 serial: «filter>
Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: amdgpu,ati
unloaded: modesetting alternate: fbdev, vesa display-ID: : screens: 1
Screen-1: s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.40.0 5.11.11-zen1-1-zen LLVM 11.1.0)
V: 4.6 Mesa 21.0.1 direct render: Yes
Audio: Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel v: kernel
bus-ID: 03:00.1 chip-ID: 1002: 15de class-ID: 0403
Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor driver: snd_pci_acp3x v: kernel
alternate: snd_rn_pci_acp3x bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.11.11-zen1-1-zen running: yes
Sound Server-2: JACK V: 0.125.0 rurning: no
Sound Server-3: PulseAudio v: 14.2 running: yes
Sound Server-4: PipeWire v: 0.3.24 running: no
Network: Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: AzureWave driver: rtw_8822be
V: N/A modules: rtw88_8822be port: f000 bus-ID: 01:00.0 chip-ID: 10ec:b822 class-ID: 0280
IF: wlp1so state: up mac: ilter
Bluetooth: Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 3-2.1:4
chip-ID: 13d3:3526 class-ID: 2001 serlal:
Report: ID: hci0 state: up address:
Drives: Local Storage: total: 476.94 GiB used: 17.34 GLB (3.6%)
SMART Message: Unable to run smartctl. Root privileges required
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: OM8PCP3512F-AB size: 476.94 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD
serial: rev: ECFK52.3 temp: 39.9 C scheme: GPT
Partition: ID-1: / raw-size: 100 GiB size: 100 GiB (100.00%) used: 17.32 GiB (17.3%) fs: btrfs
dev: /dev/nvmen1p4 maj-min: 259:4
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 25.8 MiB (10.1%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 100 GiB size: 100 GiB (100.00%) used: 17.32 GiB (17.3%) fs: btrfs
dev: /dev/nvme0n1p4 maj-min: 259:4
ID-4: /var/Log raw-size: 100 GiB size: 100 GiB (100.00%) used: 17.32 GiB (17.3%) fs: btrfs
dev: /dev/nvme0n1p4 maj-min: 259:4
ID-5: /var/tmp raw-size: 100 GiB size: 100 GiB (100.00%) used: 17.32 GiB (17.3%) fs: btrfs
dev: /dev/nvme0n1p4 maj-min: 259:4
Swap: Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: zram size: 743. 1 MiB used: @ KiB (0.0%) priority: 32767 dev: /dev/zramo
ID-2: swap-2 type: zram size: 743.1 MiB used: @ KiB (0.6%) priority: 32767 dev: /dev/zram1
ID-3: swap-3 type: zram size: 743.1 MiB used: @ KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-4: swap-4 type: zram size: 743.1 MiB used: @ KiB (0.0%) priority: 32767 dev: /dev/zram3
ID-5: swap-5 type: zram size: 743.1 MiB used: @ KiB (0.0%) priority: 32767 dev: /dev/zram4
ID-6: swap-6 type: zram size: 743. 1 MiB used: @ KLB (0.0%) priority: 32767 dev: /dev/zram5
ID-7: swap-7 type: zram size: 743.1 MiB used: @ KLB (0.0%) priority: 32767 dev: /dev/zramo
ID-8: swap-8 type: zram size: 743.1 MiB used: 0 kiB (0.0%) priority: 32767 dev: /dev/zram7
Sensors: System Temperatures: cpu: 51.0 C mobo: N/A gpu: amdgpu temp: 51.0 C
Fan Speeds (RPM): cpu: 2400
Info: Processes: 274 Uptime: 1m wakeups: 1 Memory: 5.81 GlB used: 1.54 GiB (26.6%) Init: systemd
v: 248 tool: systemctl Compilers: ecc: 10.2.0 clang: 11.1.0 Packages: pacman: 1626 lib: 504
Shell: fish v: 3.2.1 default: Zsh 5.8 running-in: konsole inxi: 3.3.03

If you had read every other wifi post as you've claimed then you should know the first thing required to diagnose your issue is the hardware specs involved.

Our forum guidelines for technical help requests require you to post your specs via the inxi command as stipulated on the Garuda Wiki.

Please read the Garuda Wiki entry on "reporting bugs" and follow its instructions.

Once you are ready to provide the required information edit your initial post to include your inxi output (as text, no pics).

Thank you.

Hi there, and welcome to Garuda.


Hi there!

As said above, post inxi to get help.
Also, you can pm any admin if you want thread to be reopened.

1 Like

Are you deliberately trolling, what part about "as text, no pics" was unclear.

You edited you post, only to do the opposite of as requested.

There are alternate ways to get a working internet connection to post your inxi output as text. You can use Ethernet or Android USB phone tethering to get a working connection to upload proper textual outputs.