RTL8821CE WiFi - How to fix very slow connection

ok so my internet is good for windows but in linux isbad as hell what can i do

First follow the template and post your garuda-inxi output as text.

4 Likes

Can you please describe it briefly and post garuda-inxi

2 Likes

what is garuda inxi

Type in your terminal this

garuda-inxi 

And post its output

You must start reading and not just delete it.

Post your terminal/konsole in- and output as text (no pictures) from:

garuda-inxi

Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

Before you open a new help request, read relevant sections of the Arch and Garuda wiki.
Thoroughly search your issue and any error messages in the forum and on the web.

Report everything you have already attempted to solve your problem.


1 Like

i cant copy paste trough diferent platforms

my linux internet is so bad i cant even do anything so ic ant paste it ;-;

So how are you doing conversation with us ?
If you don't feel any necessacity of giving garuda-inxi but still it's important for us to know many things

And one more question
You have written in your profile 'other OS' so do you really use garuda? :thinking:

1 Like

I have never noticed any difference in terms of speed (win/garuda).
Without your data from the garuda-inxi, no one here can help you.

1 Like

ok let me use garuda and try signing in to here

ello its me

System:
Kernel: 5.16.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=e63ed1c6-c492-4e65-8080-2535bd6dfc59 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=a08e6a87-2d0e-4791-9c4a-bf1d99641ed3 loglevel=3
Desktop: KDE Plasma 5.24.2 tk: Qt 5.15.3 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: LENOVO product: F0EB00DFID v: ideacentre A340-22IWL
serial: <superuser required> Chassis: type: 13 serial: <superuser required>
Mobo: LENOVO model: 370B v: SDK0Q55754 WIN 3273516960883
serial: <superuser required> UEFI: LENOVO v: O4JKT20A date: 11/24/2020
CPU:
Info: model: Intel Core i3-10110U bits: 64 type: MT MCP
arch: Comet/Whiskey Lake note: check family: 6 model-id: 0x8E (142)
stepping: 0xC (12) microcode: 0xEC
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 3535 high: 3718 min/max: 400/4100 scaling:
driver: intel_pstate governor: performance cores: 1: 3552 2: 3283 3: 3718
4: 3590 bogomips: 20799
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds mitigation: TSX disabled
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: Lenovo driver: i915
v: kernel ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0
chip-ID: 8086:9b41 class-ID: 0300
Device-2: Syntek Integrated Camera type: USB driver: uvcvideo
bus-ID: 1-6:3 chip-ID: 174f:2425 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: intel unloaded: modesetting alternate: fbdev,vesa gpu: i915
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: eDP1 mapped: eDP-1 model: Lenovo LEN-A340W-C-A
serial: <filter> built: 2018 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
size: 480x260mm (18.9x10.2") diag: 546mm (21.5") ratio: 16:9
modes: 1920x1080
OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.3.7
direct render: Yes
Audio:
Device-1: Intel Comet Lake PCH-LP cAVS vendor: Lenovo driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:02c8 class-ID: 0403
Sound Server-1: ALSA v: k5.16.12-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
vendor: Lenovo driver: rtw_8821ce v: N/A modules: rtw88_8821ce pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 4000 bus-ID: 01:00.0 chip-ID: 10ec:c821
class-ID: 0280
IF: wlp1s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Bluetooth:
Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 1-10:5 chip-ID: 0bda:c024 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 1.16 TiB used: 13.03 GiB (1.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: A-Data model: SX8200PNP
size: 238.47 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 32B3T8EA
temp: 42.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ04ABF100
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 0E scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: SanDisk model: USB 3.2Gen1
size: 14.32 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 51.23 GiB size: 51.23 GiB (100.00%)
used: 13.03 GiB (25.4%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
ID-2: /boot/efi raw-size: 350 MiB size: 349.3 MiB (99.80%)
used: 580 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p5 maj-min: 259:5
ID-3: /home raw-size: 51.23 GiB size: 51.23 GiB (100.00%)
used: 13.03 GiB (25.4%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
ID-4: /var/log raw-size: 51.23 GiB size: 51.23 GiB (100.00%)
used: 13.03 GiB (25.4%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
ID-5: /var/tmp raw-size: 51.23 GiB size: 51.23 GiB (100.00%)
used: 13.03 GiB (25.4%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 15.81 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p6 maj-min: 259:6
ID-2: swap-2 type: zram size: 7.57 GiB used: 1.2 MiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 96.0 C pch: 67.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 221 Uptime: 0m wakeups: 0 Memory: 7.57 GiB
used: 1.98 GiB (26.2%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: pacman: 1682 lib: 508 Shell: fish v: 3.3.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.13
Garuda (2.5.5-1):
System install date:     2022-03-29
Last full system update: 2022-03-29
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

there its my --garuda-inxi--

Try checking your speed at speedtest.net and if it's what it should be then you may need to change your repository mirrors. If not, then it's probably your equipment or an ISP issue.

another solution?

with teminal?

Please don't post here like in chat, this is a forum.

This is a web address and must be executed in the browser, regardless of whether it is in Windows or Linux.

1 Like

ok ima do it

Here's the full meal deal on how to correct issues with the RTL8821CE WiFi adapter.



Disable Wifi power saving:

You can disable Network Manager's power saving features by creating /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf with the following command::

sudo touch /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Add the following contents to the newly created conf file with your preferred text editor:

[connection]
wifi.powersave = 0

Alternately, you can run the following command to generate the required conf file automatically:

echo -e "[connection]\nwifi.powersave = 0" | sudo tee /etc/modprobe.d/rtl8821ce.conf

Then restart Network Manager, or reboot.


Install the rtw88-dkms-git driver from the Chaotic AUR.

If you have already installed any other driver version, then uninstall that driver before proceeding. Once the driver has been uninstalled, then install the rtw88-dkms-git Chaotic AUR driver with the following command:

sudo  pacman -Syu rtw88-dkms-git

Then reboot.


Create /etc/modprobe.d/rtl8821ce.conf:

sudo touch /etc/modprobe.d/rtl8821ce.conf

Add the following contents to the newly created conf file with your preferred text editor:

options rtw_pci disable_aspm=1
blacklist rtw88_8821ce

Alternately, you can run the following command to generate the required conf file automatically:

echo -e "options rtw_pci disable_aspm=1\nblacklist rtw88_8821ce" | sudo tee /etc/modprobe.d/rtl8821ce.conf

Then reboot.


Add the pci=noaer kernel parameter to grub.

First, backup your grub config file:

sudo cp /etc/default/grub /etc/default/grub.bak 

Then edit /etc/default/grub and add pci=noaer to the end of the following line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 pci=noaer"

After adding the boot parameter and saving your changes, run:

sudo update-grub 

Reboot


Alternately, run the following command to automatically add the pci=noaer boot parameter to /etc/default/grub:

sudo cp /etc/default/grub /etc/default/grub.bak && sudo sed '/^GRUB_CMDLINE_LINUX_DEFAULT=/s/"$/ pci=noaer"/g' -i /etc/default/grub

After adding the boot parameter(s), run:

sudo update-grub 

Reboot.


If the change does not improve your issue you can restore the grub file to its original state with:

sudo cp /etc/default/grub.bak /etc/default/grub

After restoring the file, again run:

sudo update-grub 

Then reboot again.


8 Likes

It has been over 2 weeks since the OP responded. This thread is deemed abandoned.

Please do not leave threads dangling in the future.

Thread closed.

2 Likes